summaryrefslogtreecommitdiffstats
path: root/main/dahdi-linux-grsec/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-25 06:58:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-25 07:02:24 +0000
commitf3a4453eccb53fb90453a2659ec7c42efe33e33a (patch)
treee320b65c3288831ec8dd1e0ea6ace7bc45707eb6 /main/dahdi-linux-grsec/APKBUILD
parenta65729e98beca8b113b3d5e2f6c31dcb656d70c3 (diff)
downloadaports-f3a4453eccb53fb90453a2659ec7c42efe33e33a.tar.bz2
aports-f3a4453eccb53fb90453a2659ec7c42efe33e33a.tar.xz
main/dahdi-linux-grsec: upgrade to 2.5.0.2 and enable constify plugin
Diffstat (limited to 'main/dahdi-linux-grsec/APKBUILD')
-rw-r--r--main/dahdi-linux-grsec/APKBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/dahdi-linux-grsec/APKBUILD b/main/dahdi-linux-grsec/APKBUILD
index 0bc20dda3..97e3c95fb 100644
--- a/main/dahdi-linux-grsec/APKBUILD
+++ b/main/dahdi-linux-grsec/APKBUILD
@@ -16,8 +16,8 @@ _realname=dahdi-linux
pkgname=${_realname}-${_flavor}
pkgver=$pkgver
# when chaning _dahdiver we *must* bump _mypkgrel
-_dahdiver=2.5.0.1
-_mypkgrel=1
+_dahdiver=2.5.0.2
+_mypkgrel=2
pkgrel=$(( $_kpkgrel + $_mypkgrel ))
pkgdesc="Digium Asterisk Hardware Device Interface drivers $_dahdiver"
url="http://www.asterisk.org"
@@ -37,6 +37,7 @@ source="http://downloads.digium.com/pub/telephony/dahdi-linux/releases/${_realna
zaphfc-dahdi-flortz.diff
zaphfc-dahdi-2.4.0.patch
zaphfc-dahdi-2.5.0.patch
+ constify.patch
"
prepare() {
@@ -54,13 +55,13 @@ prepare() {
build() {
cd "$srcdir/$_realname-$_dahdiver"
export GCC_SPECS=/usr/share/gcc/hardenednopie.specs
- make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" CONSTIFY_PLUGIN= \
+ make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
|| return 1
}
package() {
cd "$srcdir/$_realname-$_dahdiver"
- make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" CONSTIFY_PLUGIN= \
+ make KVERS="${_abi_release}" DYNFS="yes" MODULES_EXTRA="zaphfc" \
DESTDIR="$pkgdir" install-modules || return 1
rm -rf "$pkgdir"/lib/firmware "$pkgdir"/usr/lib/hotplug/firmware \
"$pkgdir"/usr/include
@@ -77,11 +78,12 @@ dev() {
ln -s /usr/include "$dir"/include
}
-md5sums="d7efc5ebc9bf81a5263321e5e9891fc1 dahdi-linux-2.5.0.1.tar.gz
+md5sums="037afa01dfde872c6b4864699483e199 dahdi-linux-2.5.0.2.tar.gz
c78fb8d80f9efdffd950297c88ff9273 dahdi-depmod.patch
3bb419ac598534cd4ad5248f23656001 dahdi-bri_dchan.patch
9088ee5cd24f94b7f90c24e5ed6071e0 dahdi-2.5.0-bri-fixes.patch
c6308ea8aaafba0a9d7f9825d7c9dcf8 dahdi-zaphfc.patch
035a6d91b2fb56a9b76a60a2e494fe9e zaphfc-dahdi-flortz.diff
0fdcd8c8c93bc1fe33c0af12b6cc6b05 zaphfc-dahdi-2.4.0.patch
-9ed23321512274c6c5c5b76af0411e38 zaphfc-dahdi-2.5.0.patch"
+9ed23321512274c6c5c5b76af0411e38 zaphfc-dahdi-2.5.0.patch
+15fd0337d9e592f2f1829770c2e69c86 constify.patch"