summaryrefslogtreecommitdiffstats
path: root/main/dev86
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-10 07:53:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-10 07:53:33 +0000
commit494084ad2f34aaee8cf08eea0fe85b53d7250c30 (patch)
tree977376fd3f337760956c5113bdfc504d492ae73e /main/dev86
parentb55fa1b2c5c3a28bd2cead7326f4555b1d9f93b4 (diff)
downloadaports-494084ad2f34aaee8cf08eea0fe85b53d7250c30.tar.bz2
aports-494084ad2f34aaee8cf08eea0fe85b53d7250c30.tar.xz
main/dev86: build fix for x86_64
Diffstat (limited to 'main/dev86')
-rw-r--r--main/dev86/APKBUILD4
-rw-r--r--main/dev86/dev86-long.patch21
2 files changed, 24 insertions, 1 deletions
diff --git a/main/dev86/APKBUILD b/main/dev86/APKBUILD
index 7a7735812..43a60d22f 100644
--- a/main/dev86/APKBUILD
+++ b/main/dev86/APKBUILD
@@ -15,6 +15,7 @@ source="http://www.debath.co.uk/dev86/Dev86src-$pkgver.tar.gz
dev86-noelks.patch
dev86-pic.patch
dev86-print-overflow.patch
+ dev86-long.patch
"
_builddir="$srcdir"/dev86-$pkgver
@@ -74,4 +75,5 @@ package() {
md5sums="442e98e1afa23fe00d40c5a996385942 Dev86src-0.16.19.tar.gz
eba7081bc5dbd72b7b9b902275251499 dev86-noelks.patch
d508a2a8ededa9e34dbd9105dfd66290 dev86-pic.patch
-7ce097efcb8c043727b4b3bf6c396c75 dev86-print-overflow.patch"
+7ce097efcb8c043727b4b3bf6c396c75 dev86-print-overflow.patch
+95e9df3245d46a02154fbe2f8b907782 dev86-long.patch"
diff --git a/main/dev86/dev86-long.patch b/main/dev86/dev86-long.patch
new file mode 100644
index 000000000..9e7e1f0d8
--- /dev/null
+++ b/main/dev86/dev86-long.patch
@@ -0,0 +1,21 @@
+--- ./ld/x86_aout.h.orig
++++ ./ld/x86_aout.h
+@@ -11,17 +11,12 @@
+ /* If the host isn't an x86 all bets are off, use chars. */
+ #if defined(i386) || defined(__BCC__) || defined(MSDOS)
+ typedef long Long;
+-#define __OUT_OK 1
+ #else
+ /* Beware: this will probably allow some BE hosts to generate broken files. */
+-#ifdef INT32_MAX
+ #include <stdint.h>
+ typedef int32_t Long;
+-#define __OUT_OK 1
+-#else
+-typedef char Long[4];
+ #endif
+-#endif
++#define __OUT_OK 1
+
+ struct exec { /* a.out header */
+ unsigned char a_magic[2]; /* magic number */