summaryrefslogtreecommitdiffstats
path: root/main/dosfstools
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-14 08:14:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-14 08:14:56 +0000
commitb94c4b3f2a25f734c5d1613de6770d237c5beebd (patch)
treef39b317adb5e96500225d8e1d039298843793307 /main/dosfstools
parentcdc3d5f876e9dfbe222c3a09887ac5e9ec680d50 (diff)
downloadaports-b94c4b3f2a25f734c5d1613de6770d237c5beebd.tar.bz2
aports-b94c4b3f2a25f734c5d1613de6770d237c5beebd.tar.xz
main/dosfstools: build fix for musl
copied from sabotage linux
Diffstat (limited to 'main/dosfstools')
-rw-r--r--main/dosfstools/APKBUILD17
-rw-r--r--main/dosfstools/dosfstools-loff_and_BLOCK_SIZE.patch31
2 files changed, 42 insertions, 6 deletions
diff --git a/main/dosfstools/APKBUILD b/main/dosfstools/APKBUILD
index d1bab20c5..0b9a5e728 100644
--- a/main/dosfstools/APKBUILD
+++ b/main/dosfstools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dosfstools
pkgver=3.0.24
-pkgrel=0
+pkgrel=1
pkgdesc="DOS filesystem utilities"
url="http://www.daniel-baumann.ch/software/dosfstools/"
arch="all"
@@ -9,10 +9,12 @@ license="GPL3+"
depends=""
makedepends="libiconv-dev"
subpackages="$pkgname-doc"
-source="http://daniel-baumann.ch/files/software/dosfstools/dosfstools-$pkgver.tar.xz"
+source="http://daniel-baumann.ch/files/software/dosfstools/dosfstools-$pkgver.tar.xz
+ dosfstools-loff_and_BLOCK_SIZE.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
-build() {
+build() {
cd "$_builddir"
make OPTFLAGS="$CFLAGS" LDFLAGS="-liconv $LDFLAGS" || return 1
}
@@ -26,6 +28,9 @@ package() {
install || return 1
}
-md5sums="41931f36ebee6e79e9dafe85cc916f2b dosfstools-3.0.24.tar.xz"
-sha256sums="1e21b7e7c8872fb3debf2a7fdc8c223a5f592a6efa8ae181a92f558ed28274c1 dosfstools-3.0.24.tar.xz"
-sha512sums="9e75e3868f42d4cb404998e8a0cd7d3bc7fe4fc0cf68559644c960fe73e7f0eb67c26ff169085c9e1858e5402efed813b883a5f3682aea29e4d0fc9c9142a006 dosfstools-3.0.24.tar.xz"
+md5sums="41931f36ebee6e79e9dafe85cc916f2b dosfstools-3.0.24.tar.xz
+66da181b7245895aac09f51902dcedcb dosfstools-loff_and_BLOCK_SIZE.patch"
+sha256sums="1e21b7e7c8872fb3debf2a7fdc8c223a5f592a6efa8ae181a92f558ed28274c1 dosfstools-3.0.24.tar.xz
+f9d313d3204c5b2b2a9a9ccb2906cd29aa17f66daa710c8f3358adc6e081479d dosfstools-loff_and_BLOCK_SIZE.patch"
+sha512sums="9e75e3868f42d4cb404998e8a0cd7d3bc7fe4fc0cf68559644c960fe73e7f0eb67c26ff169085c9e1858e5402efed813b883a5f3682aea29e4d0fc9c9142a006 dosfstools-3.0.24.tar.xz
+7d36320e31502fb977f8f589b0b35a7c4b9358e08bd77852f516a0421a60ebce9190134d22f0d857146de701b1c5655e62b8ae643f87d9e8a09cc41b1fdf742c dosfstools-loff_and_BLOCK_SIZE.patch"
diff --git a/main/dosfstools/dosfstools-loff_and_BLOCK_SIZE.patch b/main/dosfstools/dosfstools-loff_and_BLOCK_SIZE.patch
new file mode 100644
index 000000000..6c5d6c7d2
--- /dev/null
+++ b/main/dosfstools/dosfstools-loff_and_BLOCK_SIZE.patch
@@ -0,0 +1,31 @@
+--- src/fsck.fat.h
++++ src/fsck.fat.h
+@@ -27,6 +27,7 @@
+ #ifndef _DOSFSCK_H
+ #define _DOSFSCK_H
+
++#include <fcntl.h>
+ #include <sys/types.h>
+ #define _LINUX_STAT_H /* hack to avoid inclusion of <linux/stat.h> */
+ #define _LINUX_STRING_H_ /* hack to avoid inclusion of <linux/string.h> */
+--- src/io.h
++++ src/io.h
+@@ -27,7 +27,7 @@
+ #ifndef _IO_H
+ #define _IO_H
+
+-#include <sys/types.h> /* for loff_t */
++#include <fcntl.h> /* for loff_t */
+
+ loff_t llseek(int fd, loff_t offset, int whence);
+
+--- src/mkfs.fat.c
++++ src/mkfs.fat.c
+@@ -49,6 +49,7 @@
+ #include <fcntl.h>
+ #include <linux/hdreg.h>
+ #include <sys/mount.h>
++#include <linux/fs.h>
+ #include <linux/fd.h>
+ #include <endian.h>
+ #include <mntent.h>