summaryrefslogtreecommitdiffstats
path: root/main/exo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-12 14:57:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-12 14:57:55 +0000
commitd34fc40cfe2841590c41febcc6417050c93e4ad1 (patch)
treeb8e1ff9ab57ac7296bbb1151ce3db94bd312a252 /main/exo
parent22ab7c505929268d480f004ae3308ed21e55068a (diff)
downloadaports-d34fc40cfe2841590c41febcc6417050c93e4ad1.tar.bz2
aports-d34fc40cfe2841590c41febcc6417050c93e4ad1.tar.xz
main/exo: use claws-mail as default mail reader
we dont ship thunderbird
Diffstat (limited to 'main/exo')
-rw-r--r--main/exo/APKBUILD27
-rw-r--r--main/exo/mailreader-claws-mail.patch10
2 files changed, 32 insertions, 5 deletions
diff --git a/main/exo/APKBUILD b/main/exo/APKBUILD
index 117ef863c..26cb2c94f 100644
--- a/main/exo/APKBUILD
+++ b/main/exo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=exo
pkgver=0.10.2
-pkgrel=1
+pkgrel=2
pkgdesc="Extensions to Xfce by os-cillation"
url="http://www.os-cillation.com/article.php?sid=40"
arch="all"
@@ -11,10 +11,22 @@ depends="hicolor-icon-theme"
depends_dev="gtk+-dev libxfce4util-dev"
makedepends="$depends_dev libxfce4ui-dev perl perl-uri libnotify-dev gtk-doc"
install=
-source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ mailreader-claws-mail.patch
+ "
+
+_builddir="$srcdir"/exo-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,8 +41,13 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="c70f2a217811bfba2e62f938d4b8f748 exo-0.10.2.tar.bz2"
+md5sums="c70f2a217811bfba2e62f938d4b8f748 exo-0.10.2.tar.bz2
+3d9f7c0c3a411797fe8989ad0c75f69e mailreader-claws-mail.patch"
+sha256sums="b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce exo-0.10.2.tar.bz2
+f944ff99efb37e8848208f19ac8997e1494c2f70170c269b7c26a08c33945c94 mailreader-claws-mail.patch"
+sha512sums="91a5a7f7b893c427ef10ee6ce248a6b6f8e2aba4281e406a60bc8fe7fa50196eb79d8b0ad6609ab48371acf77425df8cb67124ab11b7c4ff08d1dc83bb180eae exo-0.10.2.tar.bz2
+957350c34b9209b89b051ccf9800f7d0e9ce580ad4161366bab0984d4d4d1f63d20bcb9fd5c22abffc0151c377a5bc7ad5c1b24b0183e997ebdd92ab61ee1c2b mailreader-claws-mail.patch"
diff --git a/main/exo/mailreader-claws-mail.patch b/main/exo/mailreader-claws-mail.patch
new file mode 100644
index 000000000..eb4cf0ebd
--- /dev/null
+++ b/main/exo/mailreader-claws-mail.patch
@@ -0,0 +1,10 @@
+--- ./exo-helper/helpers/helpers.rc.orig
++++ ./exo-helper/helpers/helpers.rc
+@@ -5,6 +5,6 @@
+ #
+
+ WebBrowser=firefox
+-MailReader=thunderbird
++MailReader=claws-mail
+ TerminalEmulator=xfce4-terminal
+ FileManager=Thunar