summaryrefslogtreecommitdiffstats
path: root/main/fcgi/configure.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-01 08:38:51 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-01 08:39:52 +0200
commit633e4398ed54ed55dd56fb077eb78a201db3fed7 (patch)
tree8b2d75b8eb71d0d27041f14cb47d83113ae6072d /main/fcgi/configure.patch
parent567c3b000adfddf8d6cd18aa282dfe3a31161e7c (diff)
downloadaports-633e4398ed54ed55dd56fb077eb78a201db3fed7.tar.bz2
aports-633e4398ed54ed55dd56fb077eb78a201db3fed7.tar.xz
main/fcgi: fix underlinking, build c++ lib
Diffstat (limited to 'main/fcgi/configure.patch')
-rw-r--r--main/fcgi/configure.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/main/fcgi/configure.patch b/main/fcgi/configure.patch
new file mode 100644
index 000000000..8ea19fb50
--- /dev/null
+++ b/main/fcgi/configure.patch
@@ -0,0 +1,28 @@
+diff --git a/configure.in b/configure.in
+index e1941d0..4780394 100755
+--- a/configure.in
++++ b/configure.in
+@@ -4,10 +4,12 @@ dnl This file is an input file used by the GNU "autoconf" program to
+ dnl generate the file "configure", which is run during the build
+ dnl to configure the system for the local environment.
+
+-AC_INIT
+-AM_INIT_AUTOMAKE(fcgi, 2.4.0)
++AC_INIT(fcgi, 2.4.0)
++AM_INIT_AUTOMAKE(1.9 foreign)
+
+-AM_CONFIG_HEADER(fcgi_config.h)
++AC_CONFIG_HEADERS(fcgi_config.h)
++
++AM_MAINTAINER_MODE
+
+ AC_PROG_CC
+ AC_PROG_CPP
+@@ -47,6 +49,7 @@ AC_LANG([C])
+
+ AC_CHECK_LIB([nsl], [gethostbyname])
+ AC_CHECK_LIB([socket], [socket])
++AC_SEARCH_LIBS(frexp, [m], [], [AC_MSG_ERROR([unable to find the frexp()]) ])
+
+ ACX_PTHREAD([THREADED=threaded${EXEEXT}])
+ AC_SUBST([THREADED])