summaryrefslogtreecommitdiffstats
path: root/main/firefox
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-04-09 09:01:14 +0300
committerTimo Teräs <timo.teras@iki.fi>2015-04-09 09:01:14 +0300
commit2917a804dc1053c78f84ac91441e4e0cf0853808 (patch)
tree08b591a8b6f681da6412df1c30ed1815ed9b9a69 /main/firefox
parent09a91e104ae245876aa575376bb0f4945e5c5757 (diff)
downloadaports-2917a804dc1053c78f84ac91441e4e0cf0853808.tar.bz2
aports-2917a804dc1053c78f84ac91441e4e0cf0853808.tar.xz
main/firefox: use paxmark
Diffstat (limited to 'main/firefox')
-rw-r--r--main/firefox/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/firefox/APKBUILD b/main/firefox/APKBUILD
index 4d385b2e5..7aa5a63b5 100644
--- a/main/firefox/APKBUILD
+++ b/main/firefox/APKBUILD
@@ -4,7 +4,7 @@ pkgname=firefox
pkgver=31.5.0
_pkgver=$pkgver
_xulver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="Firefox web browser"
url="https://www.mozilla.org/en-US/firefox/organizations/faq/"
arch="all"
@@ -41,7 +41,7 @@ makedepends="$depends_dev
automake
bsd-compat-headers
libtool
- paxctl
+ paxmark
python
sed
yasm
@@ -114,7 +114,7 @@ package() {
# only used for startupcache creation.
local paxflags="-msp"
- paxctl -c $paxflags */dist/bin/xpcshell || return 1
+ paxmark -c $paxflags */dist/bin/xpcshell || return 1
make -j1 -f client.mk install \
DESTDIR="$pkgdir" \
@@ -132,7 +132,7 @@ package() {
local paxflags="-mp"
[ "$CARCH" = "x86" ] && paxflags="-msp"
- paxctl -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1
+ paxmark -c $paxflags "$pkgdir"/$_mozappdir/firefox || return 1
# xulrunner stub launcher has changed to using a symlink overlay...
# go figure