summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2012-08-13 18:52:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-08-14 14:37:50 +0000
commitafee20a3ca5a67d4b19e725efaeff460cc55206f (patch)
tree2c182b9e37c997af26387acc0cbc6cdc9925eac5 /main/freeswitch
parent3bcd08518cd1761e1e8a4850b8ca711ebe4d67de (diff)
downloadaports-afee20a3ca5a67d4b19e725efaeff460cc55206f.tar.bz2
aports-afee20a3ca5a67d4b19e725efaeff460cc55206f.tar.xz
main/freeswitch: update to 1.2.0 release
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD38
-rw-r--r--main/freeswitch/freeswitch-mod_shout-textrels.patch2
-rw-r--r--main/freeswitch/modules.conf13
3 files changed, 19 insertions, 34 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 2d4718934..51b838db5 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,10 +1,9 @@
-# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Michael Mason <ms13sp@gmail.com>
+# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
-_snapshot=20120312
-pkgver=1.0.7_p${_snapshot}
-_commit=5e4a514531de2a1d8040c3d306a9e8de426de566
-pkgrel=5
+pkgver=1.2.0
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -15,12 +14,11 @@ pkggroups="freeswitch"
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
autoconf automake libtool libpri-dev bash net-snmp-dev postgresql-dev
libiconv-dev subversion flac-dev libogg-dev libvorbis-dev
- jpeg-dev sngtc_client-dev gnutls-dev"
+ jpeg-dev sngtc_client-dev gnutls-dev util-linux-dev"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-timezones
$pkgname-sample-config:conf $pkgname-freetdm $pkgname-sangoma"
-#hmm, saveas doesn't work with https...
-source="http://git.freeswitch.org/git/freeswitch/snapshot/$pkgname-$_commit.tar.bz2
+source="http://files.freeswitch.org/$pkgname-$pkgver.tar.bz2
freeswitch-mod_shout-textrels.patch
0002-mod_lua-alpine-module-search-path.patch
modules.conf
@@ -28,24 +26,8 @@ source="http://git.freeswitch.org/git/freeswitch/snapshot/$pkgname-$_commit.tar.
freeswitch.initd
"
-snapshot() {
- current_head=$(curl http://git.freeswitch.org/git/freeswitch/patch/ | head -n1 | cut -d" " -f2)
- current_snapshot=$(grep -e "^_snapshot=.*$" APKBUILD | cut -d"=" -f2)
- new_snapshot=$(date +"%Y%m%d")
- if [ "$current_snapshot" = "$new_snapshot" ]; then
- old_pkgrel=$(grep -e "^pkgrel=.*$" APKBUILD | cut -d"=" -f2)
- new_pkgrel=$(expr $old_pkgrel + 1 )
- else
- new_pkgrel=0
- fi
- sed -i "s/^_commit=.*$/_commit=$current_head/" APKBUILD
- sed -i "s/^pkgrel=.*$/pkgrel=$new_pkgrel/" APKBUILD
- sed -i "s/^_snapshot=.*$/_snapshot=$new_snapshot/" APKBUILD
- abuild fetch
- abuild checksum
-}
-_builddir="$srcdir/$pkgname-$_commit"
+_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
cd "$_builddir"
@@ -173,9 +155,9 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="8c0609c00039513a1a81eda685845b37 freeswitch-5e4a514531de2a1d8040c3d306a9e8de426de566.tar.bz2
-11883affe0839a8e15fe680aeb11b86e freeswitch-mod_shout-textrels.patch
+md5sums="81a6ba0cda70f78f8c36eb47cc564ba3 freeswitch-1.2.0.tar.bz2
+e3912aa52a4d8f8cb3b4e38c2668116d freeswitch-mod_shout-textrels.patch
769eaa127d4dbae687dc4aa961a8cc70 0002-mod_lua-alpine-module-search-path.patch
-1e6f8a9f18c9c332872cdc40065b76e3 modules.conf
+0a65c74e228ca4f00e8c856b16ffd642 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
54a929d16731df730de0cd5355ea3031 freeswitch.initd"
diff --git a/main/freeswitch/freeswitch-mod_shout-textrels.patch b/main/freeswitch/freeswitch-mod_shout-textrels.patch
index 7cc7e3fa7..06e561103 100644
--- a/main/freeswitch/freeswitch-mod_shout-textrels.patch
+++ b/main/freeswitch/freeswitch-mod_shout-textrels.patch
@@ -1,6 +1,6 @@
--- ./src/mod/formats/mod_shout/Makefile.orig
+++ ./src/mod/formats/mod_shout/Makefile
-@@ -30,7 +30,7 @@
+@@ -28,7 +28,7 @@
$(MPG123_BUILDDIR)/Makefile: $(MPG123_DIR)
mkdir -p $(MPG123_BUILDDIR)
diff --git a/main/freeswitch/modules.conf b/main/freeswitch/modules.conf
index 2911092d5..dcb5b40dd 100644
--- a/main/freeswitch/modules.conf
+++ b/main/freeswitch/modules.conf
@@ -1,6 +1,3 @@
-loggers/mod_console
-loggers/mod_logfile
-loggers/mod_syslog
#applications/mod_cidlookup
applications/mod_commands
applications/mod_conference
@@ -11,6 +8,7 @@ applications/mod_fifo
applications/mod_curl
applications/mod_db
applications/mod_hash
+applications/mod_httapi
#applications/mod_redis
applications/mod_voicemail
applications/mod_directory
@@ -22,6 +20,7 @@ applications/mod_fsv
#applications/mod_nibblebill
#applications/mod_soundtouch
#applications/mod_rss
+applications/mod_sms
applications/mod_spandsp
#applications/mod_snom
#applications/mod_vmd
@@ -54,6 +53,7 @@ codecs/mod_siren
#codecs/mod_opus
codecs/mod_sangoma_codec
#codecs/mod_dahdi_codec
+codecs/mod_vp8
#dialplans/mod_dialplan_directory
dialplans/mod_dialplan_xml
dialplans/mod_dialplan_asterisk
@@ -78,7 +78,7 @@ asr_tts/mod_flite
#asr_tts/mod_tts_commandline
#event_handlers/mod_event_multicast
event_handlers/mod_event_socket
-#event_handlers/mod_event_zmq
+event_handlers/mod_event_zmq
event_handlers/mod_cdr_csv
event_handlers/mod_cdr_sqlite
event_handlers/mod_cdr_pg_csv
@@ -91,7 +91,7 @@ formats/mod_shout
formats/mod_local_stream
formats/mod_tone_stream
#formats/mod_portaudio_stream
-#formats/mod_shell_stream
+formats/mod_shell_stream
#languages/mod_python
#languages/mod_spidermonkey
languages/mod_lua
@@ -99,6 +99,9 @@ languages/mod_lua
#languages/mod_yaml
#languages/mod_java
#languages/mod_managed
+loggers/mod_console
+loggers/mod_logfile
+loggers/mod_syslog
xml_int/mod_xml_rpc
xml_int/mod_xml_curl
xml_int/mod_xml_cdr