summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-21 14:55:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-21 14:57:46 +0000
commitcf4e9c8ef0d2909df977fd37fc958d923ec2c11f (patch)
tree39bf730ca6ecd4af81bcfb676ecf623013db37a1 /main/freeswitch
parent325b44c6346db54d7ec2dc236e3176bda3f0ad52 (diff)
downloadaports-cf4e9c8ef0d2909df977fd37fc958d923ec2c11f.tar.bz2
aports-cf4e9c8ef0d2909df977fd37fc958d923ec2c11f.tar.xz
main/freeswitch: fix default paths to be FHS compliant
fixes #4065
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/APKBUILD37
-rwxr-xr-xmain/freeswitch/freeswitch.initd6
2 files changed, 16 insertions, 27 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 308016480..06bd0179c 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
pkgver=1.4.18
-pkgrel=4
+pkgrel=5
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -43,7 +43,7 @@ makedepends="bash
autoconf automake libtool
"
install="$pkgname.pre-install $pkgname.pre-upgrade"
-subpackages="$pkgname-dbg $pkgname-dev $pkgname-flite $pkgname-timezones
+subpackages="$pkgname-dev $pkgname-flite $pkgname-timezones
$pkgname-sample-config:conf $pkgname-freetdm $pkgname-sangoma
$pkgname-snmp $pkgname-pgsql"
@@ -107,9 +107,8 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --sysconfdir=/etc/freeswitch \
- --with-modinstdir=/usr/lib/freeswitch \
- --with-rundir=/var/run/freeswitch \
+ --enable-fhs \
+ --with-scriptdir=/etc/freeswitch/scripts \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--with-devrandom=/dev/urandom \
@@ -127,28 +126,20 @@ build() {
}
package(){
cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+ make -j1 DESTDIR="$pkgdir" install samples-conf samples-htdocs \
+ || return 1
find "$pkgdir" -name '*.la' -delete
- # we need to do some moving/cleanup to allow some... kind of FHS
- mkdir -p "$pkgdir"/var/run/freeswitch
- mkdir -p "$pkgdir"/var/lib/freeswitch
- mkdir -p "$pkgdir"/var/log
- mkdir -p "$pkgdir"/usr/share/freeswitch/sounds
- mv "$pkgdir"/usr/db "$pkgdir"/var/lib/freeswitch/
- mv "$pkgdir"/usr/grammar "$pkgdir"/var/lib/freeswitch/
- mv "$pkgdir"/usr/htdocs "$pkgdir"/usr/share/freeswitch/
- mv "$pkgdir"/usr/recordings "$pkgdir"/var/lib/freeswitch/
- mv "$pkgdir"/usr/scripts "$pkgdir"/etc/freeswitch/
- mv "$pkgdir"/usr/log "$pkgdir"/var/log/freeswitch
- install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
- install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+ install -m755 -D "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -m644 -D "$srcdir"/$pkgname.confd \
+ "$pkgdir"/etc/conf.d/$pkgname || return 1
chown -R freeswitch:freeswitch "$pkgdir"/var/*/freeswitch
}
_mv_mod() {
- local moddir=usr/lib/freeswitch i=
+ local moddir=usr/lib/freeswitch/mod i=
mkdir -p "$subpkgdir"/$moddir
for i in $@; do
mv "$pkgdir"/$moddir/$i.so "$subpkgdir"/$moddir/ || return 1
@@ -229,7 +220,7 @@ e409b006b5dad6d8668c3e429bf20159 freeswitch-libshout-2.2.2.tar.gz
1e7f335ee00f589825ecc9affa779346 getlib.patch
0eb382f73ed393f28b8a797ebbfa608b modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
-1871cd5c0ed1dd815d44d379b5591fa1 freeswitch.initd
+165d0e80f3f3a41643979f32f0180aed freeswitch.initd
90b133b14a42c86d53d5e54dcbfbaf58 libshout-disable-examples.patch
4cd4923463c89bed053e6295b5a4ec40 freeswitch-mod_shout-textrels.patch
6a6c4aba80e99c236ef712b17f3cdd01 system-lame.patch"
@@ -243,7 +234,7 @@ b3a855acc96e0061a0c2b1162e8aff80b6b1a03849e3756786db2fcacfc9a9bd freeswitch-mpg
ab437c92149b6fc88bc2fc8a228d6a5f8af574e2c90469a6dc4c753d13972c34 getlib.patch
f83f9680d243eb254bf045571f971a6c5cf716367444cd48ed26d4c3367f4c41 modules.conf
846a29a361ef6eecd77876963b5c0133699c40fa8b34c68df42d5f8a1a1915b1 freeswitch.confd
-a8afcd9733155c0cb5a08b78f03994d24b4eb6fe54a7ef9e24f357b3235f142b freeswitch.initd
+b90220e484e0d65639083d7cede8b1bb331fbe04ec96e821198be8d05234bdce freeswitch.initd
db0d3c252b5664ecb071bcf6868eff77c85dd7943a63fcfcac7e19db6a0ff61f libshout-disable-examples.patch
be1009327de615f04956ba0b0f44183f31c263e380af8027f94b976a84bcb09a freeswitch-mod_shout-textrels.patch
11b107ca8632bb9c8fcb2aedfcfb421af24929aace4f56c34d4e701eb410e190 system-lame.patch"
@@ -257,7 +248,7 @@ d517d1d6a79dfd4819c42603faafc051c69270831f4894c01f6bd38e877eb008f8458534857641fd
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
6330e47cd3dcfdb4f5c99e91c9c725c7c8aa4f1691d83817d7600e510b5a586f3312bab84df3766448bbdab78cd1feebecf64b8280626b3f751f6e787f145e23 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd
-3ec46d452b652b8f31c0cd3938f5555e76b9f7af3d610022ebdafb92fce405951459afcfe587ea22ba6b31bfd06e9387b9b77dbdff18d8bb4f262ea3388b962e freeswitch.initd
+ebfea07fbaab6646eb1df3d2e357b9ba28e234c1ce486db1464c305625bac26aac0a1bc63c77dbda4ee68a58347dd82eba04d06bff6bbc0a03a541021f71e4a6 freeswitch.initd
91a6d7c8456de65855930b371f568f0230c28422e667453aa48fababd185b47677c06ff0c79f94c2a02182439b012d48cb54548cbde3d12b8d0e1ffbb9b229cc libshout-disable-examples.patch
5f085254ca9f5dc196afd39fc55e083b1998e776d9de2428e5657d99077526c33c1fc13f12432598184ce63138447fed7c318c384b743681703f5682dc8e1e50 freeswitch-mod_shout-textrels.patch
398dd0f2665415ff40348dc94d26ec7008fb59ec033f9d2c64dc1aa01071021f83f47954e95efc58c4033f22bb6da159e83e3b0d36b99189d5e7535ed6ae70bd system-lame.patch"
diff --git a/main/freeswitch/freeswitch.initd b/main/freeswitch/freeswitch.initd
index eebabe188..63ec58ad1 100755
--- a/main/freeswitch/freeswitch.initd
+++ b/main/freeswitch/freeswitch.initd
@@ -29,10 +29,8 @@ start() {
limits
start-stop-daemon --start --quiet --exec /usr/bin/freeswitch \
-- \
- -nc -conf /etc/freeswitch -log /var/log/freeswitch \
- -run /var/run/freeswitch -db /var/lib/freeswitch/db \
- -htdocs /usr/share/freeswitch/htdocs \
- -scripts /etc/freeswitch/scripts ${OPTS}
+ -nc \
+ ${OPTS}
eend $?
}