summaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2012-03-10 04:29:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-10 21:48:38 +0000
commite9bd997e15f5c82d187886b7a3caaa016af376e0 (patch)
tree561809e150ceb88dc73b6d0f5decda5fd1f05df0 /main/freeswitch
parent07b81e1f2da64dd7316019430b2101121dcc8c88 (diff)
downloadaports-e9bd997e15f5c82d187886b7a3caaa016af376e0.tar.bz2
aports-e9bd997e15f5c82d187886b7a3caaa016af376e0.tar.xz
main/freeswitch: update to latest git snapshot
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch27
-rw-r--r--main/freeswitch/0003-mod_conference_no_hangup.patch27
-rw-r--r--main/freeswitch/APKBUILD16
3 files changed, 7 insertions, 63 deletions
diff --git a/main/freeswitch/0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch b/main/freeswitch/0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch
deleted file mode 100644
index ccf4e5c6e..000000000
--- a/main/freeswitch/0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 67a60b5bf50fbfdf184dc4cb20a88d8d88ff59ad Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 10 Jun 2011 11:58:19 +0300
-Subject: [PATCH 1/2] mod_sofia: update mod_sofia_globals.guess_ip on address change
-
-So that we rebind to the new IP-address after reloading
-configuration. Fixes FS-3336.
----
- src/mod/endpoints/mod_sofia/mod_sofia.c | 2 ++
- 1 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/src/mod/endpoints/mod_sofia/mod_sofia.c b/src/mod/endpoints/mod_sofia/mod_sofia.c
-index 86fa140..b06eacb 100644
---- a/src/mod/endpoints/mod_sofia/mod_sofia.c
-+++ b/src/mod/endpoints/mod_sofia/mod_sofia.c
-@@ -4889,6 +4889,8 @@ static void general_event_handler(switch_event_t *event)
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "EVENT_TRAP: IP change detected\n");
- switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "IP change detected [%s]->[%s] [%s]->[%s]\n", old_ip4, new_ip4, old_ip6, new_ip6);
-
-+ strncpy(mod_sofia_globals.guess_ip, new_ip4, sizeof(mod_sofia_globals.guess_ip));
-+
- switch_mutex_lock(mod_sofia_globals.hash_mutex);
- if (mod_sofia_globals.profile_hash) {
- for (hi = switch_hash_first(NULL, mod_sofia_globals.profile_hash); hi; hi = switch_hash_next(hi)) {
---
-1.7.1
-
diff --git a/main/freeswitch/0003-mod_conference_no_hangup.patch b/main/freeswitch/0003-mod_conference_no_hangup.patch
deleted file mode 100644
index 577ca8e1a..000000000
--- a/main/freeswitch/0003-mod_conference_no_hangup.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/src/mod/applications/mod_conference/mod_conference.c b/src/mod/applications/mod_conference/mod_conference.c
-index 572fdf0..d62d114 100644
---- a/src/mod/applications/mod_conference/mod_conference.c
-+++ b/src/mod/applications/mod_conference/mod_conference.c
-@@ -1482,13 +1482,15 @@ static void *SWITCH_THREAD_FUNC conference_thread_run(switch_thread_t *thread, v
- if (!switch_test_flag(imember, MFLAG_NOCHANNEL)) {
- channel = switch_core_session_get_channel(imember->session);
-
-- /* add this little bit to preserve the bridge cause code in case of an early media call that */
-- /* never answers */
-- if (switch_test_flag(conference, CFLAG_ANSWERED)) {
-- switch_channel_hangup(channel, SWITCH_CAUSE_NORMAL_CLEARING);
-- } else {
-- /* put actual cause code from outbound channel hangup here */
-- switch_channel_hangup(channel, conference->bridge_hangup_cause);
-+ if (!switch_false(switch_channel_get_variable(channel, "hangup_after_conference"))) {
-+ /* add this little bit to preserve the bridge cause code in case of an early media call that */
-+ /* never answers */
-+ if (switch_test_flag(conference, CFLAG_ANSWERED)) {
-+ switch_channel_hangup(channel, SWITCH_CAUSE_NORMAL_CLEARING);
-+ } else {
-+ /* put actual cause code from outbound channel hangup here */
-+ switch_channel_hangup(channel, conference->bridge_hangup_cause);
-+ }
- }
- }
-
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 591a42d81..bf39232c7 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,10 +1,11 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
-pkgver=1.0.7_p20110602
+pkgver=1.0.7_p20120309
_ver=${pkgver%_p*}
_snapshot=${pkgver#*_p}
-pkgrel=7
+_commit=ca60afaa1900abdeeb3a105de6cd53f098a3dd01
+pkgrel=1
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -17,17 +18,16 @@ makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
subpackages="$pkgname-dev $pkgname-flite $pkgname-timezones
$pkgname-sample-config:conf $pkgname-freetdm $pkgname-sangoma"
-source="saveas-http://latest.freeswitch.org/freeswitch-$_ver.tar.gz/freeswitch-$pkgver.tar.gz
+#hmm, saveas doesn't work with https...
+source="http://git.freeswitch.org/git/freeswitch/snapshot/$pkgname-$_commit.tar.bz2
freeswitch-mod_shout-textrels.patch
- 0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch
0002-mod_lua-alpine-module-search-path.patch
- 0003-mod_conference_no_hangup.patch
modules.conf
freeswitch.confd
freeswitch.initd
"
-_builddir="$srcdir/$pkgname-$_ver"
+_builddir="$srcdir/$pkgname-$_commit"
prepare() {
cd "$_builddir"
@@ -153,11 +153,9 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="813edb2192d1cc0fe224d9ef0492de4f freeswitch-1.0.7_p20110602.tar.gz
+md5sums="9d539a3cbbc56cef870946506839603c freeswitch-ca60afaa1900abdeeb3a105de6cd53f098a3dd01.tar.bz2
11883affe0839a8e15fe680aeb11b86e freeswitch-mod_shout-textrels.patch
-5aed9ec61d7ac1f3758a89db159328c4 0001-mod_sofia-update-mod_sofia_globals.guess_ip-on-addre.patch
769eaa127d4dbae687dc4aa961a8cc70 0002-mod_lua-alpine-module-search-path.patch
-74c3cdd3ce8474e8d084f475fa4f92c1 0003-mod_conference_no_hangup.patch
94516a9473e2283ab201f38cb2756741 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
51e0c45ae07a675f6008f95b1ab8f18e freeswitch.initd"