summaryrefslogtreecommitdiffstats
path: root/main/gimp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-29 07:32:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-29 07:33:02 +0000
commit6d2720443e017d716f785d88eed39c8ee19b54b1 (patch)
tree6c2a4be087e9b638444a6c6a0eb4c0f22868e0f0 /main/gimp
parentda07e62d7c1a0663d00d1057f401db5984b98e80 (diff)
downloadaports-6d2720443e017d716f785d88eed39c8ee19b54b1.tar.bz2
aports-6d2720443e017d716f785d88eed39c8ee19b54b1.tar.xz
main/gimp: remove *.la and build fix for curl-7.21.7
Diffstat (limited to 'main/gimp')
-rw-r--r--main/gimp/APKBUILD11
-rw-r--r--main/gimp/gimp-curl-fix.patch12
2 files changed, 19 insertions, 4 deletions
diff --git a/main/gimp/APKBUILD b/main/gimp/APKBUILD
index dab307d38..b70fd0174 100644
--- a/main/gimp/APKBUILD
+++ b/main/gimp/APKBUILD
@@ -1,18 +1,19 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gimp
pkgver=2.6.11
-pkgrel=2
+pkgrel=3
pkgdesc="GNU Image Manipulation Program"
url="http://www.gimp.org/"
arch="all"
license="GPL"
makedepends="gtk+-dev libxpm-dev libxmu-dev librsvg-dev dbus-glib-dev
libexif-dev desktop-file-utils intltool gegl-dev tiff-dev
- jpeg-dev libpng-dev curl-dev"
+ jpeg-dev libpng-dev"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://ftp.$pkgname.org/pub/$pkgname/v2.6/$pkgname-$pkgver.tar.bz2
- gimp-libpng1.5-compat.patch"
+ gimp-libpng1.5-compat.patch
+ gimp-curl-fix.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -48,7 +49,9 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
ln -s gimptool-2.0 "$pkgdir/usr/bin/gimptool" || return 1
+ find "$pkgdir" -name '*.la' -delete
}
md5sums="bb2939fe13e54fc7255cef5d097bb5dd gimp-2.6.11.tar.bz2
-7dfc4006676fdea887f1883ccc6c7772 gimp-libpng1.5-compat.patch"
+7dfc4006676fdea887f1883ccc6c7772 gimp-libpng1.5-compat.patch
+678010acec374e06140e65f7de24ff69 gimp-curl-fix.patch"
diff --git a/main/gimp/gimp-curl-fix.patch b/main/gimp/gimp-curl-fix.patch
new file mode 100644
index 000000000..ea8935d00
--- /dev/null
+++ b/main/gimp/gimp-curl-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/plug-ins/file-uri/uri-backend-libcurl.c b/plug-ins/file-uri/uri-backend-libcurl.c
+index a566966..747dca7 100644
+--- a/plug-ins/file-uri/uri-backend-libcurl.c
++++ b/plug-ins/file-uri/uri-backend-libcurl.c
+@@ -24,7 +24,6 @@
+ #include <errno.h>
+
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+
+ #include <glib/gstdio.h>