summaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-16 20:22:02 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2013-10-16 20:22:02 +0200
commit5ae91430aa1a3025955f428c1583ef2e6c6a038c (patch)
tree9cea77680b115f2e1cb9a652015cfa2065177cea /main/git
parentd76a3914572de1822cbb77ac631f6b965f5c3f8e (diff)
downloadaports-5ae91430aa1a3025955f428c1583ef2e6c6a038c.tar.bz2
aports-5ae91430aa1a3025955f428c1583ef2e6c6a038c.tar.xz
main/git: upgrade to 1.8.4.1
Diffstat (limited to 'main/git')
-rw-r--r--main/git/0001-config-add-_cb-suffix-to-callback-functions.patch107
-rw-r--r--main/git/APKBUILD2
2 files changed, 41 insertions, 68 deletions
diff --git a/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch b/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
index 9489341cc..db0634110 100644
--- a/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
+++ b/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
@@ -1,109 +1,82 @@
-From 59c678a754227ca1fb44541cdfe39bbe052be195 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Tue, 27 Aug 2013 07:57:12 +0000
-Subject: [PATCH] config: add _cb suffix to callback functions
-
-Commit 4d8dd1494e9f3af2e9738edaca40ada096f7bf10 introduced a build
-regression on uClibc which defines fgetc as macro. To work around that
-we add a _cb suffix to the callback functions.
-
-Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
----
- config.c | 32 ++++++++++++++++----------------
- 1 file changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/config.c b/config.c
-index e13a7b6..aa80078 100644
---- a/config.c
-+++ b/config.c
-@@ -27,9 +27,9 @@ struct config_source {
- struct strbuf value;
- struct strbuf var;
-
-- int (*fgetc)(struct config_source *c);
-- int (*ungetc)(int c, struct config_source *conf);
-- long (*ftell)(struct config_source *c);
-+ int (*fgetc_cb)(struct config_source *c);
-+ int (*ungetc_cb)(int c, struct config_source *conf);
-+ long (*ftell_cb)(struct config_source *c);
+diff -rupN a/config.c b/config.c
+--- a/config.c 2013-09-27 01:49:38.000000000 +0200
++++ b/config.c 2013-10-16 20:20:44.505672141 +0200
+@@ -30,6 +30,9 @@ struct config_source {
+ int (*do_fgetc)(struct config_source *c);
+ int (*do_ungetc)(int c, struct config_source *conf);
+ long (*do_ftell)(struct config_source *c);
++ int (*do_fgetc_cb)(struct config_source *c);
++ int (*do_ungetc_cb)(int c, struct config_source *conf);
++ long (*do_ftell_cb)(struct config_source *c);
};
static struct config_source *cf;
-@@ -217,13 +217,13 @@ int git_config_from_parameters(config_fn_t fn, void *data)
+@@ -217,13 +220,13 @@ int git_config_from_parameters(config_fn
static int get_next_char(void)
{
-- int c = cf->fgetc(cf);
+- int c = cf->do_fgetc(cf);
+ int c = cf->fgetc_cb(cf);
if (c == '\r') {
/* DOS like systems */
-- c = cf->fgetc(cf);
-+ c = cf->fgetc_cb(cf);
+- c = cf->do_fgetc(cf);
++ c = cf->do_fgetc_cb(cf);
if (c != '\n') {
-- cf->ungetc(c, cf);
-+ cf->ungetc_cb(c, cf);
+- cf->do_ungetc(c, cf);
++ cf->do_ungetc_cb(c, cf);
c = '\r';
}
}
-@@ -992,9 +992,9 @@ int git_config_from_file(config_fn_t fn, const char *filename, void *data)
- top.u.file = f;
- top.name = filename;
- top.die_on_error = 1;
-- top.fgetc = config_file_fgetc;
-- top.ungetc = config_file_ungetc;
-- top.ftell = config_file_ftell;
-+ top.fgetc_cb = config_file_fgetc;
-+ top.ungetc_cb = config_file_ungetc;
-+ top.ftell_cb = config_file_ftell;
+@@ -995,6 +998,9 @@ int git_config_from_file(config_fn_t fn,
+ top.do_fgetc = config_file_fgetc;
+ top.do_ungetc = config_file_ungetc;
+ top.do_ftell = config_file_ftell;
++ top.do_fgetc_cb = config_file_fgetc;
++ top.do_ungetc_cb = config_file_ungetc;
++ top.do_ftell_cb = config_file_ftell;
ret = do_config_from(&top, fn, data);
-@@ -1013,9 +1013,9 @@ int git_config_from_buf(config_fn_t fn, const char *name, const char *buf,
- top.u.buf.pos = 0;
- top.name = name;
- top.die_on_error = 0;
-- top.fgetc = config_buf_fgetc;
-- top.ungetc = config_buf_ungetc;
-- top.ftell = config_buf_ftell;
-+ top.fgetc_cb = config_buf_fgetc;
-+ top.ungetc_cb = config_buf_ungetc;
-+ top.ftell_cb = config_buf_ftell;
+@@ -1016,6 +1022,9 @@ int git_config_from_buf(config_fn_t fn,
+ top.do_fgetc = config_buf_fgetc;
+ top.do_ungetc = config_buf_ungetc;
+ top.do_ftell = config_buf_ftell;
++ top.do_fget_cb = config_buf_fgetc;
++ top.do_ungetc_cb = config_buf_ungetc;
++ top.do_ftell_cb = config_buf_ftell;
return do_config_from(&top, fn, data);
}
-@@ -1196,7 +1196,7 @@ static int store_aux(const char *key, const char *value, void *cb)
+@@ -1196,7 +1205,7 @@ static int store_aux(const char *key, co
return 1;
}
-- store.offset[store.seen] = cf->ftell(cf);
-+ store.offset[store.seen] = cf->ftell_cb(cf);
+- store.offset[store.seen] = cf->do_ftell(cf);
++ store.offset[store.seen] = cf->do_ftell_cb(cf);
store.seen++;
}
break;
-@@ -1223,19 +1223,19 @@ static int store_aux(const char *key, const char *value, void *cb)
+@@ -1223,19 +1232,19 @@ static int store_aux(const char *key, co
* Do not increment matches: this is no match, but we
* just made sure we are in the desired section.
*/
-- store.offset[store.seen] = cf->ftell(cf);
-+ store.offset[store.seen] = cf->ftell_cb(cf);
+- store.offset[store.seen] = cf->do_ftell(cf);
++ store.offset[store.seen] = cf->do_ftell_cb(cf);
/* fallthru */
case SECTION_END_SEEN:
case START:
if (matches(key, value)) {
-- store.offset[store.seen] = cf->ftell(cf);
-+ store.offset[store.seen] = cf->ftell_cb(cf);
+- store.offset[store.seen] = cf->do_ftell(cf);
++ store.offset[store.seen] = cf->do_ftell_cb(cf);
store.state = KEY_SEEN;
store.seen++;
} else {
if (strrchr(key, '.') - key == store.baselen &&
!strncmp(key, store.key, store.baselen)) {
store.state = SECTION_SEEN;
-- store.offset[store.seen] = cf->ftell(cf);
-+ store.offset[store.seen] = cf->ftell_cb(cf);
+- store.offset[store.seen] = cf->do_ftell(cf);
++ store.offset[store.seen] = cf->do_ftell_cb(cf);
}
}
}
---
-1.8.3.4
-
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index aff0edbe1..fcc40a769 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.8.4
+pkgver=1.8.4.1
pkgrel=0
pkgdesc="A distributed version control system"
url="http://git.or.cz/"