summaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-27 08:22:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-27 08:22:09 +0000
commit755bf6da869949f77e71d3a6f89ff60f04a0c468 (patch)
tree736368d309c1507927dfc729fbe35de9ffc2c8fa /main/git
parenta0e47545be683b77b8b625827f4fcdf7b15739ea (diff)
downloadaports-755bf6da869949f77e71d3a6f89ff60f04a0c468.tar.bz2
aports-755bf6da869949f77e71d3a6f89ff60f04a0c468.tar.xz
main/git: upgrade to 1.8.4
Diffstat (limited to 'main/git')
-rw-r--r--main/git/0001-config-add-_cb-suffix-to-callback-functions.patch109
-rw-r--r--main/git/APKBUILD18
2 files changed, 121 insertions, 6 deletions
diff --git a/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch b/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
new file mode 100644
index 000000000..9489341cc
--- /dev/null
+++ b/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
@@ -0,0 +1,109 @@
+From 59c678a754227ca1fb44541cdfe39bbe052be195 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 27 Aug 2013 07:57:12 +0000
+Subject: [PATCH] config: add _cb suffix to callback functions
+
+Commit 4d8dd1494e9f3af2e9738edaca40ada096f7bf10 introduced a build
+regression on uClibc which defines fgetc as macro. To work around that
+we add a _cb suffix to the callback functions.
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+---
+ config.c | 32 ++++++++++++++++----------------
+ 1 file changed, 16 insertions(+), 16 deletions(-)
+
+diff --git a/config.c b/config.c
+index e13a7b6..aa80078 100644
+--- a/config.c
++++ b/config.c
+@@ -27,9 +27,9 @@ struct config_source {
+ struct strbuf value;
+ struct strbuf var;
+
+- int (*fgetc)(struct config_source *c);
+- int (*ungetc)(int c, struct config_source *conf);
+- long (*ftell)(struct config_source *c);
++ int (*fgetc_cb)(struct config_source *c);
++ int (*ungetc_cb)(int c, struct config_source *conf);
++ long (*ftell_cb)(struct config_source *c);
+ };
+
+ static struct config_source *cf;
+@@ -217,13 +217,13 @@ int git_config_from_parameters(config_fn_t fn, void *data)
+
+ static int get_next_char(void)
+ {
+- int c = cf->fgetc(cf);
++ int c = cf->fgetc_cb(cf);
+
+ if (c == '\r') {
+ /* DOS like systems */
+- c = cf->fgetc(cf);
++ c = cf->fgetc_cb(cf);
+ if (c != '\n') {
+- cf->ungetc(c, cf);
++ cf->ungetc_cb(c, cf);
+ c = '\r';
+ }
+ }
+@@ -992,9 +992,9 @@ int git_config_from_file(config_fn_t fn, const char *filename, void *data)
+ top.u.file = f;
+ top.name = filename;
+ top.die_on_error = 1;
+- top.fgetc = config_file_fgetc;
+- top.ungetc = config_file_ungetc;
+- top.ftell = config_file_ftell;
++ top.fgetc_cb = config_file_fgetc;
++ top.ungetc_cb = config_file_ungetc;
++ top.ftell_cb = config_file_ftell;
+
+ ret = do_config_from(&top, fn, data);
+
+@@ -1013,9 +1013,9 @@ int git_config_from_buf(config_fn_t fn, const char *name, const char *buf,
+ top.u.buf.pos = 0;
+ top.name = name;
+ top.die_on_error = 0;
+- top.fgetc = config_buf_fgetc;
+- top.ungetc = config_buf_ungetc;
+- top.ftell = config_buf_ftell;
++ top.fgetc_cb = config_buf_fgetc;
++ top.ungetc_cb = config_buf_ungetc;
++ top.ftell_cb = config_buf_ftell;
+
+ return do_config_from(&top, fn, data);
+ }
+@@ -1196,7 +1196,7 @@ static int store_aux(const char *key, const char *value, void *cb)
+ return 1;
+ }
+
+- store.offset[store.seen] = cf->ftell(cf);
++ store.offset[store.seen] = cf->ftell_cb(cf);
+ store.seen++;
+ }
+ break;
+@@ -1223,19 +1223,19 @@ static int store_aux(const char *key, const char *value, void *cb)
+ * Do not increment matches: this is no match, but we
+ * just made sure we are in the desired section.
+ */
+- store.offset[store.seen] = cf->ftell(cf);
++ store.offset[store.seen] = cf->ftell_cb(cf);
+ /* fallthru */
+ case SECTION_END_SEEN:
+ case START:
+ if (matches(key, value)) {
+- store.offset[store.seen] = cf->ftell(cf);
++ store.offset[store.seen] = cf->ftell_cb(cf);
+ store.state = KEY_SEEN;
+ store.seen++;
+ } else {
+ if (strrchr(key, '.') - key == store.baselen &&
+ !strncmp(key, store.key, store.baselen)) {
+ store.state = SECTION_SEEN;
+- store.offset[store.seen] = cf->ftell(cf);
++ store.offset[store.seen] = cf->ftell_cb(cf);
+ }
+ }
+ }
+--
+1.8.3.4
+
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index 3215ff92d..aff0edbe1 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.8.3.4
+pkgver=1.8.4
pkgrel=0
pkgdesc="A distributed version control system"
url="http://git.or.cz/"
@@ -9,8 +9,10 @@ license="GPL2+"
depends=
replaces="git-perl"
subpackages="$pkgname-doc $pkgname-svn $pkgname-perl"
-makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev"
+makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev
+ pcre-dev"
source="http://git-core.googlecode.com/files/git-$pkgver.tar.gz
+ 0001-config-add-_cb-suffix-to-callback-functions.patch
bb-tar.patch
git-daemon.initd
git-daemon.confd
@@ -20,7 +22,8 @@ _makeopts="NO_ICONV=YesPlease
NO_GETTEXT=YesPlease
NO_NSEC=YesPlease
NO_TCLTK=YesPlease
- NO_SVN_TESTS=YesPlease"
+ NO_SVN_TESTS=YesPlease
+ USE_LIBPCRE=1"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -72,15 +75,18 @@ svn() {
mv "$pkgdir"/usr/libexec/git-core/git-svn "$subpkgdir"/usr/libexec/git-core
}
-md5sums="80eec3201a5d012913d287b85adaee8e git-1.8.3.4.tar.gz
+md5sums="355768a1c70d0cb4fedf4b598ac1375b git-1.8.4.tar.gz
+45c27ede8b7c1c6af42ba328e575e7ae 0001-config-add-_cb-suffix-to-callback-functions.patch
e63a201556c4f089de790805c09a2e5b bb-tar.patch
c92d9339a131e708cc65e1cac1e2520a git-daemon.initd
2258e95d389ccc6de0b5111d53d9eed6 git-daemon.confd"
-sha256sums="dfa2cdf2df92b4abe956b1e7586030381c4e39e89161ab789a660d8d1f24d9d9 git-1.8.3.4.tar.gz
+sha256sums="51e8522c256ef8091c6fd5846b9cef8ba4e764819193b5b6cec570f530e6cb94 git-1.8.4.tar.gz
+39c89b8dd808d97a2e17127bb5c1521b83a361a1e51735fc3875818b0a01af40 0001-config-add-_cb-suffix-to-callback-functions.patch
cb6319f47d81605e199771350154cbed0a6e85ef9042a689f2b405c64039f49c bb-tar.patch
02eb703e3638275104e12c8057f16b9a858ac5c8dc56d2e9ca68d7d3250a1917 git-daemon.initd
aaa80bd059db549dadf4c4e27a9aa41a4b5def844f8e563c493bc8513dcd981e git-daemon.confd"
-sha512sums="84d2d70622d19200594f4ea8550f00c3bd46657381ea953a2171172faf27ffa8be30c9249e1ed93d983826880c7e78a76884c841212338efdfb7ab38713bdbe1 git-1.8.3.4.tar.gz
+sha512sums="4bad6dfdfadc88b6d40dc385e8ec50678fba61dc46d6e5c264ae6c3547a7c0cc1582c84e4ceeda76caee29d7ae73f03a0c98abc6a156c8b5c8c06691b2566756 git-1.8.4.tar.gz
+8b03570a4cd7ef6aa96b57b265af73f97f68b944f76a52bd2a8d823ad29b4517e750bd95e825afe3870a19371e9ee7514810503a4012c6a1e703ebdb99c0f50b 0001-config-add-_cb-suffix-to-callback-functions.patch
6fa088a753c2a697e8dbef2032ed63e8c2a0553a41cff2fcff893c2f35c51d2c697054cc921c23ee606f77b93d0f340df85220b15e1c470bd352f7fba3986cd0 bb-tar.patch
6321ea464f0c1d6245a0722e02ff3dc29996e41fb8d9f3c747bfdd914dc1284e6eb62a7d6057e4f99c0c8a23c3e57f9ff76f2cf18d19272f3cc599877f999c41 git-daemon.initd
9640f8078d68ed2678e5249da3f946fc21f50e858b94127a4221de73c6132101afcd46bc1fe33861e9a7f731c0dc9591915b8ebf376b8e690cd7135703966509 git-daemon.confd"