summaryrefslogtreecommitdiffstats
path: root/main/git
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-19 18:00:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-19 18:00:15 +0000
commit8b26b33dd797ee986559c604c2e738b995e0a909 (patch)
tree7b452ac07c4a57fba2070f66f979f5e158cc0631 /main/git
parentacdcbc8cfe9589607d3a8af6a54f2966b76075c7 (diff)
downloadaports-8b26b33dd797ee986559c604c2e738b995e0a909.tar.bz2
aports-8b26b33dd797ee986559c604c2e738b995e0a909.tar.xz
main/git: upgrade to 1.9.0
Diffstat (limited to 'main/git')
-rw-r--r--main/git/0001-config-add-_cb-suffix-to-callback-functions.patch82
-rw-r--r--main/git/APKBUILD12
2 files changed, 4 insertions, 90 deletions
diff --git a/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch b/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
deleted file mode 100644
index 5a22944be..000000000
--- a/main/git/0001-config-add-_cb-suffix-to-callback-functions.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-diff -rupN a/config.c b/config.c
---- a/config.c 2013-09-27 01:49:38.000000000 +0200
-+++ b/config.c 2013-10-16 20:26:27.835675951 +0200
-@@ -30,6 +30,9 @@ struct config_source {
- int (*do_fgetc)(struct config_source *c);
- int (*do_ungetc)(int c, struct config_source *conf);
- long (*do_ftell)(struct config_source *c);
-+ int (*do_fgetc_cb)(struct config_source *c);
-+ int (*do_ungetc_cb)(int c, struct config_source *conf);
-+ long (*do_ftell_cb)(struct config_source *c);
- };
-
- static struct config_source *cf;
-@@ -217,13 +220,13 @@ int git_config_from_parameters(config_fn
-
- static int get_next_char(void)
- {
-- int c = cf->do_fgetc(cf);
-+ int c = cf->do_fgetc_cb(cf);
-
- if (c == '\r') {
- /* DOS like systems */
-- c = cf->do_fgetc(cf);
-+ c = cf->do_fgetc_cb(cf);
- if (c != '\n') {
-- cf->do_ungetc(c, cf);
-+ cf->do_ungetc_cb(c, cf);
- c = '\r';
- }
- }
-@@ -995,6 +998,9 @@ int git_config_from_file(config_fn_t fn,
- top.do_fgetc = config_file_fgetc;
- top.do_ungetc = config_file_ungetc;
- top.do_ftell = config_file_ftell;
-+ top.do_fgetc_cb = config_file_fgetc;
-+ top.do_ungetc_cb = config_file_ungetc;
-+ top.do_ftell_cb = config_file_ftell;
-
- ret = do_config_from(&top, fn, data);
-
-@@ -1016,6 +1022,9 @@ int git_config_from_buf(config_fn_t fn,
- top.do_fgetc = config_buf_fgetc;
- top.do_ungetc = config_buf_ungetc;
- top.do_ftell = config_buf_ftell;
-+ top.do_fgetc_cb = config_buf_fgetc;
-+ top.do_ungetc_cb = config_buf_ungetc;
-+ top.do_ftell_cb = config_buf_ftell;
-
- return do_config_from(&top, fn, data);
- }
-@@ -1196,7 +1205,7 @@ static int store_aux(const char *key, co
- return 1;
- }
-
-- store.offset[store.seen] = cf->do_ftell(cf);
-+ store.offset[store.seen] = cf->do_ftell_cb(cf);
- store.seen++;
- }
- break;
-@@ -1223,19 +1232,19 @@ static int store_aux(const char *key, co
- * Do not increment matches: this is no match, but we
- * just made sure we are in the desired section.
- */
-- store.offset[store.seen] = cf->do_ftell(cf);
-+ store.offset[store.seen] = cf->do_ftell_cb(cf);
- /* fallthru */
- case SECTION_END_SEEN:
- case START:
- if (matches(key, value)) {
-- store.offset[store.seen] = cf->do_ftell(cf);
-+ store.offset[store.seen] = cf->do_ftell_cb(cf);
- store.state = KEY_SEEN;
- store.seen++;
- } else {
- if (strrchr(key, '.') - key == store.baselen &&
- !strncmp(key, store.key, store.baselen)) {
- store.state = SECTION_SEEN;
-- store.offset[store.seen] = cf->do_ftell(cf);
-+ store.offset[store.seen] = cf->do_ftell_cb(cf);
- }
- }
- }
diff --git a/main/git/APKBUILD b/main/git/APKBUILD
index a3496b521..d23c89538 100644
--- a/main/git/APKBUILD
+++ b/main/git/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=git
-pkgver=1.8.5.4
+pkgver=1.9.0
pkgrel=0
pkgdesc="A distributed version control system"
url="http://git.or.cz/"
@@ -26,7 +26,6 @@ subpackages="$pkgname-doc
makedepends="zlib-dev openssl-dev curl-dev expat-dev perl-dev python-dev
pcre-dev asciidoc xmlto perl-error"
source="http://git-core.googlecode.com/files/git-$pkgver.tar.gz
- 0001-config-add-_cb-suffix-to-callback-functions.patch
bb-tar.patch
git-daemon.initd
git-daemon.confd
@@ -178,18 +177,15 @@ _git_perl() {
}
-md5sums="25965b5973aae43848a4ba5ca91b6a52 git-1.8.5.4.tar.gz
-178d2d10f9740fac4a8af0155368b3d9 0001-config-add-_cb-suffix-to-callback-functions.patch
+md5sums="e16c14b27c644b8e0dd72bdb5ff77450 git-1.9.0.tar.gz
e63a201556c4f089de790805c09a2e5b bb-tar.patch
53546650670c0ab8858e91474e5ffee9 git-daemon.initd
2258e95d389ccc6de0b5111d53d9eed6 git-daemon.confd"
-sha256sums="93ce88ae2fabfa72188145a23d89771bafed7556bf0adde7a6cd410789245f18 git-1.8.5.4.tar.gz
-c0f66913df49d35e197ff18426b2835a3bd539373c579d253cc4fcdf6c5b77c5 0001-config-add-_cb-suffix-to-callback-functions.patch
+sha256sums="de3097fdc36d624ea6cf4bb853402fde781acdb860f12152c5eb879777389882 git-1.9.0.tar.gz
cb6319f47d81605e199771350154cbed0a6e85ef9042a689f2b405c64039f49c bb-tar.patch
817cd58dcb9a5ff32759d2132bb805a5dd34ad6fa0b0a5cbe4ab8786f3b7c0d9 git-daemon.initd
aaa80bd059db549dadf4c4e27a9aa41a4b5def844f8e563c493bc8513dcd981e git-daemon.confd"
-sha512sums="57dec8cf4224a7ad3745e56a2e5c66f3134f742a937e224d8945b15daeeb0a22306060e421c4381ae961e47fb6765d621b508a72c490c504a1fa6ba9bfe5aed9 git-1.8.5.4.tar.gz
-3de27e2ff97be2673c218b86c5b0db515a6e6c603302ac158c8cb412e90f13b79381c432adcf661afcc2d5d0d156946bc85c2921c15066d20acf72defc0ce194 0001-config-add-_cb-suffix-to-callback-functions.patch
+sha512sums="e81f320cf13262e08a262c9fb70d701b8d8017a5d6b10c8be959c234b99486012cb7fa808a49f97db143777cd6c4368fd08a69f8ef272f9e187f82aed32d0854 git-1.9.0.tar.gz
6fa088a753c2a697e8dbef2032ed63e8c2a0553a41cff2fcff893c2f35c51d2c697054cc921c23ee606f77b93d0f340df85220b15e1c470bd352f7fba3986cd0 bb-tar.patch
47f35d1553408236502f936d0ce5dbc6c44b6593ad5ef9ddebbfd8dbca5f968c21452df7053ac271445830d36a147a7124e2ea1cf9fb98340d975fdb0346011a git-daemon.initd
9640f8078d68ed2678e5249da3f946fc21f50e858b94127a4221de73c6132101afcd46bc1fe33861e9a7f731c0dc9591915b8ebf376b8e690cd7135703966509 git-daemon.confd"