summaryrefslogtreecommitdiffstats
path: root/main/glade3
diff options
context:
space:
mode:
authorAmatCoder <amatcoder@gmail.com>2015-01-15 11:25:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-01-15 15:24:58 +0000
commit8d8512d008e32d6622cf554d7f00f89ae09b344f (patch)
treefe9988674b14f7bbea5bd6dfe71d719a90565851 /main/glade3
parent9ab9fdcba910e0d1d7e5bcab0e8ba192a57ab95f (diff)
downloadaports-8d8512d008e32d6622cf554d7f00f89ae09b344f.tar.bz2
aports-8d8512d008e32d6622cf554d7f00f89ae09b344f.tar.xz
main/glade3: disable RANDMMAP
This allows to add items under Hierarchy tabs.
Diffstat (limited to 'main/glade3')
-rw-r--r--main/glade3/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/glade3/APKBUILD b/main/glade3/APKBUILD
index bcf89af36..d1355b8a4 100644
--- a/main/glade3/APKBUILD
+++ b/main/glade3/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glade3
pkgver=3.8.5
-pkgrel=0
+pkgrel=1
pkgdesc="a RAD tool to enable quick & easy development of user interfaces for GTK+"
url="http://glade.gnome.org/"
arch="all"
license="GPL"
depends=
-makedepends="gtk+2.0-dev libxml2-dev"
+makedepends="gtk+2.0-dev libxml2-dev paxctl"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-dev $pkgname-lang"
source="http://ftp.gnome.org/pub/GNOME/sources/glade3/${pkgver%.*}/glade3-$pkgver.tar.xz"
@@ -36,6 +36,7 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
+ paxctl -c -r "$pkgdir"/usr/bin/glade-3
rm "$pkgdir"/usr/lib/*.la \
"$pkgdir"/usr/lib/glade3/modules/*.la
}