summaryrefslogtreecommitdiffstats
path: root/main/gnumeric
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:12:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-04 21:12:29 +0000
commitbdf4a9e7022c840459877bd34eebd148c48ae3e0 (patch)
treed3734c9b9e8203473bdbc03853ae6729fd8ac73e /main/gnumeric
parent44e7f79e382c6ed69511972c3b271f1945780344 (diff)
downloadaports-bdf4a9e7022c840459877bd34eebd148c48ae3e0.tar.bz2
aports-bdf4a9e7022c840459877bd34eebd148c48ae3e0.tar.xz
main/gnumeric: moved from testing
Diffstat (limited to 'main/gnumeric')
-rw-r--r--main/gnumeric/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/gnumeric/APKBUILD b/main/gnumeric/APKBUILD
new file mode 100644
index 000000000..ef7d620a4
--- /dev/null
+++ b/main/gnumeric/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnumeric
+pkgver=1.10.3
+pkgrel=0
+pkgdesc="A GNOME Spreadsheet Program"
+url="http://www.gnome.org/projects/gnumeric/"
+license="GPL"
+makedepends="gtk+-dev intltool desktop-file-utils libglade-dev goffice-dev
+ rarian"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/1.10/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-install \
+ --disable-static \
+ --enable-ssindex || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+md5sums="7da8b0acac1395c6fb049d5be7da37ef gnumeric-1.10.3.tar.bz2"