summaryrefslogtreecommitdiffstats
path: root/main/gobject-introspection
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-22 17:25:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-22 17:25:41 +0000
commitdc36e1d905e3c8c70e2b3c81631efb921e76e988 (patch)
tree46d9313924ddaa0050ab831c99081ec466cf9f20 /main/gobject-introspection
parent0975c61de8c50ba9675ec76f0c275f2fe43a2413 (diff)
downloadaports-dc36e1d905e3c8c70e2b3c81631efb921e76e988.tar.bz2
aports-dc36e1d905e3c8c70e2b3c81631efb921e76e988.tar.xz
main/gobject-introspection: fix for CC="ccache gcc"
from upstream
Diffstat (limited to 'main/gobject-introspection')
-rw-r--r--main/gobject-introspection/001-ccache.patch24
-rw-r--r--main/gobject-introspection/002-ccache.patch21
-rw-r--r--main/gobject-introspection/APKBUILD10
3 files changed, 52 insertions, 3 deletions
diff --git a/main/gobject-introspection/001-ccache.patch b/main/gobject-introspection/001-ccache.patch
new file mode 100644
index 000000000..1f9145df5
--- /dev/null
+++ b/main/gobject-introspection/001-ccache.patch
@@ -0,0 +1,24 @@
+From 404af5e1d854522df2b02db9f8805ce19f9e8b76 Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Fri, 22 Oct 2010 15:28:40 +0000
+Subject: Handle CC="ccache gcc" for linker command too
+
+The compiler path explicitly split()s the variable, we should do
+so in the linker path too.
+---
+diff --git a/giscanner/dumper.py b/giscanner/dumper.py
+index 773dec9..7462aa3 100644
+--- a/giscanner/dumper.py
++++ b/giscanner/dumper.py
+@@ -200,7 +200,8 @@ class DumpCompiler(object):
+ args.append('--tag=CC')
+ args.append('--silent')
+
+- args.extend([self._linker_cmd, '-o', output])
++ args = self._linker_cmd.split()
++ args.extend(['-o', output])
+ if libtool:
+ args.append('-export-dynamic')
+
+--
+cgit v0.8.3.1
diff --git a/main/gobject-introspection/002-ccache.patch b/main/gobject-introspection/002-ccache.patch
new file mode 100644
index 000000000..9e9b69a9d
--- /dev/null
+++ b/main/gobject-introspection/002-ccache.patch
@@ -0,0 +1,21 @@
+From a09298e2638282e8529c554704a2493006af379f Mon Sep 17 00:00:00 2001
+From: Colin Walters <walters@verbum.org>
+Date: Fri, 22 Oct 2010 16:54:29 +0000
+Subject: Fix previous commit
+
+---
+diff --git a/giscanner/dumper.py b/giscanner/dumper.py
+index 7462aa3..e44f4f4 100644
+--- a/giscanner/dumper.py
++++ b/giscanner/dumper.py
+@@ -200,7 +200,7 @@ class DumpCompiler(object):
+ args.append('--tag=CC')
+ args.append('--silent')
+
+- args = self._linker_cmd.split()
++ args.extend(self._linker_cmd.split())
+ args.extend(['-o', output])
+ if libtool:
+ args.append('-export-dynamic')
+--
+cgit v0.8.3.1
diff --git a/main/gobject-introspection/APKBUILD b/main/gobject-introspection/APKBUILD
index 432001536..4fce9875d 100644
--- a/main/gobject-introspection/APKBUILD
+++ b/main/gobject-introspection/APKBUILD
@@ -1,13 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gobject-introspection
pkgver=0.9.12
-pkgrel=0
+pkgrel=1
pkgdesc="Introspection system for GObject-based libraries"
url="http://live.gnome.org/GObjectInstrospection"
license="LGPL GPL"
makedepends="flex bison glib-dev libffi-dev python-dev libtool"
depends="python glib-dev libffi-dev cairo-dev"
-source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ 001-ccache.patch
+ 002-ccache.patch"
# since this is a dev package by definition we dont bother separate -dev
subpackages="$pkgname-doc libgirepository"
@@ -45,4 +47,6 @@ libgirepository() {
mv "$pkgdir"/usr/lib/libgirepository*.so* "$subpkgdir"/usr/lib/
}
-md5sums="260ba5e77b5c0de0e7d8faf63ecbfee7 gobject-introspection-0.9.12.tar.bz2"
+md5sums="260ba5e77b5c0de0e7d8faf63ecbfee7 gobject-introspection-0.9.12.tar.bz2
+4ad235a1372f247f6df83a548ad4a331 001-ccache.patch
+13c587cda7bbb12402ed43dbd7161310 002-ccache.patch"