summaryrefslogtreecommitdiffstats
path: root/main/gst-plugins-ugly1
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-04 08:02:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-04 08:02:14 +0000
commitf3633b129534bf3eb502de242916fd4a612631ff (patch)
tree259293a5d9c9ba65f50eb65309f7280dec25a0bb /main/gst-plugins-ugly1
parent537e18b91b2b0b9cb62e285ea60c9fc8883e7546 (diff)
downloadaports-f3633b129534bf3eb502de242916fd4a612631ff.tar.bz2
aports-f3633b129534bf3eb502de242916fd4a612631ff.tar.xz
main/gst-*1,gstreamer1: moved from testing
Diffstat (limited to 'main/gst-plugins-ugly1')
-rw-r--r--main/gst-plugins-ugly1/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/main/gst-plugins-ugly1/APKBUILD b/main/gst-plugins-ugly1/APKBUILD
new file mode 100644
index 000000000..417bfff72
--- /dev/null
+++ b/main/gst-plugins-ugly1/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gst-plugins-ugly1
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="GStreamer Multimedia Framework Ugly Plugins (gst-plugins-ugly)"
+url="http://gstreamer.freedesktop.org/"
+arch="all"
+license="LGPL"
+depends=
+makedepends="
+ a52dec-dev
+ glib-dev
+ gst-plugins-base1-dev
+ gstreamer1-dev
+ lame-dev
+ libcdio-dev
+ libdvdread-dev
+ libid3tag-dev
+ libmad-dev
+ libmpeg2-dev
+ liboil-dev
+ orc-dev
+ x264-dev
+ "
+source="http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+ldpath="/usr/lib/gstreamer-1.0"
+
+_builddir="$srcdir"/gst-plugins-ugly-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --enable-experimental \
+ --with-package-name="GStreamer Ugly Plugins (Alpine Linux)" \
+ --with-package-origin="http://alpinelinux.org/" || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name '*.la' -delete
+}
+md5sums="7f20303caf4305278573fb7ef73a07b7 gst-plugins-ugly-1.0.0.tar.xz"