summaryrefslogtreecommitdiffstats
path: root/main/guile
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-30 07:56:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-30 13:44:37 +0000
commit4ce598e0e91cf9ecb264d0ea5522f4078f23caaf (patch)
tree6ce02cc007473e451a66d9660bf6de2ece164141 /main/guile
parentceddc2cfc53ec9838a81ccf6408e6cf345daf9bf (diff)
downloadaports-4ce598e0e91cf9ecb264d0ea5522f4078f23caaf.tar.bz2
aports-4ce598e0e91cf9ecb264d0ea5522f4078f23caaf.tar.xz
main/guile: build fix for gcc-4.5
Diffstat (limited to 'main/guile')
-rw-r--r--main/guile/APKBUILD26
-rw-r--r--main/guile/guile-1.8.7-gcc45.patch15
2 files changed, 36 insertions, 5 deletions
diff --git a/main/guile/APKBUILD b/main/guile/APKBUILD
index 6283d7e34..8a1bd6e5d 100644
--- a/main/guile/APKBUILD
+++ b/main/guile/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=guile
pkgver=1.8.7
-pkgrel=3
+pkgrel=4
pkgdesc="Guile is a portable, embeddable Scheme implementation written in C"
url="http://www.gnu.org/software/guile/"
license="GPL"
@@ -9,18 +9,34 @@ subpackages="$pkgname-dev $pkgname-doc"
makedepends="gmp-dev libtool ncurses-dev texinfo"
depends=
install=
-source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+source="ftp://ftp.gnu.org/pub/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ guile-1.8.7-gcc45.patch
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr \
--disable-error-on-warning || return 1
make LDFLAGS+="-lpthread" || return 1
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="991b5b3efcbbc3f7507d05bc42f80a5e guile-1.8.7.tar.gz"
+md5sums="991b5b3efcbbc3f7507d05bc42f80a5e guile-1.8.7.tar.gz
+608a4d2d7bc072d5edc34aa2be1f609f guile-1.8.7-gcc45.patch"
diff --git a/main/guile/guile-1.8.7-gcc45.patch b/main/guile/guile-1.8.7-gcc45.patch
new file mode 100644
index 000000000..6c9c2cd44
--- /dev/null
+++ b/main/guile/guile-1.8.7-gcc45.patch
@@ -0,0 +1,15 @@
+Fixing docs build with gcc-4.5
+
+http://bugs.gentoo.org/317175
+
+Patch scavenged from
+http://lists.gnu.org/archive/html/guile-devel/2009-11/msg00078.html
+
+--- ./libguile/guile-snarf-docs.in
++++ ./libguile/guile-snarf-docs.in
+@@ -23,4 +23,4 @@
+ ## Let the user override the preprocessor autoconf found.
+ test -n "${CPP+set}" || CPP="@CPP@"
+
+-${CPP} -DSCM_MAGIC_SNARF_DOCS "$@"
++${CPP} -P -DSCM_MAGIC_SNARF_DOCS "$@"