summaryrefslogtreecommitdiffstats
path: root/main/icecast
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-16 12:03:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-16 12:03:58 +0000
commitd82e502b6322313f28d8f78e959162dc43055a18 (patch)
tree4d9b545839106e96dd8d624830c9006dcf41deea /main/icecast
parentedbb3a0c527c339a69ea5c46dfedc88596eb61ed (diff)
downloadaports-d82e502b6322313f28d8f78e959162dc43055a18.tar.bz2
aports-d82e502b6322313f28d8f78e959162dc43055a18.tar.xz
main/icecast: moved from testing
Diffstat (limited to 'main/icecast')
-rw-r--r--main/icecast/APKBUILD49
-rw-r--r--main/icecast/conf-change-owner.patch16
-rw-r--r--main/icecast/icecast.confd1
-rw-r--r--main/icecast/icecast.initd19
-rw-r--r--main/icecast/icecast.pre-install5
5 files changed, 90 insertions, 0 deletions
diff --git a/main/icecast/APKBUILD b/main/icecast/APKBUILD
new file mode 100644
index 000000000..80e23f14c
--- /dev/null
+++ b/main/icecast/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=icecast
+pkgver=2.3.2
+pkgrel=5
+pkgdesc="Open source media server"
+url="http://www.icecast.org"
+arch="all"
+license="GPL"
+depends=
+install="$pkgname.pre-install"
+pkgusers="icecast"
+pkggroups="icecast"
+makedepends="libxslt-dev libxml2-dev libogg-dev libvorbis-dev libtheora-dev openssl-dev"
+subpackages="$pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz
+ conf-change-owner.patch
+ icecast.initd
+ icecast.confd"
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i "$srcdir"/conf-change-owner.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D -m755 ../icecast.initd "$pkgdir"/etc/init.d/icecast
+ install -D -m755 ../icecast.confd "$pkgdir"/etc/conf.d/icecast
+ install -d -D -o icecast -g icecast "$pkgdir"/var/log/icecast
+}
+
+md5sums="ff516b3ccd2bcc31e68f460cd316093f icecast-2.3.2.tar.gz
+d65fe756a3811e21fd8327ec599206c8 conf-change-owner.patch
+9860c914e30d0cfac45eef4cc4e81535 icecast.initd
+37ceeb26f61551e712364a2dffa8c208 icecast.confd"
diff --git a/main/icecast/conf-change-owner.patch b/main/icecast/conf-change-owner.patch
new file mode 100644
index 000000000..5c87c1f0d
--- /dev/null
+++ b/main/icecast/conf-change-owner.patch
@@ -0,0 +1,16 @@
+--- icecast-2.3.2/conf/icecast.xml.in.orig
++++ icecast-2.3.2/conf/icecast.xml.in
+@@ -164,11 +164,9 @@
+
+ <security>
+ <chroot>0</chroot>
+- <!--
+ <changeowner>
+- <user>nobody</user>
+- <group>nogroup</group>
++ <user>icecast</user>
++ <group>icecast</group>
+ </changeowner>
+- -->
+ </security>
+ </icecast>
diff --git a/main/icecast/icecast.confd b/main/icecast/icecast.confd
new file mode 100644
index 000000000..80cdfc57f
--- /dev/null
+++ b/main/icecast/icecast.confd
@@ -0,0 +1 @@
+ICEC_OPTS="-b -c ${icecast_conf:-/etc/icecast.xml}"
diff --git a/main/icecast/icecast.initd b/main/icecast/icecast.initd
new file mode 100644
index 000000000..b30027b2f
--- /dev/null
+++ b/main/icecast/icecast.initd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting Icecast 2"
+ start-stop-daemon --start --exec /usr/bin/icecast \
+ -- ${ICEC_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Icecast 2"
+ start-stop-daemon --stop --exec /usr/bin/icecast
+ eend $?
+}
diff --git a/main/icecast/icecast.pre-install b/main/icecast/icecast.pre-install
new file mode 100644
index 000000000..7149ba723
--- /dev/null
+++ b/main/icecast/icecast.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+adduser -h /var/log/icecast -s /bin/false -D icecast 2>/dev/null
+
+exit 0