summaryrefslogtreecommitdiffstats
path: root/main/icu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-09 12:11:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-11 15:04:39 +0000
commit903badd01cd570da8877446a84c7b33dc445bb1a (patch)
tree0467ec1c2b9883d26f46b029a92b89bcf4babb42 /main/icu
parente9b78f6a340cb0902aa8979b3076749fa5b9e0d0 (diff)
downloadaports-903badd01cd570da8877446a84c7b33dc445bb1a.tar.bz2
aports-903badd01cd570da8877446a84c7b33dc445bb1a.tar.xz
main/icu: upgrade to 49.1.1
Diffstat (limited to 'main/icu')
-rw-r--r--main/icu/APKBUILD10
-rw-r--r--main/icu/cve-2011-4599.patch20
-rw-r--r--main/icu/icu-timezone-uclibc.patch11
3 files changed, 16 insertions, 25 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index 948c581ec..fc3ce98ab 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -1,11 +1,11 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=icu
-pkgver=4.8.1.1
+pkgver=49.1.1
# convert x.y.z to x_y_z
_ver=${pkgver//./_}
-pkgrel=1
+pkgrel=0
pkgdesc="International Components for Unicode library"
url="http://www.icu-project.org/"
arch="all"
@@ -14,7 +14,7 @@ subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends=
source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz
- cve-2011-4599.patch
+ icu-timezone-uclibc.patch
"
_builddir="$srcdir"/icu/source
@@ -53,5 +53,5 @@ package() {
install -Dm644 "$srcdir"/icu/license.html \
"$pkgdir"/usr/share/licenses/icu/license.html
}
-md5sums="ea93970a0275be6b42f56953cd332c17 icu4c-4_8_1_1-src.tgz
-f6798a48ee00015e2d5351a3c7a3bafe cve-2011-4599.patch"
+md5sums="7c53f83e0327343f4060c0eb83842daf icu4c-49_1_1-src.tgz
+70aabd2c1e14477cfa261e729ffd7054 icu-timezone-uclibc.patch"
diff --git a/main/icu/cve-2011-4599.patch b/main/icu/cve-2011-4599.patch
deleted file mode 100644
index 4243370c9..000000000
--- a/main/icu/cve-2011-4599.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./common/uloc.c.orig
-+++ ./common/uloc.c
-@@ -1797,7 +1797,7 @@
- int32_t variantLen = _deleteVariant(variant, uprv_min(variantSize, (nameCapacity-len)), variantToCompare, n);
- len -= variantLen;
- if (variantLen > 0) {
-- if (name[len-1] == '_') { /* delete trailing '_' */
-+ if (len > 0 && name[len-1] == '_') { /* delete trailing '_' */
- --len;
- }
- addKeyword = VARIANT_MAP[j].keyword;
-@@ -1805,7 +1805,7 @@
- break;
- }
- }
-- if (name[len-1] == '_') { /* delete trailing '_' */
-+ if (len > 0 && name[len-1] == '_') { /* delete trailing '_' */
- --len;
- }
- }
diff --git a/main/icu/icu-timezone-uclibc.patch b/main/icu/icu-timezone-uclibc.patch
new file mode 100644
index 000000000..c3ea0bd45
--- /dev/null
+++ b/main/icu/icu-timezone-uclibc.patch
@@ -0,0 +1,11 @@
+--- ./common/putil.cpp.orig
++++ ./common/putil.cpp
+@@ -633,7 +633,7 @@
+ U_CAPI int32_t U_EXPORT2
+ uprv_timezone()
+ {
+-#ifdef U_TIMEZONE
++#if defined(U_TIMEZONE) && !defined(__UCLIBC__)
+ return U_TIMEZONE;
+ #else
+ time_t t, t1, t2;