summaryrefslogtreecommitdiffstats
path: root/main/icu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-07-24 08:01:31 +0000
commitb70981b68efcce5256eb11c6cd26ae123b10b6ea (patch)
treea38be6efae5e2ba15c2e839504632f9b7bfd5f91 /main/icu
parent2b4df81538b8398442d5296650905c70341dd8d3 (diff)
downloadaports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.bz2
aports-b70981b68efcce5256eb11c6cd26ae123b10b6ea.tar.xz
moved extra/* to main/
and fixed misc build issues
Diffstat (limited to 'main/icu')
-rw-r--r--main/icu/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
new file mode 100644
index 000000000..c2150b3ec
--- /dev/null
+++ b/main/icu/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=icu
+pkgver=4.2.1
+_ver=4_2_1
+pkgrel=0
+pkgdesc="International Components for Unicode library"
+url="http://www.icu-project.org/"
+license="custom:icu"
+subpackages="$pkgname-dev $pkgname-doc"
+depends=""
+makedepends="uclibc++-dev"
+source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz"
+
+build ()
+{
+ cd "$srcdir"/icu/source
+ export CXX=g++-uc
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make || return 1
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ chmod +x "$pkgdir"/usr/bin/icu-config
+ install -Dm644 "$srcdir"/icu/license.html \
+ "$pkgdir"/usr/share/licenses/icu/license.html
+}
+md5sums="e3738abd0d3ce1870dc1fd1f22bba5b1 icu4c-4_2_1-src.tgz"