summaryrefslogtreecommitdiffstats
path: root/main/imake
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-17 11:07:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-17 11:07:47 +0000
commit672e98e1970eb737fde64c48ff3e160b8f1af937 (patch)
tree43d1ec5c121cc41859afb09737071836f37b32bc /main/imake
parent26e8092e7166c8d3b9ae83faff2e84c32ad30158 (diff)
downloadaports-672e98e1970eb737fde64c48ff3e160b8f1af937.tar.bz2
aports-672e98e1970eb737fde64c48ff3e160b8f1af937.tar.xz
main/imake: move from testing
Diffstat (limited to 'main/imake')
-rw-r--r--main/imake/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/imake/APKBUILD b/main/imake/APKBUILD
new file mode 100644
index 000000000..e74c114b5
--- /dev/null
+++ b/main/imake/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=imake
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="X Windows make utility"
+url="http://www.x.org"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="xproto util-macros $depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ftp.x.org/pub/individual/util/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d5058b1317a85bedc1dc40c7e85c8d26 imake-1.0.6.tar.bz2"
+sha256sums="fa8983fdb0a72ba8482d1d2683967fb45c29edd7149b25f619f97ea5a599069d imake-1.0.6.tar.bz2"
+sha512sums="5e0744903c8b044fac98859fee1d15fe1db4b8346a1b1fd0c8c8a683914c3a83a2d18316cadf1ab7ee455004b761c1fa7808bdf48bbfb9e7cbe6c7c143ad2f43 imake-1.0.6.tar.bz2"