summaryrefslogtreecommitdiffstats
path: root/main/ldoc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-31 10:20:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-02 07:16:19 +0000
commit41729940a74e113929d0d9c0aa68e25b32c22cb4 (patch)
tree3d4a44351243199e1df14e49ebdcfe265c2463e7 /main/ldoc
parentf9707eb97a564b162f5599980edc456768ac25df (diff)
downloadaports-41729940a74e113929d0d9c0aa68e25b32c22cb4.tar.bz2
aports-41729940a74e113929d0d9c0aa68e25b32c22cb4.tar.xz
main/ldoc: moved from testing
Diffstat (limited to 'main/ldoc')
-rw-r--r--main/ldoc/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/main/ldoc/APKBUILD b/main/ldoc/APKBUILD
new file mode 100644
index 000000000..dd1af00f0
--- /dev/null
+++ b/main/ldoc/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=ldoc
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Documentation tool for Lua"
+url="http://github.com/stevedonovan/LDoc"
+arch="noarch"
+license="MIT"
+depends="lua$_luaver-penlight lua$_luaver"
+makedepends=""
+install=""
+subpackages=
+source="LDoc-$pkgver.tar.gz::https://github.com/stevedonovan/LDoc/archive/$pkgver.tar.gz"
+
+_luashare=/usr/share/lua/$_luaver
+_builddir="$srcdir"/LDoc-$pkgver
+prepare() {
+ local i
+ cd "$_builddir" || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ sed -i "1s:.*:#!/usr/bin/lua$_luaver:" ldoc.lua
+}
+
+build() {
+ cd "$_builddir"
+ find -type d | xargs chmod 755
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 ldoc.lua "$pkgdir"/usr/bin/ldoc || return 1
+ install -d "$pkgdir"/$_luashare || return 1
+ cp -a ldoc "$pkgdir"/$_luashare/
+}
+
+md5sums="b6643cb575b50cba4c3ae8694e9f0bab LDoc-1.4.0.tar.gz"
+sha256sums="e6eeaa3f068fc8cadc66ced2492727c0bd7246117998a6d528d041891b7d12d5 LDoc-1.4.0.tar.gz"
+sha512sums="410a129c021fdc959b73efbc2be1ac849d1eebce332a4ae4655cc9957730199ec9bdf3aacc7dd1a650e8c8c139bce27e79fdf0720579045c419353ccb675008e LDoc-1.4.0.tar.gz"