summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-27 11:47:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-27 11:47:25 +0000
commit3161576d06aa52a0dfbfdc13a539fa6d14100855 (patch)
tree87254a0a2d68f0aa1b9ec1bfea4dd07b41f7ee4c /main/libc0.9.32
parentb1a46b89ef69924ffcc45e22618ff6727c8c2da1 (diff)
downloadaports-3161576d06aa52a0dfbfdc13a539fa6d14100855.tar.bz2
aports-3161576d06aa52a0dfbfdc13a539fa6d14100855.tar.xz
main/libc0.9.32: fix eventfd syscall
<tteras> old kernels have only eventfd() <tteras> they noticed uh oh, we need add a new parameter <tteras> so there's eventfd2() syscall <tteras> when it was added to glibc <tteras> eventfd2 was already there <tteras> so the glibc call got name eventfd() even though it had signature of syscall eventfd2() <ncopa> so they picked eventfd() <tteras> yeah <ncopa> doh Requires 2.6.27+ kernel. The old eventfd() syscall, is not really usable and emulation is not feasible.
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/eventfd.patch14
2 files changed, 17 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index e108975c4..0f282158e 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.1
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -32,6 +32,7 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.xz
0006-malloc-standard-synchronize-on-fork.patch
0007-libc-x86-fix-stack-unwinding-and-backtrace-informati.patch
0008-ldso-limited-support-for-ORIGIN-in-rpath.patch
+eventfd.patch
uclibcconfig.x86
@@ -135,6 +136,7 @@ d8e62f8016274fc8605e6f77d4def79e 0005-stdlib-fix-arc4random-return-type-to-u_in
235ca36ca8c10878d63d68ba61f76634 0006-malloc-standard-synchronize-on-fork.patch
d9611de57fb72b74c0b9e243b8e9165b 0007-libc-x86-fix-stack-unwinding-and-backtrace-informati.patch
12cf5330b092ee7e00d14909737abc70 0008-ldso-limited-support-for-ORIGIN-in-rpath.patch
+a86eb40e8aca531a1cfee5faff3c53d4 eventfd.patch
20bfe471ee26f613834ebab0f68af28f uclibcconfig.x86
b1207627da796c653dda93ec261a72fa uclibcconfig.x86_64
20bfe471ee26f613834ebab0f68af28f uclibcconfig.i486
diff --git a/main/libc0.9.32/eventfd.patch b/main/libc0.9.32/eventfd.patch
new file mode 100644
index 000000000..930521eaa
--- /dev/null
+++ b/main/libc0.9.32/eventfd.patch
@@ -0,0 +1,14 @@
+diff --git a/libc/sysdeps/linux/common/eventfd.c b/libc/sysdeps/linux/common/eventfd.c
+index cc3f3f0..06a26ee 100644
+--- a/libc/sysdeps/linux/common/eventfd.c
++++ b/libc/sysdeps/linux/common/eventfd.c
+@@ -14,5 +14,9 @@
+ * eventfd()
+ */
+ #ifdef __NR_eventfd
++#ifdef __NR_eventfd2
++#undef __NR_eventfd
++#define __NR_eventfd __NR_eventfd2
++#endif
+ _syscall2(int, eventfd, int, count, int, flags)
+ #endif