summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-25 11:38:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-25 11:38:58 +0000
commit57c63f042b68d4481b9200423c8e8c52b18f38da (patch)
tree411c3fa820ac86fb8879944763eb1481250a281a /main/libc0.9.32
parent990f15b729b6ca58b3fd5024ad3a6dd8987a6389 (diff)
downloadaports-57c63f042b68d4481b9200423c8e8c52b18f38da.tar.bz2
aports-57c63f042b68d4481b9200423c8e8c52b18f38da.tar.xz
main/libc0.9.32: add fegetround for x86_64
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/0001-libm-x86_64-implement-fegetround.patch50
-rw-r--r--main/libc0.9.32/APKBUILD7
2 files changed, 56 insertions, 1 deletions
diff --git a/main/libc0.9.32/0001-libm-x86_64-implement-fegetround.patch b/main/libc0.9.32/0001-libm-x86_64-implement-fegetround.patch
new file mode 100644
index 000000000..cb0a4a17d
--- /dev/null
+++ b/main/libc0.9.32/0001-libm-x86_64-implement-fegetround.patch
@@ -0,0 +1,50 @@
+From a66161f44853403b2cf464de08753d4b5aa6d2dd Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Thu, 25 Apr 2013 11:28:37 +0000
+Subject: [PATCH] libm/x86_64: implement fegetround
+
+---
+ libm/x86_64/fegetround.c | 31 +++++++++++++++++++++++++++++++
+ 1 file changed, 31 insertions(+)
+ create mode 100644 libm/x86_64/fegetround.c
+
+diff --git a/libm/x86_64/fegetround.c b/libm/x86_64/fegetround.c
+new file mode 100644
+index 0000000..8ae0c3a
+--- /dev/null
++++ b/libm/x86_64/fegetround.c
+@@ -0,0 +1,31 @@
++/* Return current rounding direction.
++ Copyright (C) 1997 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++ Contributed by Ulrich Drepper <drepper@cygnus.com>, 1997.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#include <fenv.h>
++
++int
++fegetround (void)
++{
++ int cw;
++
++ __asm__ ("fnstcw %0" : "=m" (*&cw));
++
++ return cw & 0xc00;
++}
+--
+1.8.2.1
+
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 0cd147d80..18045134e 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=15
+pkgrel=16
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -58,6 +58,8 @@ librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
uclibc-rtld_next-fix.patch
560-res_init_asterisk.patch
+ 0001-libm-x86_64-implement-fegetround.patch
+
uclibcconfig.x86
uclibcconfig.x86_64
uclibcconfig.i486
@@ -197,6 +199,7 @@ da043a65003ac29ca8b96f416e7752ee 0002-libc-sysdeps-add-get-make-set-swap-contex
8374c98e769e603af4adad12e01cf358 uclibc-dlclose-fix.patch
ffe7564afe846026a278dd8c0251ace9 uclibc-rtld_next-fix.patch
1c4199349874608161575f047c32be02 560-res_init_asterisk.patch
+2e27c00c1af216eb5fb3aef81d7ba515 0001-libm-x86_64-implement-fegetround.patch
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.x86
e861a17baa541accf4d4d39a98d74c32 uclibcconfig.x86_64
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.i486
@@ -230,6 +233,7 @@ ba5b0cb1c42bb221a38cc3b22e150a08e64952716d24a4af3b61036b23d60bfd 0003-pread-pwr
08bfb952464d1b3876d88f38929e8c98c074e40579685733e21612442ed0472e uclibc-dlclose-fix.patch
16ace72a805b39a623364cfd1e884e6d9f19bb85f650a03712e4104533f5186f uclibc-rtld_next-fix.patch
d7f11efbce5c4ef27849e7a3cd370be86540c635effd51d5374194b65c7c7e83 560-res_init_asterisk.patch
+b4cd24a506f4f286144080b3e95a2999efb4ec58e759255e82e09a1d7c353549 0001-libm-x86_64-implement-fegetround.patch
7f613b473adbbf38701125f3d298d11f91e102e5cda17eec8133e8463bdc10c9 uclibcconfig.x86
bec76f2c67c0c632b24bb8c3db01396cc56f208a8c5ca16543fd5e71050d8c88 uclibcconfig.x86_64
7f613b473adbbf38701125f3d298d11f91e102e5cda17eec8133e8463bdc10c9 uclibcconfig.i486
@@ -263,6 +267,7 @@ f5ef0feac6b036062d2c6c346a12e71850c183233678979008aa70d5fb4da9adc7ae561ba42cb299
f6de454c16a56c5978b9e840440baf4b17cd92c30191407fd371a88a5764ea3f119a5b639ca9aab57fc3e08ab5f94eefdcca4e84bd63a71788cb8ee50531af0c uclibc-dlclose-fix.patch
8068fb6f40c370f3fd6cf05f39c0d8f54adb442faf279fa14a7f7d0e14a49f9220aacae9617460ccea71824e2f1272faf5bf1dab12ffeeb42129869c8b61c30d uclibc-rtld_next-fix.patch
3d06e204dcca1f570356c42b9a3265448217668db7df4c9641dccd14190d7578df8be1fc1a6d7824544736348bd54f816d10b49b860b9c390d109803f3ea5b6a 560-res_init_asterisk.patch
+72e1aa3bb6b97c86d2539c370d47da5aa6b9ef80f1514229bf6acb366f91b87b55207c904f228cce6156cba8b10cf1318d00a69f677e498235ac69f10bf5c240 0001-libm-x86_64-implement-fegetround.patch
ab04402abefad1f239d27d9638c1d8d76bc6a8edd77bbb8ed5a4b1445dbc44d709bb1b5214fc9a37a2208c2b6e92dd0a147eddea5d0b2e1ca3ec227432fe86eb uclibcconfig.x86
063899afb5f3c20e5dae1b613aa8963408b66ef21228df2500366163aeda71ca4163cbef8c3e53f389ba4a85b8eec5991667cdb31576141ce2ccbc1dc3d33cab uclibcconfig.x86_64
ab04402abefad1f239d27d9638c1d8d76bc6a8edd77bbb8ed5a4b1445dbc44d709bb1b5214fc9a37a2208c2b6e92dd0a147eddea5d0b2e1ca3ec227432fe86eb uclibcconfig.i486