summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-27 18:45:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-27 18:45:07 +0000
commit57e08ebf665e034d75ff86bbd92bcd3b71ca3869 (patch)
treef63aab8b30f4a751b9634e762e91e95484db1790 /main/libc0.9.32
parent7bcfb77d399b529354975b5d1e61c520007847e5 (diff)
downloadaports-57e08ebf665e034d75ff86bbd92bcd3b71ca3869.tar.bz2
aports-57e08ebf665e034d75ff86bbd92bcd3b71ca3869.tar.xz
main/libc0.9.32: backport fix of pread/pwrite syscalls
fixes issue with git 1.7.11
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD7
-rw-r--r--main/libc0.9.32/pread.patch207
2 files changed, 213 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 5801781c6..b10c8d9fb 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=3
+pkgrel=4
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -35,6 +35,7 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.xz
eventfd.patch
uClibc-0.9.33-avahi.patch
0001-libc-add-posix_fallocate.patch
+ pread.patch
uclibcconfig.x86
uclibcconfig.x86_64
@@ -43,6 +44,9 @@ uClibc-0.9.33-avahi.patch
uclibcconfig.powerpc
uclibc-utils.trigger
"
+#pread-rename.patch
+#pread-remove-fallback.patch
+#pread-cancellable.patch
_config="$srcdir"/uclibcconfig.${CARCH}
_builddir="$srcdir"/uClibc-${_ver}
@@ -140,6 +144,7 @@ d9611de57fb72b74c0b9e243b8e9165b 0007-libc-x86-fix-stack-unwinding-and-backtrac
a86eb40e8aca531a1cfee5faff3c53d4 eventfd.patch
d91fcb785ae14632a4ea8fa03ba0236f uClibc-0.9.33-avahi.patch
08297e76052108d95303efe7d8745444 0001-libc-add-posix_fallocate.patch
+1cc5c5f3f1d2a66c0ab0f8585627faa9 pread.patch
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.x86
e861a17baa541accf4d4d39a98d74c32 uclibcconfig.x86_64
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.i486
diff --git a/main/libc0.9.32/pread.patch b/main/libc0.9.32/pread.patch
new file mode 100644
index 000000000..443d3b561
--- /dev/null
+++ b/main/libc0.9.32/pread.patch
@@ -0,0 +1,207 @@
+pread/pwrite syscalls has been renamed to pread64/pwrite in 2.6 kernel.
+
+There was a fallback function using lseek for kernels who did not have
+this syscall (pre 2.1.60). This is broken in many ways.
+
+uclibc have been using the broken fallback due to they forgot to rename
+pread syscall.
+
+This got detected with git-1.7.11 which introduced threaded index-pack
+which broke in similar ways a windows (msys).
+
+This issue in uclibc have been reported upstream and fixed in git master
+so this patch does not need to be upstreamed. It might be an idea to
+backport it properly for 0.9.33 branch though.
+
+
+diff --git a/libc/sysdeps/linux/common/pread_write.c b/libc/sysdeps/linux/common/pread_write.c
+index 88e6957..9fa7cab 100644
+--- a/libc/sysdeps/linux/common/pread_write.c
++++ b/libc/sysdeps/linux/common/pread_write.c
+@@ -17,6 +17,7 @@
+ #include <unistd.h>
+ #include <stdint.h>
+ #include <endian.h>
++#include <sysdep-cancel.h>
+
+ extern __typeof(pread) __libc_pread;
+ extern __typeof(pwrite) __libc_pwrite;
+@@ -27,15 +28,17 @@ extern __typeof(pwrite64) __libc_pwrite64;
+
+ #include <bits/kernel_types.h>
+
+-#ifdef __NR_pread
+-
+-# define __NR___syscall_pread __NR_pread
++# define __NR___syscall_pread __NR_pread64
+ static __inline__ _syscall5(ssize_t, __syscall_pread, int, fd, void *, buf,
+ size_t, count, off_t, offset_hi, off_t, offset_lo)
+
+ ssize_t __libc_pread(int fd, void *buf, size_t count, off_t offset)
+ {
+- return __syscall_pread(fd, buf, count, __LONG_LONG_PAIR(offset >> 31, offset));
++ int oldtype = LIBC_CANCEL_ASYNC ();
++ int result = __syscall_pread(fd, buf, count, __LONG_LONG_PAIR(offset >> 31, offset));
++ LIBC_CANCEL_RESET (oldtype);
++ return result;
++
+ }
+ weak_alias(__libc_pread,pread)
+
+@@ -44,22 +47,24 @@ ssize_t __libc_pread64(int fd, void *buf, size_t count, off64_t offset)
+ {
+ uint32_t low = offset & 0xffffffff;
+ uint32_t high = offset >> 32;
+- return __syscall_pread(fd, buf, count, __LONG_LONG_PAIR(high, low));
++ int oldtype = LIBC_CANCEL_ASYNC ();
++ int result = __syscall_pread(fd, buf, count, __LONG_LONG_PAIR(high, low));
++ LIBC_CANCEL_RESET (oldtype);
++ return result;
+ }
+ weak_alias(__libc_pread64,pread64)
+ # endif /* __UCLIBC_HAS_LFS__ */
+
+-#endif /* __NR_pread */
+-
+-#ifdef __NR_pwrite
+-
+-# define __NR___syscall_pwrite __NR_pwrite
++# define __NR___syscall_pwrite __NR_pwrite64
+ static __inline__ _syscall5(ssize_t, __syscall_pwrite, int, fd, const void *, buf,
+ size_t, count, off_t, offset_hi, off_t, offset_lo)
+
+ ssize_t __libc_pwrite(int fd, const void *buf, size_t count, off_t offset)
+ {
+- return __syscall_pwrite(fd, buf, count, __LONG_LONG_PAIR(offset >> 31, offset));
++ int oldtype = LIBC_CANCEL_ASYNC ();
++ int result = __syscall_pwrite(fd, buf, count, __LONG_LONG_PAIR(offset >> 31, offset));
++ LIBC_CANCEL_RESET (oldtype);
++ return result;
+ }
+ weak_alias(__libc_pwrite,pwrite)
+
+@@ -68,120 +73,11 @@ ssize_t __libc_pwrite64(int fd, const void *buf, size_t count, off64_t offset)
+ {
+ uint32_t low = offset & 0xffffffff;
+ uint32_t high = offset >> 32;
+- return __syscall_pwrite(fd, buf, count, __LONG_LONG_PAIR(high, low));
+-}
+-weak_alias(__libc_pwrite64,pwrite64)
+-# endif /* __UCLIBC_HAS_LFS__ */
+-#endif /* __NR_pwrite */
+-
+-#if ! defined __NR_pread || ! defined __NR_pwrite
+-
+-static ssize_t __fake_pread_write(int fd, void *buf,
+- size_t count, off_t offset, int do_pwrite)
+-{
+- int save_errno;
+- ssize_t result;
+- off_t old_offset;
+-
+- /* Since we must not change the file pointer preserve the
+- * value so that we can restore it later. */
+- if ((old_offset=lseek(fd, 0, SEEK_CUR)) == (off_t) -1)
+- return -1;
+-
+- /* Set to wanted position. */
+- if (lseek(fd, offset, SEEK_SET) == (off_t) -1)
+- return -1;
+-
+- if (do_pwrite == 1) {
+- /* Write the data. */
+- result = write(fd, buf, count);
+- } else {
+- /* Read the data. */
+- result = read(fd, buf, count);
+- }
+-
+- /* Now we have to restore the position. If this fails we
+- * have to return this as an error. */
+- save_errno = errno;
+- if (lseek(fd, old_offset, SEEK_SET) == (off_t) -1)
+- {
+- if (result == -1)
+- __set_errno(save_errno);
+- return -1;
+- }
+- __set_errno(save_errno);
+- return(result);
+-}
+-
+-# ifdef __UCLIBC_HAS_LFS__
+-
+-static ssize_t __fake_pread_write64(int fd, void *buf,
+- size_t count, off64_t offset, int do_pwrite)
+-{
+- int save_errno;
+- ssize_t result;
+- off64_t old_offset;
+-
+- /* Since we must not change the file pointer preserve the
+- * value so that we can restore it later. */
+- if ((old_offset=lseek64(fd, 0, SEEK_CUR)) == (off64_t) -1)
+- return -1;
+-
+- /* Set to wanted position. */
+- if (lseek64(fd, offset, SEEK_SET) == (off64_t) -1)
+- return -1;
+-
+- if (do_pwrite == 1) {
+- /* Write the data. */
+- result = write(fd, buf, count);
+- } else {
+- /* Read the data. */
+- result = read(fd, buf, count);
+- }
+-
+- /* Now we have to restore the position. */
+- save_errno = errno;
+- if (lseek64(fd, old_offset, SEEK_SET) == (off64_t) -1) {
+- if (result == -1)
+- __set_errno (save_errno);
+- return -1;
+- }
+- __set_errno (save_errno);
++ int oldtype = LIBC_CANCEL_ASYNC ();
++ int result = __syscall_pwrite(fd, buf, count, __LONG_LONG_PAIR(high, low));
++ LIBC_CANCEL_RESET (oldtype);
+ return result;
+ }
+-# endif /* __UCLIBC_HAS_LFS__ */
+-#endif /* ! defined __NR_pread || ! defined __NR_pwrite */
+-
+-#ifndef __NR_pread
+-ssize_t __libc_pread(int fd, void *buf, size_t count, off_t offset)
+-{
+- return __fake_pread_write(fd, buf, count, offset, 0);
+-}
+-weak_alias(__libc_pread,pread)
+-
+-# ifdef __UCLIBC_HAS_LFS__
+-ssize_t __libc_pread64(int fd, void *buf, size_t count, off64_t offset)
+-{
+- return __fake_pread_write64(fd, buf, count, offset, 0);
+-}
+-weak_alias(__libc_pread64,pread64)
+-# endif /* __UCLIBC_HAS_LFS__ */
+-#endif /* ! __NR_pread */
+-
+-#ifndef __NR_pwrite
+-ssize_t __libc_pwrite(int fd, const void *buf, size_t count, off_t offset)
+-{
+- /* we won't actually be modifying the buffer,
+- *just cast it to get rid of warnings */
+- return __fake_pread_write(fd, (void*)buf, count, offset, 1);
+-}
+-weak_alias(__libc_pwrite,pwrite)
+-
+-# ifdef __UCLIBC_HAS_LFS__
+-ssize_t __libc_pwrite64(int fd, const void *buf, size_t count, off64_t offset)
+-{
+- return __fake_pread_write64(fd, (void*)buf, count, offset, 1);
+-}
+ weak_alias(__libc_pwrite64,pwrite64)
+ # endif /* __UCLIBC_HAS_LFS__ */
+-#endif /* ! __NR_pwrite */
++