summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-02 14:11:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-02 14:11:25 +0000
commit5e9951fd11a29febad28c2bd1e4cd5486e4bc329 (patch)
tree945bead75d81a553c76b4c2bff6b1a7c8f98dfbf /main/libc0.9.32
parent8083a74b34a0d7b12e24bf15be3db5e77635e7b0 (diff)
downloadaports-5e9951fd11a29febad28c2bd1e4cd5486e4bc329.tar.bz2
aports-5e9951fd11a29febad28c2bd1e4cd5486e4bc329.tar.xz
main/libc0.9.32: upgrade to 0.9.32.1
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/0012-getaddrinfo-allow-numeric-service-without-any-hints.patch41
-rw-r--r--main/libc0.9.32/APKBUILD8
2 files changed, 3 insertions, 46 deletions
diff --git a/main/libc0.9.32/0012-getaddrinfo-allow-numeric-service-without-any-hints.patch b/main/libc0.9.32/0012-getaddrinfo-allow-numeric-service-without-any-hints.patch
deleted file mode 100644
index 2cb303a94..000000000
--- a/main/libc0.9.32/0012-getaddrinfo-allow-numeric-service-without-any-hints.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From eb5d129b641c644d82089c3ded3d36288c66123c Mon Sep 17 00:00:00 2001
-From: Natanael Copa <natanael.copa@gmail.com>
-Date: Sun, 12 Jun 2011 12:09:04 +0000
-Subject: [PATCH] getaddrinfo: allow numeric service without any hints
-
-This appears to correspond to what glibc does and this fixes an
-issue with iptables-1.4.11 with udp and raw port numbers.
-
-(see http://bugzilla.netfilter.org/show_bug.cgi?id=721)
-
-This fixes #3841
-https://bugs.busybox.net/show_bug.cgi?id=3841
-
-Signed-off-by: Natanael Copa <natanael.copa@gmail.com>
-Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
-(cherry picked from commit bc3be18145e4d57e7268506f123c0f0f373a15e2)
----
- libc/inet/getaddrinfo.c | 7 -------
- 1 files changed, 0 insertions(+), 7 deletions(-)
-
-diff --git a/libc/inet/getaddrinfo.c b/libc/inet/getaddrinfo.c
-index 1a77c51..e7511f6 100644
---- a/libc/inet/getaddrinfo.c
-+++ b/libc/inet/getaddrinfo.c
-@@ -820,13 +820,6 @@ getaddrinfo(const char *name, const char *service,
- if (hints->ai_flags & AI_NUMERICSERV)
- return EAI_NONAME;
- gaih_service.num = -1;
-- } else {
-- /*
-- * Can't specify a numerical socket unless a protocol
-- * family was given.
-- */
-- if (hints->ai_socktype == 0 && hints->ai_protocol == 0)
-- return EAI_SERVICE;
- }
- pservice = &gaih_service;
- } else
---
-1.7.8
-
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 6c6185ec7..0d0cb1215 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -2,9 +2,9 @@
_abiver=0.9.32
pkgname=libc$_abiver
_gitver=
-pkgver=0.9.32
+pkgver=0.9.32.1
_ver=${pkgver/_/-}
-pkgrel=15
+pkgrel=0
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -36,7 +36,6 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
0009-libdl-rudimentary-locking-for-dlopen-dlsym-dlclose.patch
0010-malloc-standard-synchronize-on-fork.patch
0011-time-fix-parsing-of-tzdata-files-where-off_t-is-64-b.patch
-0012-getaddrinfo-allow-numeric-service-without-any-hints.patch
0013-libc-x86-fix-stack-unwinding-and-backtrace-informati.patch
0014-libm-add-cabsf-and-cabsl-functions.patch
0015-libm-implement-generic-cexp-cexpf-and-cexpl.patch
@@ -141,7 +140,7 @@ libthread_db() {
mv "$pkgdir"/lib/libthread_db* "$subpkgdir"/lib/
}
-md5sums="cfcb6c25d8ebe12817499d8749ee8ae1 uClibc-0.9.32.tar.bz2
+md5sums="ade6e441242be5cdd735fec97954a54a uClibc-0.9.32.1.tar.bz2
11c206cd4be86514dd9abd811429ad06 0001-Compatible-stack-protector-for-non-Thread-Local-stor.patch
b905f5f0f27348cc91019275dcff51cb 0002-resolv-res_query-for-CNAMEs.patch
208f6ea0a97f2940319456d32549bfc5 0003-resolv-fix-memory-leak.patch
@@ -153,7 +152,6 @@ afafe88bca1ffc1d4eb49de813c39c5b 0007-stdlib-fix-arc4random-return-type-to-u_in
f0fc6dbeb1467812085b60a49654a955 0009-libdl-rudimentary-locking-for-dlopen-dlsym-dlclose.patch
a1c5871c3b799cce8d1dfcf8ca0f3743 0010-malloc-standard-synchronize-on-fork.patch
b2c09cdfc3116c6236dbe96697241a59 0011-time-fix-parsing-of-tzdata-files-where-off_t-is-64-b.patch
-ddd3073f1a2696c1a9b40bfa81bfa5bf 0012-getaddrinfo-allow-numeric-service-without-any-hints.patch
78cdafafc99007da8cbdf8d2f841ea47 0013-libc-x86-fix-stack-unwinding-and-backtrace-informati.patch
63af22efb20d9dfd3cb10bc9900f1615 0014-libm-add-cabsf-and-cabsl-functions.patch
7158d0ae15ca742cc1577b47735751df 0015-libm-implement-generic-cexp-cexpf-and-cexpl.patch