summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-11-02 08:48:35 +0200
committerTimo Teräs <timo.teras@iki.fi>2012-11-02 08:48:35 +0200
commit6954a3429933a6c8aa7110f5a11649ecf048d2c7 (patch)
tree61bf0d702517b22a40bc167eebcf0c62ecbe6af9 /main/libc0.9.32
parentb1638039e29283d0f0f1251f275f11fd904e8986 (diff)
downloadaports-6954a3429933a6c8aa7110f5a11649ecf048d2c7.tar.bz2
aports-6954a3429933a6c8aa7110f5a11649ecf048d2c7.tar.xz
main/libc0.9.32: dlsym(RTLD_NEXT) fix
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/STATUS18
2 files changed, 21 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 88fa0bf64..714e79598 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=13
+pkgrel=14
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -55,6 +55,7 @@ librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
uclibc-dlclose-fix.patch
+ uclibc-rtld_next-fix.patch
uclibcconfig.x86
uclibcconfig.x86_64
@@ -193,6 +194,7 @@ f41ab6cf22545d2e629d4c7107ac6f85 0009-sys-quota.h-sync-with-glibc.patch
e5aceb82bf4ffd5328113af5380fcdb6 0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
da043a65003ac29ca8b96f416e7752ee 0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
8374c98e769e603af4adad12e01cf358 uclibc-dlclose-fix.patch
+ffe7564afe846026a278dd8c0251ace9 uclibc-rtld_next-fix.patch
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.x86
e861a17baa541accf4d4d39a98d74c32 uclibcconfig.x86_64
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.i486
diff --git a/main/libc0.9.32/STATUS b/main/libc0.9.32/STATUS
index c457f2fef..155df167f 100644
--- a/main/libc0.9.32/STATUS
+++ b/main/libc0.9.32/STATUS
@@ -49,4 +49,22 @@
Needs to be upstreamed
+uclibc-dlclose-fix.patch
+ Origin: Alpine
+ Author: Timo Teräs
+
+ Fix dlclose() to not try to free static TLS symbols. This seems
+ to happen on x86_64 with certain .so's. They probably link against
+ TLS symbol defined in the main binary (or the loader has additional
+ bug on this).
+
+ Needs to be upstreamed
+uclibc-rtld_next-fix.patch
+ Origin: Alpine
+ Author: Timo Teräs
+
+ Fix dlsym(RTLD_NEXT) lookups to search all linked-in modules
+ instead of just the first one of them.
+
+ Needs to be upstreamed