summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-07 06:43:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-07 06:43:14 +0000
commit72dc3b5920c3cab4b8e562bb452fbccb3392e081 (patch)
tree6170c3a5dff60421ebd19183e85e48d5919d2dfe /main/libc0.9.32
parent31c2bc9c26bfe7545d60e1c56a8bc88f82033a7e (diff)
downloadaports-72dc3b5920c3cab4b8e562bb452fbccb3392e081.tar.bz2
aports-72dc3b5920c3cab4b8e562bb452fbccb3392e081.tar.xz
main/libc0.9.32
updated fix for resolv
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD6
-rw-r--r--main/libc0.9.32/resolv.patch13
-rw-r--r--main/libc0.9.32/uclibc-resolv-fix.patch22
3 files changed, 25 insertions, 16 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index d65397c52..355df1189 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=100427
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=3
+pkgrel=4
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -16,7 +16,7 @@ replaces=uclibc
source="
http://git.uclibc.org/uClibc/snapshot/master.tar.bz2
compat-stack-guard.patch
- resolv.patch
+ uclibc-resolv-fix.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -89,6 +89,6 @@ utils() {
md5sums="1189f8f739b1977a86b7afa8637e6827 master.tar.bz2
4d408f72142ce55a0754948cc9cfe447 compat-stack-guard.patch
-b12fcf44388db8b3331541234def9477 resolv.patch
+14d0d155887319f32f164da0bea48c9e uclibc-resolv-fix.patch
791e2fc050cab523ce1c907ca39a2486 uclibcconfig.x86
791e2fc050cab523ce1c907ca39a2486 uclibcconfig.i486"
diff --git a/main/libc0.9.32/resolv.patch b/main/libc0.9.32/resolv.patch
deleted file mode 100644
index 8b84177d1..000000000
--- a/main/libc0.9.32/resolv.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
-index 84289a6..5107dec 100644
---- a/libc/inet/resolv.c
-+++ b/libc/inet/resolv.c
-@@ -689,7 +689,7 @@ int attribute_hidden __decode_dotted(const unsigned char *packet,
-
- if (used + b + 1 >= dest_len)
- return -1;
-- if (offset + b + 1 >= packet_len)
-+ if (offset + b >= packet_len)
- return -1;
- memcpy(dest + used, packet + offset, b);
- offset += b;
diff --git a/main/libc0.9.32/uclibc-resolv-fix.patch b/main/libc0.9.32/uclibc-resolv-fix.patch
new file mode 100644
index 000000000..afde80df3
--- /dev/null
+++ b/main/libc0.9.32/uclibc-resolv-fix.patch
@@ -0,0 +1,22 @@
+diff --git a/libc/inet/resolv.c b/libc/inet/resolv.c
+index 84289a6..84a6b41 100644
+--- a/libc/inet/resolv.c
++++ b/libc/inet/resolv.c
+@@ -689,7 +689,7 @@ int attribute_hidden __decode_dotted(const unsigned char *packet,
+
+ if (used + b + 1 >= dest_len)
+ return -1;
+- if (offset + b + 1 >= packet_len)
++ if (offset + b >= packet_len)
+ return -1;
+ memcpy(dest + used, packet + offset, b);
+ offset += b;
+@@ -2456,7 +2456,7 @@ int gethostbyaddr_r(const void *addr, socklen_t addrlen,
+ char *dst = buf;
+ unsigned char *tp = (unsigned char *)addr + addrlen - 1;
+ do {
+- dst += sprintf(dst, "%x.%x.", tp[i] & 0xf, tp[i] >> 4);
++ dst += sprintf(dst, "%x.%x.", tp[0] & 0xf, tp[0] >> 4);
+ tp--;
+ } while (tp >= (unsigned char *)addr);
+ strcpy(dst, "ip6.arpa");