summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-03 07:49:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-03 08:08:33 +0000
commit98a000b8e92b3aa1e0b7a5f94a74910bb0993c4d (patch)
tree8d2a699cb4efa51fb99e8ac1a90ea9d51d48b2bb /main/libc0.9.32
parentcf929d706567c4b3b935c885d34dee7777a9428a (diff)
downloadaports-98a000b8e92b3aa1e0b7a5f94a74910bb0993c4d.tar.bz2
aports-98a000b8e92b3aa1e0b7a5f94a74910bb0993c4d.tar.xz
main/libc0.9.32: fix for SIGCANCEL from upstream
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch32
2 files changed, 35 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 072a79148..06edd5de8 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=8
+pkgrel=9
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -34,6 +34,7 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.xz
0008-ldso-limited-support-for-ORIGIN-in-rpath.patch
eventfd.patch
uClibc-0.9.33-avahi.patch
+librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
0001-add-posix_madvise.c.patch
posix_fallocate.patch
@@ -151,6 +152,7 @@ d9611de57fb72b74c0b9e243b8e9165b 0007-libc-x86-fix-stack-unwinding-and-backtrac
12cf5330b092ee7e00d14909737abc70 0008-ldso-limited-support-for-ORIGIN-in-rpath.patch
a86eb40e8aca531a1cfee5faff3c53d4 eventfd.patch
d91fcb785ae14632a4ea8fa03ba0236f uClibc-0.9.33-avahi.patch
+b99adbb951c35aec0a09930e12efab86 librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
f88dac5fe54a1bffce7d1ff4b53a755c 0001-add-posix_madvise.c.patch
ddc2778790a0f3537828c2c3dbcdb042 posix_fallocate.patch
a93a0e50e73bb6e8d8abf6e4340378b6 posix_fallocate-fix.patch
diff --git a/main/libc0.9.32/librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch b/main/libc0.9.32/librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
new file mode 100644
index 000000000..688d2f503
--- /dev/null
+++ b/main/libc0.9.32/librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
@@ -0,0 +1,32 @@
+From fec308fdfaf9f557ef5fb17c308c48259012b825 Mon Sep 17 00:00:00 2001
+From: Filippo Arcidiacono <filippo.arcidiacono@st.com>
+Date: Thu, 12 Jul 2012 07:24:39 +0000
+Subject: librt: re-add SIGCANCEL to the list of blocked signal in helper thread
+
+Indeed if the libpthread is before the libc in the library look up
+the SIGCANCEL is removed from the list of the blocked signal by
+sigfillset func, this can produce the handler not properly called.
+This commit revert what Denys modified in commit
+162cfaea20d807f0ae329efe39292a9b22593b41.
+
+Signed-off-by: Filippo Arcidiacono <filippo.arcidiacono@st.com>
+Signed-off-by: Carmelo Amoroso <carmelo.amoroso@st.com>
+(cherry picked from commit cb43f2afba0633400387fa7c55dda3396517f58a)
+
+Signed-off-by: Carmelo Amoroso <carmelo.amoroso@st.com>
+---
+diff --git a/libpthread/nptl/sysdeps/unix/sysv/linux/timer_routines.c b/libpthread/nptl/sysdeps/unix/sysv/linux/timer_routines.c
+index 4319d8d..2681961 100644
+--- a/libpthread/nptl/sysdeps/unix/sysv/linux/timer_routines.c
++++ b/libpthread/nptl/sysdeps/unix/sysv/linux/timer_routines.c
+@@ -175,7 +175,7 @@ __start_helper_thread (void)
+ sigset_t ss;
+ sigset_t oss;
+ sigfillset (&ss);
+- /*__sigaddset (&ss, SIGCANCEL); - already done by sigfillset */
++ __sigaddset (&ss, SIGCANCEL);
+ INTERNAL_SYSCALL_DECL (err);
+ INTERNAL_SYSCALL (rt_sigprocmask, err, 4, SIG_SETMASK, &ss, &oss, _NSIG / 8);
+
+--
+cgit v0.9.0.1-2-gef13