summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-30 08:40:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-30 08:40:09 +0000
commita698043a5c26a506b78e6d3c11ffc8114954f653 (patch)
tree1e9f744d8e20efd5f8ae303f3274b8cfb4e5a9c7 /main/libc0.9.32
parentcb081d863d10e8294f1d81910c59bb08c9f4768f (diff)
downloadaports-a698043a5c26a506b78e6d3c11ffc8114954f653.tar.bz2
aports-a698043a5c26a506b78e6d3c11ffc8114954f653.tar.xz
main/libc0.9.32: fix ucontext for i386
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch14
-rw-r--r--main/libc0.9.32/APKBUILD6
2 files changed, 11 insertions, 9 deletions
diff --git a/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch b/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
index 1292fce91..54038d59f 100644
--- a/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
+++ b/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
@@ -1,9 +1,11 @@
-From 647868c7ccfbe766445fc74ff7bcb1f9b76fdb0f Mon Sep 17 00:00:00 2001
+From cb079bffc0b93c75f2118f101add4d7d2259440b Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 29 Oct 2012 13:24:05 +0000
-Subject: [PATCH 1/2] libc/sysdeps: {get,make,set,swap}context for i386
+Subject: [PATCH] libc/sysdeps: {get,make,set,swap}context for i386
-crudely imported from glibc
+imported from glibc
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
Conflicts:
libc/sysdeps/linux/i386/Makefile.arch
@@ -174,7 +176,7 @@ index 0000000..3221b59
+weak_alias (__getcontext, getcontext)
diff --git a/libc/sysdeps/linux/i386/makecontext.S b/libc/sysdeps/linux/i386/makecontext.S
new file mode 100644
-index 0000000..0f68b57
+index 0000000..d12799d
--- /dev/null
+++ b/libc/sysdeps/linux/i386/makecontext.S
@@ -0,0 +1,123 @@
@@ -253,7 +255,7 @@ index 0000000..0f68b57
+ set the return address for the function the user provides
+ to a little bit of helper code which does the magic (see
+ below). */
-+#ifdef PIC
++#ifdef __PIC__
+ call 1f
+ cfi_adjust_cfa_offset (4)
+1: popl %ecx
@@ -280,7 +282,7 @@ index 0000000..0f68b57
+ parameters (see above). */
+ leal (%esp,%ebx,4), %esp
+
-+#ifdef PIC
++#ifdef __PIC__
+ call 1f
+1: popl %ebx
+ addl $_GLOBAL_OFFSET_TABLE_+[.-1b], %ebx
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 928e8a3aa..da7d6e18c 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.33.2
_ver=${pkgver/_/-}
-pkgrel=11
+pkgrel=12
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -52,6 +52,7 @@ librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
0009-sys-quota.h-sync-with-glibc.patch
+ 0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
uclibcconfig.x86
@@ -62,8 +63,6 @@ librt-re-add-SIGCANCEL-to-the-list-of-blocked-signal-in-helper-thread.patch
uclibc-utils.trigger
"
-# 0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
-
_config="$srcdir"/uclibcconfig.${CARCH}
_builddir="$srcdir"/uClibc-${_ver}
@@ -190,6 +189,7 @@ f059f5e437ed4fe1b6973dd08972e583 0003-pread-pwrite-drop-fallback-funcs.patch
32544dc16cc1b4845484535bf758a4b1 0005-pread_write.c-make-all-archs-use-common-code.patch
73037bc978897e20ae2fc531759443eb 0006-endian.h-add-some-handy-macros-to-be-used-in-syscall.patch
f41ab6cf22545d2e629d4c7107ac6f85 0009-sys-quota.h-sync-with-glibc.patch
+e5aceb82bf4ffd5328113af5380fcdb6 0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
da043a65003ac29ca8b96f416e7752ee 0002-libc-sysdeps-add-get-make-set-swap-context-for-x86_6.patch
ce8a33a31f5a53031fbad8b1d1b66d44 uclibcconfig.x86
e861a17baa541accf4d4d39a98d74c32 uclibcconfig.x86_64