summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-12-05 15:18:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-12-05 15:18:20 +0000
commitdf7fc5c4eac84e5faed698f4c8c518bad6f0d841 (patch)
tree86c42605d36358c1ea3561bff61522a66d2b8239 /main/libc0.9.32
parentdba348b3174ed2f8beba9115672ad222019fc002 (diff)
downloadaports-df7fc5c4eac84e5faed698f4c8c518bad6f0d841.tar.bz2
aports-df7fc5c4eac84e5faed698f4c8c518bad6f0d841.tar.xz
main/libc0.9.32: remove the librt as-needed fix
We should really fix the broken apps instead as suggested by upstream This also fixes issue with c++ apps linking in librt when they shouldn't. gcc needs to be rebuilt with a libstdc++ thats not linked to librt. ref #854
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/uclibc-librt-asneeded-fix.patch39
2 files changed, 1 insertions, 42 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 8b8b0a28a..398f6a3bd 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -4,7 +4,7 @@ pkgname=libc$_abiver
_gitver=
pkgver=0.9.32
_ver=${pkgver/_/-}
-pkgrel=11
+pkgrel=12
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -36,7 +36,6 @@ source="http://uclibc.org/downloads/uClibc-${_ver}.tar.bz2
libm-cabsf.patch
libm-cexp.patch
uclibc-ubacktrace-asneeded-fix.patch
- uclibc-librt-asneeded-fix.patch
uclibc-epoll_pwait-hack.patch
uclibcconfig.x86
uclibcconfig.x86_64
@@ -149,7 +148,6 @@ e814d39ab0adab58d69396ac0b9acdea 0001-libc-x86-fix-stack-unwinding-and-backtrac
40e9c7f017cc81ee5b19ead000b9b6b7 libm-cabsf.patch
42416385763f7cd50775ed9bfaf2d59e libm-cexp.patch
7c47e9cb284b0da8df6ed2096b2c9c66 uclibc-ubacktrace-asneeded-fix.patch
-e5caf13c43ee8d48f22eded21b857d81 uclibc-librt-asneeded-fix.patch
0ed588014227935fbb83b207282f3c15 uclibc-epoll_pwait-hack.patch
b313290b2d700e82b7292c1dcd7d559e uclibcconfig.x86
8e49d9b5bb7b77a27beb53d5580367d5 uclibcconfig.x86_64
diff --git a/main/libc0.9.32/uclibc-librt-asneeded-fix.patch b/main/libc0.9.32/uclibc-librt-asneeded-fix.patch
deleted file mode 100644
index d85af19f2..000000000
--- a/main/libc0.9.32/uclibc-librt-asneeded-fix.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- uClibc-0.9.32-rc3.orig/Makefile.in
-+++ uClibc-0.9.32-rc3/Makefile.in
-@@ -340,6 +340,12 @@
- echo "GROUP ( $(UBACKTRACE_ASNEEDED) )" >> $(PREFIX)$(DEVEL_PREFIX)$(MULTILIB_DIR)/libc.so; \
- fi
- endif
-+ifeq ($(UCLIBC_HAS_REALTIME),y)
-+# Add the AS_NEEDED entry for librt.so
-+ if [ -f $(top_builddir)lib/libc.so -a -f $(PREFIX)$(DEVEL_PREFIX)$(MULTILIB_DIR)/libc.so ] ; then \
-+ echo "GROUP ( $(LIBRT_ASNEEDED) )" >> $(PREFIX)$(DEVEL_PREFIX)$(MULTILIB_DIR)/libc.so; \
-+ fi
-+endif
- ifeq ($(UCLIBC_HAS_THREADS),y)
- ifneq ($(LINUXTHREADS_OLD),y)
- ifeq ($(HARDWIRED_ABSPATH),y)
---- uClibc-0.9.32-rc3.orig/Rules.mak
-+++ uClibc-0.9.32-rc3/Rules.mak
-@@ -119,6 +119,7 @@
- LIBC := libc
- SHARED_LIBNAME := $(LIBC).so.$(ABI_VERSION)
- UBACKTRACE_DSO := libubacktrace.so.$(ABI_VERSION)
-+LIBRT_DSO := librt.so.$(ABI_VERSION)
- ifneq ($(findstring $(TARGET_ARCH) , hppa64 ia64 mips64 powerpc64 s390x sparc64 x86_64 ),)
- UCLIBC_LDSO_NAME := ld64-uClibc
- ARCH_NATIVE_BIT := 64
-@@ -542,6 +543,13 @@
- export UBACKTRACE_ASNEEDED:=$(shell $(LD) --help 2>/dev/null | grep -q -- --as-needed && echo "AS_NEEDED ( $(UBACKTRACE_FULL_NAME) )" || echo "$(UBACKTRACE_FULL_NAME)")
- else
- export UBACKTRACE_ASNEEDED:=""
-+endif
-+ifeq ($(UCLIBC_HAS_REALTIME),y)
-+# Only used in installed libc.so linker script
-+LIBRT_FULL_NAME := $(RUNTIME_PREFIX)lib/$(LIBRT_DSO)
-+export LIBRT_ASNEEDED:=$(shell $(LD) --help 2>/dev/null | grep -q -- --as-needed && echo "AS_NEEDED ( $(LIBRT_FULL_NAME) )" || echo "$(LIBRT_FULL_NAME)")
-+else
-+export LIBRT_ASNEEDED:=""
- endif
- endif
-