summaryrefslogtreecommitdiffstats
path: root/main/libical
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-31 20:06:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-31 20:06:11 +0000
commit2980382356f2bd8b3ed5163661a024771ea9c423 (patch)
tree854e85a36a03c290d4d006430e5f3a820c0f99a6 /main/libical
parent8c5bcc759b3f37742a9b5fc83cedc8dec6b7f4ea (diff)
downloadaports-2980382356f2bd8b3ed5163661a024771ea9c423.tar.bz2
aports-2980382356f2bd8b3ed5163661a024771ea9c423.tar.xz
main/libical: build fix for automake-1.13
Diffstat (limited to 'main/libical')
-rw-r--r--main/libical/APKBUILD15
-rw-r--r--main/libical/automake.patch11
2 files changed, 23 insertions, 3 deletions
diff --git a/main/libical/APKBUILD b/main/libical/APKBUILD
index e38688f3c..4d891584d 100644
--- a/main/libical/APKBUILD
+++ b/main/libical/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libical
pkgver=0.48
-pkgrel=0
+pkgrel=1
pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
url="http://sourceforge.net/projects/freeassociation/"
arch="all"
@@ -9,10 +9,18 @@ license="LGPL MPL"
depends=
makedepends="perl autoconf automake libtool"
subpackages="$pkgname-dev"
-source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz automake.patch"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
aclocal && autoheader && autoconf && automake -a || return 1
libtoolize --force
}
@@ -32,4 +40,5 @@ package() {
rm "$pkgdir"/usr/lib/*.la
}
-md5sums="e549f434d5fbf9cd156c60ed4943618f libical-0.48.tar.gz"
+md5sums="e549f434d5fbf9cd156c60ed4943618f libical-0.48.tar.gz
+79a2ea148f8c6b2a2337ecff296287cb automake.patch"
diff --git a/main/libical/automake.patch b/main/libical/automake.patch
new file mode 100644
index 000000000..757220a62
--- /dev/null
+++ b/main/libical/automake.patch
@@ -0,0 +1,11 @@
+--- ./configure.in.orig 2012-12-31 20:03:51.355227119 +0000
++++ ./configure.in 2012-12-31 20:04:03.445327143 +0000
+@@ -5,7 +5,7 @@
+ AC_CANONICAL_SYSTEM
+ AM_INIT_AUTOMAKE
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(config.h)
+
+ dnl Initialize maintainer mode
+ AM_MAINTAINER_MODE