summaryrefslogtreecommitdiffstats
path: root/main/libssh
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-09 07:43:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-09 07:44:17 +0000
commitdf3d203709e000164df9636e606aa2a36671bded (patch)
treef4828ea87bb979693918e1427b635cf8e2ededb8 /main/libssh
parentaff7349e5da417ac968da94fb59c97b176593537 (diff)
downloadaports-df3d203709e000164df9636e606aa2a36671bded.tar.bz2
aports-df3d203709e000164df9636e606aa2a36671bded.tar.xz
main/libssh: upgrade to 0.6.0
Diffstat (limited to 'main/libssh')
-rw-r--r--main/libssh/APKBUILD16
-rw-r--r--main/libssh/link-pthread.patch63
2 files changed, 6 insertions, 73 deletions
diff --git a/main/libssh/APKBUILD b/main/libssh/APKBUILD
index 521a5835b..705f2ff4b 100644
--- a/main/libssh/APKBUILD
+++ b/main/libssh/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libssh
-pkgver=0.5.5
+pkgver=0.6.0
pkgrel=0
pkgdesc="Library for accessing ssh client services through C libraries"
url="http://www.libssh.org/"
@@ -10,8 +10,7 @@ license="LGPL"
depends=
makedepends="openssl-dev cmake doxygen"
subpackages="$pkgname-dev"
-source="https://red.libssh.org/attachments/download/51/libssh-$pkgver.tar.gz
- link-pthread.patch
+source="https://red.libssh.org/attachments/download/71/libssh-$pkgver.tar.xz
fix-includes.patch
"
@@ -31,7 +30,7 @@ prepare() {
build() {
cd "$srcdir"
-
+
mkdir build && cd build
cmake "$srcdir"/${pkgname}-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
@@ -44,12 +43,9 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="bb308196756c7255c0969583d917136b libssh-0.5.5.tar.gz
-8d58b3391286de4dad3eb8a5b70171aa link-pthread.patch
+md5sums="12d9b1edfb8c2d85b24e123b6b386b40 libssh-0.6.0.tar.xz
8257f5a2a6be16b158a83d76b5eed4fd fix-includes.patch"
-sha256sums="c0df0f05fc812dbe26fd4118bec0776aa9e892c0719590f3971130489c6b8e9d libssh-0.5.5.tar.gz
-7a57c161357cb588e37a0b2e0b6a4a42505834da00e763ffe21141ed3a899169 link-pthread.patch
+sha256sums="4c6de7caa23debbe4639f83fa2ff411924643e65356d6af048daa31e4a1a2f71 libssh-0.6.0.tar.xz
d1798cd15d8682464a0b1b1853a9e17e63fed2fa732849570e595347d91b160c fix-includes.patch"
-sha512sums="114a8d078b9530fe37f12c769283213ceacdd8cbf0c1c3e64e09c07d38b3886bc8c9a78816562ab1bc44c55c604fcc4ed85cdb2a8203962c9331f9d10977e802 libssh-0.5.5.tar.gz
-da26f14312a0988c72663225b6412ec06b2cdda6fdfd234f167f7fe9f1371fa432cb4c5d6326048540cffa527781203019023844870fe52c1b58631d8ca45b39 link-pthread.patch
+sha512sums="6680e351b22ce6629047929dfcb7ac02dd7c332af5995191dcb72037ef727bc8c9394760517f79a58f8f7e489c29581fc41f6c7bc08c187ef5cb6091b66ab6a7 libssh-0.6.0.tar.xz
055a8f6b97c65384a5a3ab8fe00c69d94cc30092fe926093dbbc122ce301fbe9d76127aa07b5e6107d7fa9dd2aad6b165fa0958b56520253b5d64428ff42a318 fix-includes.patch"
diff --git a/main/libssh/link-pthread.patch b/main/libssh/link-pthread.patch
deleted file mode 100644
index 2e2c770f6..000000000
--- a/main/libssh/link-pthread.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
-index aeff201..0191d5d 100644
---- a/examples/CMakeLists.txt
-+++ b/examples/CMakeLists.txt
-@@ -13,36 +13,36 @@ include_directories(
-
- if (LINUX)
- add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
-- target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(scp_download scp_download.c ${examples_SRCS})
-- target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(scp_download ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(samplessh sample.c ${examples_SRCS})
-- target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(sshnetcat sshnetcat.c ${examples_SRCS})
-- target_link_libraries(sshnetcat ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(sshnetcat ${LIBSSH_SHARED_LIBRARY} pthread)
-
- if (WITH_SFTP)
- add_executable(samplesftp samplesftp.c ${examples_SRCS})
-- target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(samplesftp ${LIBSSH_SHARED_LIBRARY} pthread)
- endif (WITH_SFTP)
-
- if (WITH_SERVER)
- add_executable(samplesshd samplesshd.c)
-- target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY})
-+ target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY} pthread)
- endif (WITH_SERVER)
- endif (LINUX)
-
- add_executable(exec exec.c ${examples_SRCS})
--target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY})
-+target_link_libraries(exec ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(senddata senddata.c ${examples_SRCS})
--target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY})
-+target_link_libraries(senddata ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(libsshpp libsshpp.cpp)
--target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY})
-+target_link_libraries(libsshpp ${LIBSSH_SHARED_LIBRARY} pthread)
-
- add_executable(libsshpp_noexcept libsshpp_noexcept.cpp)
--target_link_libraries(libsshpp_noexcept ${LIBSSH_SHARED_LIBRARY})
-+target_link_libraries(libsshpp_noexcept ${LIBSSH_SHARED_LIBRARY} pthread)
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index e158665..ef2005d 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -40,6 +40,7 @@ if (HAVE_LIBSOCKET)
- set(LIBSSH_LINK_LIBRARIES
- ${LIBSSH_LINK_LIBRARIES}
- socket
-+ pthread
- )
- endif (HAVE_LIBSOCKET)
-