summaryrefslogtreecommitdiffstats
path: root/main/libxml2
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:42:57 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:42:57 +0000
commit1372cc184451ae1f3837017ca97d9fa3cc45b55b (patch)
treec6b87c22d13fa5bd83059884a64d6a42027e68e6 /main/libxml2
parentc5d8cfdc4a5a1b5303475627fd265422dc1887df (diff)
downloadaports-1372cc184451ae1f3837017ca97d9fa3cc45b55b.tar.bz2
aports-1372cc184451ae1f3837017ca97d9fa3cc45b55b.tar.xz
main/libxml2: fix pthreads patch for non-musl
the weak hack is needed if -lpthreads is separate library. so just differentiate with musl and non-musl with __GLIBC__ as an ugly hack.
Diffstat (limited to 'main/libxml2')
-rw-r--r--main/libxml2/APKBUILD6
-rw-r--r--main/libxml2/libxml2-pthread.patch56
2 files changed, 10 insertions, 52 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index 1fb7ad948..1738e0396 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -66,8 +66,8 @@ utils() {
}
md5sums="9c0cfef285d5c4a5c80d00904ddab380 libxml2-2.9.1.tar.gz
-f5fe0da88617b8d87977640a009b8ea9 libxml2-pthread.patch"
+cc0da520c5296e87407d24166480da73 libxml2-pthread.patch"
sha256sums="fd3c64cb66f2c4ea27e934d275904d92cec494a8e8405613780cbc8a71680fdb libxml2-2.9.1.tar.gz
-59e0013398c959df25cf7406e43ad15cccc9bdcfefb6875260bf0daf67c76543 libxml2-pthread.patch"
+97d5e152580774483c47b28483282a4180c2c375bb7716a807ec859e59c3ec2f libxml2-pthread.patch"
sha512sums="7b10de749485bc2eb2108063e97d89e70d6fbb78b1bf195ab5528c8c64e79483d55223a49d95934f4e00b00e906c18bdd34344703ffe158dcf08096905a44c1b libxml2-2.9.1.tar.gz
-1a1c747bfd5f8692ef5df2510dea5572aaf153b597463da0dfd817e53a5cd5c8ebb7e9be88ab787194ccedbf4f2739ada45acf655d38fb40a384004e91062322 libxml2-pthread.patch"
+bda49c5e09605acc2bb36203521f750903d81345cc38af54b977e3ce71e288267fb3ab98f1813d846ab45461490482337f7af8b0f1a8a5e0b2c09e03bbadc7f7 libxml2-pthread.patch"
diff --git a/main/libxml2/libxml2-pthread.patch b/main/libxml2/libxml2-pthread.patch
index d6e6f466a..77d7b3849 100644
--- a/main/libxml2/libxml2-pthread.patch
+++ b/main/libxml2/libxml2-pthread.patch
@@ -1,53 +1,11 @@
---- libxml2-2.9.1.patched/threads.c 2013-07-24 03:30:55.160000003 +0000
-+++ libxml2-2.9.1/threads.c 2013-07-24 03:33:50.323000003 +0000
-@@ -47,49 +47,7 @@
+--- libxml2-2.9.1/threads.c.orig
++++ libxml2-2.9.1/threads.c
+@@ -47,7 +47,7 @@
#ifdef HAVE_PTHREAD_H
static int libxml_is_threaded = -1;
-#ifdef __GNUC__
--#ifdef linux
--#if (__GNUC__ == 3 && __GNUC_MINOR__ >= 3) || (__GNUC__ > 3)
--extern int pthread_once (pthread_once_t *__once_control,
-- void (*__init_routine) (void))
-- __attribute((weak));
--extern void *pthread_getspecific (pthread_key_t __key)
-- __attribute((weak));
--extern int pthread_setspecific (pthread_key_t __key,
-- __const void *__pointer)
-- __attribute((weak));
--extern int pthread_key_create (pthread_key_t *__key,
-- void (*__destr_function) (void *))
-- __attribute((weak));
--extern int pthread_key_delete (pthread_key_t __key)
-- __attribute((weak));
--extern int pthread_mutex_init ()
-- __attribute((weak));
--extern int pthread_mutex_destroy ()
-- __attribute((weak));
--extern int pthread_mutex_lock ()
-- __attribute((weak));
--extern int pthread_mutex_unlock ()
-- __attribute((weak));
--extern int pthread_cond_init ()
-- __attribute((weak));
--extern int pthread_cond_destroy ()
-- __attribute((weak));
--extern int pthread_cond_wait ()
-- __attribute((weak));
--extern int pthread_equal ()
-- __attribute((weak));
--extern pthread_t pthread_self ()
-- __attribute((weak));
--extern int pthread_key_create ()
-- __attribute((weak));
--extern int pthread_key_delete ()
-- __attribute((weak));
--extern int pthread_cond_signal ()
-- __attribute((weak));
--#endif
--#endif /* linux */
--#endif /* __GNUC__ */
-+
- #endif /* HAVE_PTHREAD_H */
-
- /*
++#if defined(__GNUC__) && defined(__GLIBC__)
+ #ifdef linux
+ #if (__GNUC__ == 3 && __GNUC_MINOR__ >= 3) || (__GNUC__ > 3)
+ extern int pthread_once (pthread_once_t *__once_control,