summaryrefslogtreecommitdiffstats
path: root/main/linux-headers
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-12 08:37:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-12 08:39:53 +0000
commit2647bd61e602e4e3aca22f558d8a79b11cc8a4d0 (patch)
tree5c6109041790c1361f9e8e1b6b5563e850970977 /main/linux-headers
parent7ca62936d297e385c94c629838644bbc7c992cdc (diff)
downloadaports-2647bd61e602e4e3aca22f558d8a79b11cc8a4d0.tar.bz2
aports-2647bd61e602e4e3aca22f558d8a79b11cc8a4d0.tar.xz
main/linux-headers: properly set as arch specific package
since the headers produced depend on ARCH. also support crosscompiling and arm.
Diffstat (limited to 'main/linux-headers')
-rw-r--r--main/linux-headers/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index e50310b24..fdddffa4e 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -2,10 +2,11 @@
pkgname=linux-headers
pkgver=3.8.7
_kernver=3.8
-pkgrel=0
+pkgrel=1
pkgdesc="Linux system headers"
url="http://kernel.org"
-arch="noarch"
+arch="all"
+_carch=${CARCH/armel/arm}
license='GPL-2'
makedepends="perl"
if [ "$ALPINE_LIBC" = "eglibc" ]; then
@@ -29,11 +30,10 @@ build() {
return 0
}
-
package() {
cd "$srcdir"/linux-$_kernver
mkdir -p "$pkgdir/usr"
- make headers_install INSTALL_HDR_PATH="$pkgdir/usr" || return 1
+ make headers_install ARCH="${_carch}" INSTALL_HDR_PATH="$pkgdir/usr" || return 1
find "$pkgdir/usr" \( -name .install -o -name ..install.cmd \) -exec \
rm -f {} \;