summaryrefslogtreecommitdiffstats
path: root/main/linux-headers
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-26 11:12:56 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-26 11:12:56 +0000
commit3cb6f657bdcc0cffb08470d6b22b4f659c2d074e (patch)
treeea2c6dd6c608cac003d30bd35997b2af28b9eaed /main/linux-headers
parent999654d46ba295e141618c20ebac415269907f40 (diff)
downloadaports-3cb6f657bdcc0cffb08470d6b22b4f659c2d074e.tar.bz2
aports-3cb6f657bdcc0cffb08470d6b22b4f659c2d074e.tar.xz
main/linux-headers: support armhf
Diffstat (limited to 'main/linux-headers')
-rw-r--r--main/linux-headers/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index fdddffa4e..b3e42e8fa 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -6,7 +6,6 @@ pkgrel=1
pkgdesc="Linux system headers"
url="http://kernel.org"
arch="all"
-_carch=${CARCH/armel/arm}
license='GPL-2'
makedepends="perl"
if [ "$ALPINE_LIBC" = "eglibc" ]; then
@@ -31,6 +30,12 @@ build() {
}
package() {
+ local _carch=$CARCH
+
+ case "$_carch" in
+ arm*) _carch="arm" ;;
+ esac
+
cd "$srcdir"/linux-$_kernver
mkdir -p "$pkgdir/usr"
make headers_install ARCH="${_carch}" INSTALL_HDR_PATH="$pkgdir/usr" || return 1