summaryrefslogtreecommitdiffstats
path: root/main/linux-vanilla
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-15 18:03:40 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-15 18:03:40 +0000
commit084730934aac6fdbf074c04f3562910391f9b498 (patch)
tree632b7a721667141c29d7a5a0209079c62298c048 /main/linux-vanilla
parentfc8259b74579020824a298b4c65f34d522993941 (diff)
downloadaports-084730934aac6fdbf074c04f3562910391f9b498.tar.bz2
aports-084730934aac6fdbf074c04f3562910391f9b498.tar.xz
main/linux-vanilla: enable EFI stub for x86_64
Diffstat (limited to 'main/linux-vanilla')
-rw-r--r--main/linux-vanilla/APKBUILD8
-rw-r--r--main/linux-vanilla/kernelconfig.x86_6414
2 files changed, 15 insertions, 7 deletions
diff --git a/main/linux-vanilla/APKBUILD b/main/linux-vanilla/APKBUILD
index 36dd3d557..6ecba6ee6 100644
--- a/main/linux-vanilla/APKBUILD
+++ b/main/linux-vanilla/APKBUILD
@@ -7,7 +7,7 @@ case $pkgver in
*.*.*) _kernver=${pkgver%.*};;
*.*) _kernver=$pkgver;;
esac
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with grsecurity"
url=http://grsecurity.net
depends="mkinitfs linux-firmware"
@@ -147,17 +147,17 @@ md5sums="cc6ee608854e0da4b64f6c1ff8b6398c linux-3.12.tar.xz
59d1fabcccea6a8a3fcf59d610205a6e fs-binfmt_elf-fix-memory-map-for-PIE-applications.patch
401c8766656e65d18f99e5253ef0dd34 kernelconfig.armhf
e398fabcf021ff445ac39482f9e0d19c kernelconfig.x86
-13d21cf8e20b02d916a58f32f36d43b0 kernelconfig.x86_64
+a1a4f1a5406676817038bf1d16f1fa21 kernelconfig.x86_64
a158a29ecf49e768ebd2f34967991606 patch-3.12.7.xz"
sha256sums="2e120ec7fde19fa51dc6b6cc11c81860a0775defcad5a5bf910ed9a50e845a02 linux-3.12.tar.xz
e1377ef692929a37f1e638038b10e06a98502f28efc461e1948dcd67df1e7619 fs-binfmt_elf-fix-memory-map-for-PIE-applications.patch
391ea5a791c46a9d7630d18cdf58cf32d7f70b77e9dff31da23a75411f10618a kernelconfig.armhf
a0c86879f4e0a4f5b9d73771c2b702075141bb05f941342bd40b9125d789513f kernelconfig.x86
-2036810be28ab494e6d688405f3d4d85409549b43dd6789452f2c51b3202e7f5 kernelconfig.x86_64
+ec702fef732a2ca5d315fd08bf05968b9b37085a5d0cf07a2e3bf23b896549bd kernelconfig.x86_64
ac57d56064bb23dae55fe656c407c662e842c98a6a5411251d6bb79c9718f555 patch-3.12.7.xz"
sha512sums="4ba5797e0772726d05c9f2eee66dc6dc2a5033c749ef44764c805a83da739ed5d0c6443b76785e38fe1ef74cc7ade787e48144faed0cfcb6f124f05248c700ff linux-3.12.tar.xz
e8b5a96ddcf55ac9df7de506728a5308f9156086410edf6d354d7c69f6fb450222b25eb062e397889eeb9e5653c3f5110b0603003cca5d6706171b5559ddcd97 fs-binfmt_elf-fix-memory-map-for-PIE-applications.patch
9467b106797276495ec0448b23d72ad10e52d15401d729d27b35f4e0d05d587f55e2387264ce3f28ee44cd1b77e5ce3eb224ab52749f3512879c24e1afff2a06 kernelconfig.armhf
483231e9d51ae18e44a8ef6739688cfcc8aaa7f1831481ef34a66e0e6f980455dff83b7cfcad78631e3fade18e00354445c00585b8ed97b6a218f46e0a52a3b7 kernelconfig.x86
-26e7a4dc33667cfde328839cc51f0458247d4038a0f077834c02f55666ef758fc7e0ef81d5f33c5c101269a74f6bdada9ab7ac4bb87c0607e82b53cc3ab25385 kernelconfig.x86_64
+c19dc40777aa832cf4a6bf28463dfd81738cc2da3d817b44ffc2bcbc89b19579ad18d2245c9b5df48b550e250cc274173408f45f132a7b48bca14460646bebaf kernelconfig.x86_64
070536e1ed0911e91e96f32038b38efd8d531a306b09eb3074f68ebd7c582cf09574ea712666c3e3dff8443d66d054028a58497dd5e11f66d3bb5eb4570aee78 patch-3.12.7.xz"
diff --git a/main/linux-vanilla/kernelconfig.x86_64 b/main/linux-vanilla/kernelconfig.x86_64
index 7fd0c6f12..87a22e29a 100644
--- a/main/linux-vanilla/kernelconfig.x86_64
+++ b/main/linux-vanilla/kernelconfig.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 3.12.5 Kernel Configuration
+# Linux/x86 3.12.7 Kernel Configuration
#
CONFIG_64BIT=y
CONFIG_X86_64=y
@@ -448,7 +448,8 @@ CONFIG_X86_PAT=y
CONFIG_ARCH_USES_PG_UNCACHED=y
CONFIG_ARCH_RANDOM=y
CONFIG_X86_SMAP=y
-# CONFIG_EFI is not set
+CONFIG_EFI=y
+CONFIG_EFI_STUB=y
# CONFIG_SECCOMP is not set
# CONFIG_CC_STACKPROTECTOR is not set
# CONFIG_HZ_100 is not set
@@ -510,6 +511,7 @@ CONFIG_ACPI_CONTAINER=y
CONFIG_ACPI_SBS=m
CONFIG_ACPI_HED=m
# CONFIG_ACPI_CUSTOM_METHOD is not set
+CONFIG_ACPI_BGRT=y
CONFIG_ACPI_APEI=y
# CONFIG_ACPI_APEI_GHES is not set
CONFIG_ACPI_APEI_EINJ=m
@@ -4789,7 +4791,6 @@ CONFIG_DMA_ACPI=y
#
# DMA Clients
#
-CONFIG_NET_DMA=y
# CONFIG_ASYNC_TX_DMA is not set
CONFIG_DMATEST=m
CONFIG_DCA=m
@@ -5034,6 +5035,11 @@ CONFIG_DMIID=y
# CONFIG_GOOGLE_FIRMWARE is not set
#
+# EFI (Extensible Firmware Interface) Support
+#
+# CONFIG_EFI_VARS is not set
+
+#
# File systems
#
CONFIG_DCACHE_WORD_ACCESS=y
@@ -5224,6 +5230,7 @@ CONFIG_F2FS_STAT_FS=y
CONFIG_F2FS_FS_XATTR=y
CONFIG_F2FS_FS_POSIX_ACL=y
# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_EFIVAR_FS=m
CONFIG_ORE=m
CONFIG_NETWORK_FILESYSTEMS=y
CONFIG_NFS_FS=m
@@ -5740,6 +5747,7 @@ CONFIG_CORDIC=m
CONFIG_DDR=y
CONFIG_MPILIB=m
CONFIG_OID_REGISTRY=m
+CONFIG_UCS2_STRING=y
CONFIG_FONT_SUPPORT=m
# CONFIG_FONTS is not set
CONFIG_FONT_8x8=y