summaryrefslogtreecommitdiffstats
path: root/main/lua-pty
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-23 12:06:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-23 12:06:26 +0000
commitf1e50c070e43abbcbf647dc83f468a4e04f743ba (patch)
tree3e850ac2196ffedaa9df313013840085b9834b06 /main/lua-pty
parent62b76d8d6546412e8dcb504a6c38ecb481f29874 (diff)
downloadaports-f1e50c070e43abbcbf647dc83f468a4e04f743ba.tar.bz2
aports-f1e50c070e43abbcbf647dc83f468a4e04f743ba.tar.xz
main/lua-pty: new aport
Lua module to control other programs via PTYs. http://www.tset.de/lpty/
Diffstat (limited to 'main/lua-pty')
-rw-r--r--main/lua-pty/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/lua-pty/APKBUILD b/main/lua-pty/APKBUILD
new file mode 100644
index 000000000..db39e0204
--- /dev/null
+++ b/main/lua-pty/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor:
+# Maintainer:
+pkgname=lua-pty
+_name=lpty
+pkgver=0.8.2
+_ver=${pkgver%.*}
+_pver=${pkgver##*.}
+pkgrel=0
+pkgdesc="Lua module to control other programs via PTYs."
+url="http://www.tset.de/lpty/"
+license="MIT/X11"
+depends=
+makedepends="lua-dev"
+subpackages=
+source="http://www.tset.de/downloads/lpty-${_ver}-${_pver}.tar.gz"
+
+_builddir="$srcdir"/lpty-${_ver}-${_pver}
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ gcc -fPIC -shared -o lpty.so lpty.c
+}
+
+package() {
+ cd "$_builddir"
+ install -D lpty.so "$pkgdir"/usr/lib/lua/5.1/lpty.so
+}
+
+md5sums="58e99745bd239a0b97191bf4ce11d15f lpty-0.8-2.tar.gz"