summaryrefslogtreecommitdiffstats
path: root/main/lua5.1/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-27 08:13:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-27 08:14:22 +0000
commit8a8d04916305d3f9109c3fe93a028d3113d4aa4f (patch)
tree56a1e7228478a38e2b683864dbfdb48b61e43e05 /main/lua5.1/APKBUILD
parent7c2a2e0722a11b7b5aa8c530025854a1c2f3be29 (diff)
downloadaports-8a8d04916305d3f9109c3fe93a028d3113d4aa4f.tar.bz2
aports-8a8d04916305d3f9109c3fe93a028d3113d4aa4f.tar.xz
main/lua5.1: fixes for newer libtool
Diffstat (limited to 'main/lua5.1/APKBUILD')
-rw-r--r--main/lua5.1/APKBUILD52
1 files changed, 41 insertions, 11 deletions
diff --git a/main/lua5.1/APKBUILD b/main/lua5.1/APKBUILD
index b30643429..20ef64c56 100644
--- a/main/lua5.1/APKBUILD
+++ b/main/lua5.1/APKBUILD
@@ -2,13 +2,13 @@
pkgname=lua5.1
pkgver=5.1.5
_ver=$pkgver
-pkgrel=0
+pkgrel=1
pkgdesc="A powerful light-weight programming language designed for extending applications."
url="http://www.lua.org/"
arch="all"
license="MIT"
depends=
-makedepends="libtool"
+makedepends="libtool autoconf automake"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
source="http://www.lua.org/ftp/lua-$_ver.tar.gz
lua-5.1-make.patch
@@ -17,7 +17,7 @@ source="http://www.lua.org/ftp/lua-$_ver.tar.gz
"
_builddir="$srcdir"/lua-$_ver
-build() {
+prepare() {
cd "$_builddir"
for i in $source; do
case $i in
@@ -28,24 +28,46 @@ build() {
esac
done
- # correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:4:1/' src/Makefile
-
# we want packages to find our things
sed -i -e 's:/usr/local:/usr:' etc/lua.pc
- cd src
+ # correct lua versioning
+ sed -i -e 's/\(LIB_VERSION = \).*/\16:4:1/' src/Makefile
+
+ # we use libtool
+ cat >configure.ac <<EOF
+top_buildir=.
+
+AC_INIT(src/luaconf.h)
+AC_PROG_LIBTOOL
+AC_OUTPUT()
+EOF
+ libtoolize --force --install && aclocal && autoconf
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+
+ cd "$_builddir"/src
make CFLAGS=" -DLUA_USE_LINUX $CFLAGS" \
RPATH="/usr/lib" \
LIB_LIBS="-lpthread -lm -ldl" \
V=$pkgver \
- gentoo_all || return 1
+ alpine_all || return 1
}
package() {
cd "$_builddir"
- make INSTALL_TOP="$pkgdir"/usr INSTALL_LIB="$pkgdir"/usr/lib \
- V=$pkgver gentoo_install || return 1
+ make V=$pkgver \
+ INSTALL_TOP="$pkgdir"/usr \
+ INSTALL_INC="$pkgdir"/usr/include \
+ INSTALL_LIB="$pkgdir"/usr/lib \
+ alpine_install || return 1
rm "$pkgdir"/usr/lib/*.la || return 1
for i in "$pkgdir"/usr/bin/*; do
@@ -71,6 +93,14 @@ libs() {
md5sums="2e115fe26e435e33b0d5c022e4490567 lua-5.1.5.tar.gz
-0145ff6036eb6bfdab427dc8f0c3f3c0 lua-5.1-make.patch
+7fa6ce1f09e18415f2ba00db437f2804 lua-5.1-make.patch
e60ef15deefb72a5930c498f1184aced lua-5.1-module_paths.patch
f2205b897edb31292a1f597a7fd638cb lua-5.1-readline.patch"
+sha256sums="2640fc56a795f29d28ef15e13c34a47e223960b0240e8cb0a82d9b0738695333 lua-5.1.5.tar.gz
+99a709038b0910edff3e40a2d368f35abe8eebbd699ee06aea4005de401ce843 lua-5.1-make.patch
+1115b6aa00eb4e918156ae70c763534bd2f603ba888da75e4908c19c2ac3e5f7 lua-5.1-module_paths.patch
+1f0f90eb8103e338f1188cc884c0c59cc6afd023828c11d86b8145b2a8d1efc2 lua-5.1-readline.patch"
+sha512sums="0142fefcbd13afcd9b201403592aa60620011cc8e8559d4d2db2f92739d18186860989f48caa45830ff4f99bfc7483287fd3ff3a16d4dec928e2767ce4d542a9 lua-5.1.5.tar.gz
+ec5945f9f73d87fceaaa2418f1dc5c0f1e2ab1392e3a110e9ca737bfd122a951543899cd9b6170771374c35de8dd106f7b51ba9885eae281241c79b47ee58370 lua-5.1-make.patch
+123b115389d01d383af8698d2ed66c75bb7c3e2d33de57b8539ae56a9478930a0a72fa5657e78cc1c5b6bef00d07ec3a51e19ec0e419647e84eb158fb5c4795a lua-5.1-module_paths.patch
+a99154258419dc2e582804eae97517687e5b8b5f731dc91722193d1ff470b8522af6ff4e7142c9258afe4734cd52e6987d3c2108ac52b1487a262f1e89f2f332 lua-5.1-readline.patch"