summaryrefslogtreecommitdiffstats
path: root/main/lua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-22 16:09:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-22 16:09:21 +0000
commitacdd8885dd810ddcea0f0dc77b9cb34e66c97709 (patch)
tree97c08ac90fa6c7b6c103b9bc79ac08e4ca2fa65a /main/lua
parent8ad2c78fa191ff203dfad04d5509708d116a6b04 (diff)
downloadaports-acdd8885dd810ddcea0f0dc77b9cb34e66c97709.tar.bz2
aports-acdd8885dd810ddcea0f0dc77b9cb34e66c97709.tar.xz
main/lua: upgrade to 5.1.4_p3
Diffstat (limited to 'main/lua')
-rw-r--r--main/lua/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/lua/APKBUILD b/main/lua/APKBUILD
index f6bdf9b9c..f6377dabc 100644
--- a/main/lua/APKBUILD
+++ b/main/lua/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lua
-pkgver=5.1.4
-pkgrel=6
+pkgver=5.1.4_p3
+_ver=${pkgver%_p*}
+pkgrel=0
pkgdesc="A powerful light-weight programming language designed for extending applications."
url="http://www.lua.org/"
arch="all"
@@ -9,15 +10,16 @@ license="MIT"
depends=
makedepends="readline-dev libtool"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://www.$pkgname.org/ftp/$pkgname-$pkgver.tar.gz
- http://www.lua.org/ftp/patch-lua-5.1.4-2
+source="http://www.$pkgname.org/ftp/$pkgname-$_ver.tar.gz
+ http://www.lua.org/ftp/patch-lua-5.1.4-${pkgver#*_p}
lua-5.1-make.patch
lua-5.1-module_paths.patch
"
+_builddir="$srcdir"/lua-$_ver
build ()
{
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
for i in $source; do
case $i in
patch*|*.patch)
@@ -43,7 +45,7 @@ build ()
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make INSTALL_TOP="$pkgdir"/usr INSTALL_LIB="$pkgdir"/usr/lib \
V=$pkgver gentoo_install || return 1
@@ -52,6 +54,6 @@ package() {
install -D -m 644 doc/luac.1 "$pkgdir"/usr/share/man/man1/luac.1
}
md5sums="d0870f2de55d59c1c8419f36e8fac150 lua-5.1.4.tar.gz
-1239310e0c4a581c7831e596f95cc6cd patch-lua-5.1.4-2
+998ef7886183f61d3a5ca891a9ce6a79 patch-lua-5.1.4-3
0145ff6036eb6bfdab427dc8f0c3f3c0 lua-5.1-make.patch
e60ef15deefb72a5930c498f1184aced lua-5.1-module_paths.patch"