summaryrefslogtreecommitdiffstats
path: root/main/mate-notification-daemon
diff options
context:
space:
mode:
authorAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 14:59:52 +0000
committerAlan Lacerda <alacerda@alpinelinux.org>2015-03-24 16:19:36 +0000
commit1c84bf3f55570e9a7dcbfec2c5751c76daca062a (patch)
tree16ff08dafc450006b4d37429f37a446247619af9 /main/mate-notification-daemon
parent524d3067cd5b991d7307739eede57a5712457083 (diff)
downloadaports-1c84bf3f55570e9a7dcbfec2c5751c76daca062a.tar.bz2
aports-1c84bf3f55570e9a7dcbfec2c5751c76daca062a.tar.xz
main/mate-notification-daemon: move from testing
Diffstat (limited to 'main/mate-notification-daemon')
-rw-r--r--main/mate-notification-daemon/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/main/mate-notification-daemon/APKBUILD b/main/mate-notification-daemon/APKBUILD
new file mode 100644
index 000000000..d45974a4c
--- /dev/null
+++ b/main/mate-notification-daemon/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Alan Lacerda <alacerda@alpinelinux.org>
+# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
+pkgname=mate-notification-daemon
+pkgver=1.9.90
+pkgrel=1
+pkgdesc="Small, passive popup dialogs that notify the user of particular events"
+url="https://github.com/mate-desktop/mate-notification-daemon"
+arch="all"
+license="GPL2"
+depends="mate-common"
+depends_dev=""
+makedepends="$depends_dev libwnck-dev libnotify-dev libtool intltool dbus-glib-dev
+ libcanberra-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://pub.mate-desktop.org/releases/1.9/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --with-gtk=2.0 \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="${pkgdir}" install || return 1
+ find "$pkgdir" -name \*.la -delete
+}
+
+md5sums="fdd243c649f64ea6dbab2e3defe64aa2 mate-notification-daemon-1.9.90.tar.xz"
+sha256sums="e6f97a3dcab652500b1b4ce0ab47331a5bd5eb81d250c763666b1f791b831d57 mate-notification-daemon-1.9.90.tar.xz"
+sha512sums="19e6dde45717198d8fa81f7b8dbd7df2acc21bbf9354facb4f581d8bc971d582e5021c6260880dd6db28d6e0018a499d7472f01cf26bc7ead72b61c4c468f913 mate-notification-daemon-1.9.90.tar.xz"