summaryrefslogtreecommitdiffstats
path: root/main/metacity
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 16:38:50 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 16:38:50 +0000
commit8267dee29fc3288c5deed523af8f46c660574939 (patch)
treed4e28516c987ade9780b2b99f6f5be768b0ccf9b /main/metacity
parent35d84c71a8e384f083eb51c000b9d31204d8422e (diff)
downloadaports-8267dee29fc3288c5deed523af8f46c660574939.tar.bz2
aports-8267dee29fc3288c5deed523af8f46c660574939.tar.xz
main/metacity: fix musl build
Diffstat (limited to 'main/metacity')
-rw-r--r--main/metacity/APKBUILD14
-rw-r--r--main/metacity/fix-xopen.patch28
2 files changed, 39 insertions, 3 deletions
diff --git a/main/metacity/APKBUILD b/main/metacity/APKBUILD
index 986134b8c..82a4d21bf 100644
--- a/main/metacity/APKBUILD
+++ b/main/metacity/APKBUILD
@@ -17,16 +17,19 @@ depends_dev="gtk+-dev
libwnck-dev
librsvg-dev
libxcomposite-dev"
-makedepends="$depends_dev intltool gobject-introspection-dev"
+makedepends="$depends $depends_dev intltool gobject-introspection-dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-lang"
replaces_dev="$pkgname"
-source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ fix-xopen.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
local i
cd "$_builddir"
+ update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -55,4 +58,9 @@ package() {
find "$pkgdir" -name '*.la' -delete
}
-md5sums="553784f376d96b902e19ff437cd5b339 metacity-2.30.3.tar.bz2"
+md5sums="553784f376d96b902e19ff437cd5b339 metacity-2.30.3.tar.bz2
+3d45e9fe130a89f9a31c415f4f979103 fix-xopen.patch"
+sha256sums="08f887018fa5e447cf184d03bae3fe2c05fdb7583bed6768e3b4d66392fc18dd metacity-2.30.3.tar.bz2
+ae4b5961934a5a799358cae4f91af6aa0627ec9bb3bcd942d9ec2ea0ea83c45a fix-xopen.patch"
+sha512sums="d74150d2340605d5d023f9c528d771f7c469ead635a938caf92326e6f80aec9cd1f6eed49a7704698bd7cb0a3455ebaee459d02714bb821322c60850505d6b2e metacity-2.30.3.tar.bz2
+7177b9599af7d55789d6eefc6d822251c54ab14449a2b77e1bbb0061b22630223dfa1dbd41a3cfee536469c0b448dd3b935ffb1c62bd4ec5571c5a15385aafbe fix-xopen.patch"
diff --git a/main/metacity/fix-xopen.patch b/main/metacity/fix-xopen.patch
new file mode 100644
index 000000000..13e55c6ac
--- /dev/null
+++ b/main/metacity/fix-xopen.patch
@@ -0,0 +1,28 @@
+--- ./src/ui/theme.c.orig
++++ ./src/ui/theme.c
+@@ -52,6 +52,7 @@
+ * things. This is the parser used for that language.
+ */
+
++#define _XOPEN_SOURCE
+ #include <config.h>
+ #include "theme.h"
+ #include "theme-parser.h"
+@@ -60,7 +61,6 @@
+ #include <gtk/gtk.h>
+ #include <string.h>
+ #include <stdlib.h>
+-#define __USE_XOPEN
+ #include <math.h>
+
+ #define GDK_COLOR_RGBA(color) \
+--- ./src/core/session.c.orig
++++ ./src/core/session.c
+@@ -23,6 +23,7 @@
+ * 02111-1307, USA.
+ */
+
++#define _XOPEN_SOURCE
+ #include <config.h>
+
+ #include "session.h"