summaryrefslogtreecommitdiffstats
path: root/main/midori/execinfo-detect.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 18:02:35 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 18:02:35 +0000
commit46f1e5db6ce295c6842dbcec50c75f2552c5a463 (patch)
tree17815910ef92a937f75863415fe03e40317ad6ce /main/midori/execinfo-detect.patch
parent94749d466a1c060165299ede44ebf640c99b162a (diff)
downloadaports-46f1e5db6ce295c6842dbcec50c75f2552c5a463.tar.bz2
aports-46f1e5db6ce295c6842dbcec50c75f2552c5a463.tar.xz
main/midori: fix musl build
Diffstat (limited to 'main/midori/execinfo-detect.patch')
-rw-r--r--main/midori/execinfo-detect.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/main/midori/execinfo-detect.patch b/main/midori/execinfo-detect.patch
new file mode 100644
index 000000000..171bcacb6
--- /dev/null
+++ b/main/midori/execinfo-detect.patch
@@ -0,0 +1,18 @@
+--- midori-0.5.6.orig/CMakeLists.txt
++++ midori-0.5.6/CMakeLists.txt
+@@ -97,13 +97,8 @@
+ endif ()
+
+ # Check if execinfo.h header exists
+-string(FIND ${CMAKE_SYSTEM_NAME} "BSD" BEGIN)
+-if (${BEGIN} GREATER 0)
+- string(SUBSTRING ${CMAKE_SYSTEM_NAME} ${BEGIN} 3 BSD)
+-else()
+- set(BSD 0)
+-endif()
+-if (UNIX AND NOT BSD)
++find_file (EXECINFO execinfo.h)
++if (EXECINFO)
+ set(VALAFLAGS ${VALAFLAGS} -D HAVE_EXECINFO_H)
+ endif ()
+