summaryrefslogtreecommitdiffstats
path: root/main/monit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-11-01 15:01:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-11-01 15:06:39 +0000
commit987ee2addca17d0a61f3117b6f1022be986f8e11 (patch)
treea7ae236d281d7ba28d4b5c7b7fea915ad5fc8f72 /main/monit
parent60cb09fe2b8fe9269ece2fbf48de6be0d14a0dd7 (diff)
downloadaports-987ee2addca17d0a61f3117b6f1022be986f8e11.tar.bz2
aports-987ee2addca17d0a61f3117b6f1022be986f8e11.tar.xz
main/monit: don't give @users read access by default
Diffstat (limited to 'main/monit')
-rw-r--r--main/monit/APKBUILD6
-rw-r--r--main/monit/monitrc80
2 files changed, 43 insertions, 43 deletions
diff --git a/main/monit/APKBUILD b/main/monit/APKBUILD
index c22cd8f63..efa81944d 100644
--- a/main/monit/APKBUILD
+++ b/main/monit/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=monit
pkgver=5.6
-pkgrel=0
+pkgrel=1
pkgdesc="Managing and monitoring on a UNIX system"
url="http://mmonit.com/monit/"
arch="all"
@@ -14,7 +14,7 @@ install=""
subpackages="$pkgname-doc"
source="http://mmonit.com/monit/dist/monit-$pkgver.tar.gz
$pkgname.initd"
-
+
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
diff --git a/main/monit/monitrc b/main/monit/monitrc
index d454d9bea..816ff0769 100644
--- a/main/monit/monitrc
+++ b/main/monit/monitrc
@@ -5,8 +5,8 @@
## Comments begin with a '#' and extend through the end of the line. Keywords
## are case insensitive. All path's MUST BE FULLY QUALIFIED, starting with '/'.
##
-## Below you will find examples of some frequently used statements. For
-## information about the control file and a complete list of statements and
+## Below you will find examples of some frequently used statements. For
+## information about the control file and a complete list of statements and
## options, please have a look in the Monit manual.
##
##
@@ -17,19 +17,19 @@
## Start Monit in the background (run as a daemon):
#
set daemon 60 # check services at 1-minute intervals
-# with start delay 240 # optional: delay the first check by 4-minutes (by
+# with start delay 240 # optional: delay the first check by 4-minutes (by
# # default Monit check immediately after Monit start)
#
#
## Set syslog logging with the 'daemon' facility. If the FACILITY option is
-## omitted, Monit will use 'user' facility by default. If you want to log to
+## omitted, Monit will use 'user' facility by default. If you want to log to
## a standalone log file instead, specify the full path to the log file
#
-# set logfile syslog facility log_daemon
+# set logfile syslog facility log_daemon
#
#
## Set the location of the Monit id file which stores the unique id for the
-## Monit instance. The id is generated and stored on first Monit start. By
+## Monit instance. The id is generated and stored on first Monit start. By
## default the file is placed in $HOME/.monit.id.
#
# set idfile /var/.monit.id
@@ -42,9 +42,9 @@ set daemon 60 # check services at 1-minute intervals
#
# set statefile /var/.monit.state
#
-## Set the list of mail servers for alert delivery. Multiple servers may be
-## specified using a comma separator. If the first mail server fails, Monit
-# will use the second mail server in the list and so on. By default Monit uses
+## Set the list of mail servers for alert delivery. Multiple servers may be
+## specified using a comma separator. If the first mail server fails, Monit
+# will use the second mail server in the list and so on. By default Monit uses
# port 25 - it is possible to override this with the PORT option.
#
# set mailserver mail.bar.baz, # primary mailserver
@@ -52,11 +52,11 @@ set daemon 60 # check services at 1-minute intervals
# localhost # fallback relay
#
#
-## By default Monit will drop alert events if no mail servers are available.
-## If you want to keep the alerts for later delivery retry, you can use the
-## EVENTQUEUE statement. The base directory where undelivered alerts will be
+## By default Monit will drop alert events if no mail servers are available.
+## If you want to keep the alerts for later delivery retry, you can use the
+## EVENTQUEUE statement. The base directory where undelivered alerts will be
## stored is specified by the BASEDIR option. You can limit the maximal queue
-## size using the SLOTS option (if omitted, the queue is limited by space
+## size using the SLOTS option (if omitted, the queue is limited by space
## available in the back end filesystem).
#
# set eventqueue
@@ -64,11 +64,11 @@ set daemon 60 # check services at 1-minute intervals
# slots 100 # optionally limit the queue size
#
#
-## Send status and events to M/Monit (for more informations about M/Monit
-## see http://mmonit.com/). By default Monit registers credentials with
+## Send status and events to M/Monit (for more informations about M/Monit
+## see http://mmonit.com/). By default Monit registers credentials with
## M/Monit so M/Monit can smoothly communicate back to Monit and you don't
## have to register Monit credentials manually in M/Monit. It is possible to
-## disable credential registration using the commented out option below.
+## disable credential registration using the commented out option below.
## Though, if safety is a concern we recommend instead using https when
## communicating with M/Monit and send credentials encrypted.
#
@@ -100,25 +100,25 @@ set daemon 60 # check services at 1-minute intervals
# set mail-format { from: monit@foo.bar }
#
#
-## You can set alert recipients whom will receive alerts if/when a
-## service defined in this file has errors. Alerts may be restricted on
-## events by using a filter as in the second example below.
+## You can set alert recipients whom will receive alerts if/when a
+## service defined in this file has errors. Alerts may be restricted on
+## events by using a filter as in the second example below.
#
# set alert sysadm@foo.bar # receive all alerts
## Do not alert when Monit start,stop or perform a user initiated action
-# set alert manager@foo.bar not on { instance, action }
+# set alert manager@foo.bar not on { instance, action }
#
#
-## Monit has an embedded web server which can be used to view status of
+## Monit has an embedded web server which can be used to view status of
## services monitored and manage services from a web interface. See the
-## Monit Wiki if you want to enable SSL for the web server.
+## Monit Wiki if you want to enable SSL for the web server.
#
set httpd port 2812 and
use address localhost # only accept connection from localhost
allow localhost # allow localhost to connect to the server and
allow admin:monit # require user 'admin' with password 'monit'
# allow @monit # allow users of group 'monit' to connect (rw)
- allow @users readonly # allow users of group 'users' to connect readonly
+# allow @users readonly # allow users of group 'users' to connect readonly
###############################################################################
## Services
@@ -137,15 +137,15 @@ set httpd port 2812 and
# if cpu usage (system) > 30% then alert
# if cpu usage (wait) > 20% then alert
#
-#
+#
## Check if a file exists, checksum, permissions, uid and gid. In addition
-## to alert recipients in the global section, customized alert can be sent to
-## additional recipients by specifying a local alert handler. The service may
+## to alert recipients in the global section, customized alert can be sent to
+## additional recipients by specifying a local alert handler. The service may
## be grouped using the GROUP option. More than one group can be specified by
## repeating the 'group name' statement.
-#
+#
# check file apache_bin with path /usr/local/apache/bin/httpd
-# if failed checksum and
+# if failed checksum and
# expect the sum 8f7f419955cefa0b33a2ba316cba3659 then unmonitor
# if failed permission 755 then unmonitor
# if failed uid root then unmonitor
@@ -155,15 +155,15 @@ set httpd port 2812 and
# } with the mail-format { subject: Alarm! }
# group server
#
-#
+#
## Check that a process is running, in this case Apache, and that it respond
## to HTTP and HTTPS requests. Check its resource usage such as cpu and memory,
-## and number of children. If the process is not running, Monit will restart
-## it by default. In case the service is restarted very often and the
+## and number of children. If the process is not running, Monit will restart
+## it by default. In case the service is restarted very often and the
## problem remains, it is possible to disable monitoring using the TIMEOUT
## statement. This service depends on another service (apache_bin) which
## is defined above.
-#
+#
# check process apache with pidfile /usr/local/apache/logs/httpd.pid
# start program = "/etc/init.d/httpd start" with timeout 60 seconds
# stop program = "/etc/init.d/httpd stop"
@@ -172,7 +172,7 @@ set httpd port 2812 and
# if totalmem > 200.0 MB for 5 cycles then restart
# if children > 250 then restart
# if loadavg(5min) greater than 10 for 8 cycles then stop
-# if failed host www.tildeslash.com port 80 protocol http
+# if failed host www.tildeslash.com port 80 protocol http
# and request "/somefile.html"
# then restart
# if failed port 443 type tcpssl protocol http
@@ -181,8 +181,8 @@ set httpd port 2812 and
# if 3 restarts within 5 cycles then timeout
# depends on apache_bin
# group server
-#
-#
+#
+#
## Check filesystem permissions, uid, gid, space and inode usage. Other services,
## such as databases, may depend on this resource and an automatically graceful
## stop may be cascaded to them before the filesystem will become full and data
@@ -201,7 +201,7 @@ set httpd port 2812 and
# group server
#
#
-## Check a file's timestamp. In this example, we test if a file is older
+## Check a file's timestamp. In this example, we test if a file is older
## than 15 minutes and assume something is wrong if its not updated. Also,
## if the file size exceed a given limit, execute a script
#
@@ -213,8 +213,8 @@ set httpd port 2812 and
# if size > 100 MB then exec "/my/cleanup/script" as uid dba and gid dba
#
#
-## Check directory permission, uid and gid. An event is triggered if the
-## directory does not belong to the user with uid 0 and gid 0. In addition,
+## Check directory permission, uid and gid. An event is triggered if the
+## directory does not belong to the user with uid 0 and gid 0. In addition,
## the permissions have to match the octal description of 755 (see chmod(1)).
#
# check directory bin with path /bin
@@ -223,8 +223,8 @@ set httpd port 2812 and
# if failed gid 0 then unmonitor
#
#
-## Check a remote host availability by issuing a ping test and check the
-## content of a response from a web server. Up to three pings are sent and
+## Check a remote host availability by issuing a ping test and check the
+## content of a response from a web server. Up to three pings are sent and
## connection to a port and an application level network check is performed.
#
# check host myserver with address 192.168.1.1