summaryrefslogtreecommitdiffstats
path: root/main/monit
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-11-01 13:55:37 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2013-11-01 13:55:42 +0000
commitb20d58f4e643d155ed97a164ecc89b56444c9a8f (patch)
tree492f0e733123ebd09cb83c1273e0c2984281ea4c /main/monit
parent7467d292063c766cc80129520e9ca22c9c096705 (diff)
downloadaports-b20d58f4e643d155ed97a164ecc89b56444c9a8f.tar.bz2
aports-b20d58f4e643d155ed97a164ecc89b56444c9a8f.tar.xz
main/monit: move to main and add monitrc
Diffstat (limited to 'main/monit')
-rw-r--r--main/monit/APKBUILD60
-rw-r--r--main/monit/monit.initd39
-rw-r--r--main/monit/monitrc246
3 files changed, 345 insertions, 0 deletions
diff --git a/main/monit/APKBUILD b/main/monit/APKBUILD
new file mode 100644
index 000000000..c22cd8f63
--- /dev/null
+++ b/main/monit/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=monit
+pkgver=5.6
+pkgrel=0
+pkgdesc="Managing and monitoring on a UNIX system"
+url="http://mmonit.com/monit/"
+arch="all"
+license="AGPL"
+depends=""
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://mmonit.com/monit/dist/monit-$pkgver.tar.gz
+ $pkgname.initd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --without-pam \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm 755 "$srcdir"/$pkgname.initd \
+ "$pkgdir"/etc/init.d/$pkgname || return 1
+ install -Dm 644 "$_builddir"/monitrc \
+ "$pkgdir"/etc/monitrc
+ sed -i '/allow @monit/s/^/#/' \
+ "$pkgdir"/etc/monitrc || return 1
+ sed -i '/allow @users readonly/s/^/#/' \
+ "$pkgdir"/etc/monitrc || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="19dfc1ce8512e832134d06eedd96ba50 monit-5.6.tar.gz
+c3162a769081f3759e3fae2a672a8a61 monit.initd"
+sha256sums="38e09bd8b39abc59e6b9a9bb7a78f7eac2b02a92f4de1f3a6dc24e84dfedae0d monit-5.6.tar.gz
+78c013bb1258895a262c670a730e1319ea0f1140bbc3ca2f8dfc85ec02f923a1 monit.initd"
+sha512sums="36933b6560860eac39421a56726c8748e2ce0f16ee51149828e6ffcb77edf3ce73394c2b58e208f6614712e7c6e0e114bc92e911794503b89793b225199193b8 monit-5.6.tar.gz
+20fb54b251fd97e8014a35940a8cab1ca0de4c1ec3bcc05d2a9091585187759c1ce77cd5f872dde01fa91118d61e9ed3ec0650d09d7e767e78b42c68c1d35b64 monit.initd"
diff --git a/main/monit/monit.initd b/main/monit/monit.initd
new file mode 100644
index 000000000..4163c988b
--- /dev/null
+++ b/main/monit/monit.initd
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-admin/monit/files/monit.initd-5.0-r1,v 1.2 2011/12/31 16:28:50 idl0r Exp $
+
+extra_commands="configtest"
+extra_started_commands="reload"
+
+depend() {
+ use net
+}
+
+configtest() {
+ /usr/bin/monit -t 1>/dev/null 2>&1
+ ret=$?
+ if [ $ret -ne 0 ]; then
+ eerror "${SVCNAME} has detected an error in your setup:"
+ /usr/bin/monit -t
+ fi
+ return $ret
+}
+
+start() {
+ ebegin "Starting monit"
+ start-stop-daemon --start --quiet --exec /usr/bin/monit >/dev/null 2>&1
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping monit"
+ start-stop-daemon --stop --quiet --exec /usr/bin/monit
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading monit"
+ /usr/bin/monit -c /etc/monitrc reload >/dev/null 2>&1
+ eend $?
+}
diff --git a/main/monit/monitrc b/main/monit/monitrc
new file mode 100644
index 000000000..d454d9bea
--- /dev/null
+++ b/main/monit/monitrc
@@ -0,0 +1,246 @@
+###############################################################################
+## Monit control file
+###############################################################################
+##
+## Comments begin with a '#' and extend through the end of the line. Keywords
+## are case insensitive. All path's MUST BE FULLY QUALIFIED, starting with '/'.
+##
+## Below you will find examples of some frequently used statements. For
+## information about the control file and a complete list of statements and
+## options, please have a look in the Monit manual.
+##
+##
+###############################################################################
+## Global section
+###############################################################################
+##
+## Start Monit in the background (run as a daemon):
+#
+set daemon 60 # check services at 1-minute intervals
+# with start delay 240 # optional: delay the first check by 4-minutes (by
+# # default Monit check immediately after Monit start)
+#
+#
+## Set syslog logging with the 'daemon' facility. If the FACILITY option is
+## omitted, Monit will use 'user' facility by default. If you want to log to
+## a standalone log file instead, specify the full path to the log file
+#
+# set logfile syslog facility log_daemon
+#
+#
+## Set the location of the Monit id file which stores the unique id for the
+## Monit instance. The id is generated and stored on first Monit start. By
+## default the file is placed in $HOME/.monit.id.
+#
+# set idfile /var/.monit.id
+#
+## Set the location of the Monit state file which saves monitoring states
+## on each cycle. By default the file is placed in $HOME/.monit.state. If
+## the state file is stored on a persistent filesystem, Monit will recover
+## the monitoring state across reboots. If it is on temporary filesystem, the
+## state will be lost on reboot which may be convenient in some situations.
+#
+# set statefile /var/.monit.state
+#
+## Set the list of mail servers for alert delivery. Multiple servers may be
+## specified using a comma separator. If the first mail server fails, Monit
+# will use the second mail server in the list and so on. By default Monit uses
+# port 25 - it is possible to override this with the PORT option.
+#
+# set mailserver mail.bar.baz, # primary mailserver
+# backup.bar.baz port 10025, # backup mailserver on port 10025
+# localhost # fallback relay
+#
+#
+## By default Monit will drop alert events if no mail servers are available.
+## If you want to keep the alerts for later delivery retry, you can use the
+## EVENTQUEUE statement. The base directory where undelivered alerts will be
+## stored is specified by the BASEDIR option. You can limit the maximal queue
+## size using the SLOTS option (if omitted, the queue is limited by space
+## available in the back end filesystem).
+#
+# set eventqueue
+# basedir /var/monit # set the base directory where events will be stored
+# slots 100 # optionally limit the queue size
+#
+#
+## Send status and events to M/Monit (for more informations about M/Monit
+## see http://mmonit.com/). By default Monit registers credentials with
+## M/Monit so M/Monit can smoothly communicate back to Monit and you don't
+## have to register Monit credentials manually in M/Monit. It is possible to
+## disable credential registration using the commented out option below.
+## Though, if safety is a concern we recommend instead using https when
+## communicating with M/Monit and send credentials encrypted.
+#
+# set mmonit http://monit:monit@192.168.1.10:8080/collector
+# # and register without credentials # Don't register credentials
+#
+#
+## Monit by default uses the following format for alerts if the the mail-format
+## statement is missing::
+## --8<--
+## set mail-format {
+## from: monit@$HOST
+## subject: monit alert -- $EVENT $SERVICE
+## message: $EVENT Service $SERVICE
+## Date: $DATE
+## Action: $ACTION
+## Host: $HOST
+## Description: $DESCRIPTION
+##
+## Your faithful employee,
+## Monit
+## }
+## --8<--
+##
+## You can override this message format or parts of it, such as subject
+## or sender using the MAIL-FORMAT statement. Macros such as $DATE, etc.
+## are expanded at runtime. For example, to override the sender, use:
+#
+# set mail-format { from: monit@foo.bar }
+#
+#
+## You can set alert recipients whom will receive alerts if/when a
+## service defined in this file has errors. Alerts may be restricted on
+## events by using a filter as in the second example below.
+#
+# set alert sysadm@foo.bar # receive all alerts
+## Do not alert when Monit start,stop or perform a user initiated action
+# set alert manager@foo.bar not on { instance, action }
+#
+#
+## Monit has an embedded web server which can be used to view status of
+## services monitored and manage services from a web interface. See the
+## Monit Wiki if you want to enable SSL for the web server.
+#
+set httpd port 2812 and
+ use address localhost # only accept connection from localhost
+ allow localhost # allow localhost to connect to the server and
+ allow admin:monit # require user 'admin' with password 'monit'
+# allow @monit # allow users of group 'monit' to connect (rw)
+ allow @users readonly # allow users of group 'users' to connect readonly
+
+###############################################################################
+## Services
+###############################################################################
+##
+## Check general system resources such as load average, cpu and memory
+## usage. Each test specifies a resource, conditions and the action to be
+## performed should a test fail.
+#
+# check system myhost.mydomain.tld
+# if loadavg (1min) > 4 then alert
+# if loadavg (5min) > 2 then alert
+# if memory usage > 75% then alert
+# if swap usage > 25% then alert
+# if cpu usage (user) > 70% then alert
+# if cpu usage (system) > 30% then alert
+# if cpu usage (wait) > 20% then alert
+#
+#
+## Check if a file exists, checksum, permissions, uid and gid. In addition
+## to alert recipients in the global section, customized alert can be sent to
+## additional recipients by specifying a local alert handler. The service may
+## be grouped using the GROUP option. More than one group can be specified by
+## repeating the 'group name' statement.
+#
+# check file apache_bin with path /usr/local/apache/bin/httpd
+# if failed checksum and
+# expect the sum 8f7f419955cefa0b33a2ba316cba3659 then unmonitor
+# if failed permission 755 then unmonitor
+# if failed uid root then unmonitor
+# if failed gid root then unmonitor
+# alert security@foo.bar on {
+# checksum, permission, uid, gid, unmonitor
+# } with the mail-format { subject: Alarm! }
+# group server
+#
+#
+## Check that a process is running, in this case Apache, and that it respond
+## to HTTP and HTTPS requests. Check its resource usage such as cpu and memory,
+## and number of children. If the process is not running, Monit will restart
+## it by default. In case the service is restarted very often and the
+## problem remains, it is possible to disable monitoring using the TIMEOUT
+## statement. This service depends on another service (apache_bin) which
+## is defined above.
+#
+# check process apache with pidfile /usr/local/apache/logs/httpd.pid
+# start program = "/etc/init.d/httpd start" with timeout 60 seconds
+# stop program = "/etc/init.d/httpd stop"
+# if cpu > 60% for 2 cycles then alert
+# if cpu > 80% for 5 cycles then restart
+# if totalmem > 200.0 MB for 5 cycles then restart
+# if children > 250 then restart
+# if loadavg(5min) greater than 10 for 8 cycles then stop
+# if failed host www.tildeslash.com port 80 protocol http
+# and request "/somefile.html"
+# then restart
+# if failed port 443 type tcpssl protocol http
+# with timeout 15 seconds
+# then restart
+# if 3 restarts within 5 cycles then timeout
+# depends on apache_bin
+# group server
+#
+#
+## Check filesystem permissions, uid, gid, space and inode usage. Other services,
+## such as databases, may depend on this resource and an automatically graceful
+## stop may be cascaded to them before the filesystem will become full and data
+## lost.
+#
+# check filesystem datafs with path /dev/sdb1
+# start program = "/bin/mount /data"
+# stop program = "/bin/umount /data"
+# if failed permission 660 then unmonitor
+# if failed uid root then unmonitor
+# if failed gid disk then unmonitor
+# if space usage > 80% for 5 times within 15 cycles then alert
+# if space usage > 99% then stop
+# if inode usage > 30000 then alert
+# if inode usage > 99% then stop
+# group server
+#
+#
+## Check a file's timestamp. In this example, we test if a file is older
+## than 15 minutes and assume something is wrong if its not updated. Also,
+## if the file size exceed a given limit, execute a script
+#
+# check file database with path /data/mydatabase.db
+# if failed permission 700 then alert
+# if failed uid data then alert
+# if failed gid data then alert
+# if timestamp > 15 minutes then alert
+# if size > 100 MB then exec "/my/cleanup/script" as uid dba and gid dba
+#
+#
+## Check directory permission, uid and gid. An event is triggered if the
+## directory does not belong to the user with uid 0 and gid 0. In addition,
+## the permissions have to match the octal description of 755 (see chmod(1)).
+#
+# check directory bin with path /bin
+# if failed permission 755 then unmonitor
+# if failed uid 0 then unmonitor
+# if failed gid 0 then unmonitor
+#
+#
+## Check a remote host availability by issuing a ping test and check the
+## content of a response from a web server. Up to three pings are sent and
+## connection to a port and an application level network check is performed.
+#
+# check host myserver with address 192.168.1.1
+# if failed icmp type echo count 3 with timeout 3 seconds then alert
+# if failed port 3306 protocol mysql with timeout 15 seconds then alert
+# if failed url http://user:password@www.foo.bar:8080/?querystring
+# and content == 'action="j_security_check"'
+# then alert
+#
+#
+###############################################################################
+## Includes
+###############################################################################
+##
+## It is possible to include additional configuration parts from other files or
+## directories.
+#
+# include /etc/monit.d/*
+#