summaryrefslogtreecommitdiffstats
path: root/main/mp3splt-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-04-26 07:36:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-04-26 07:38:14 +0000
commit3483d380a358910fd1e392d72109dc9c2780a224 (patch)
tree01b550c8d7938b38b1328b74635420a44f8cbac7 /main/mp3splt-gtk
parentec170d21e18b1059951c464137de25a2aca12caf (diff)
downloadaports-3483d380a358910fd1e392d72109dc9c2780a224.tar.bz2
aports-3483d380a358910fd1e392d72109dc9c2780a224.tar.xz
main/mp3splt-gtk: upgrade to 0.8.2
Diffstat (limited to 'main/mp3splt-gtk')
-rw-r--r--main/mp3splt-gtk/APKBUILD17
-rw-r--r--main/mp3splt-gtk/dbus-glib-underlinking.patch27
2 files changed, 6 insertions, 38 deletions
diff --git a/main/mp3splt-gtk/APKBUILD b/main/mp3splt-gtk/APKBUILD
index 5f55a0873..ceeff7141 100644
--- a/main/mp3splt-gtk/APKBUILD
+++ b/main/mp3splt-gtk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mp3splt-gtk
-pkgver=0.8.1
+pkgver=0.8.2
pkgrel=0
pkgdesc="Gtk frontend for mp3splt"
url="http://mp3splt.sourceforge.net/"
@@ -13,8 +13,7 @@ makedepends="gtk+3.0-dev gst-plugins-base-dev gnome-doc-utils libmp3splt-dev
autoconf automake libtool"
install=""
subpackages="$pkgname-doc $pkgname-lang"
-source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-gtk-$pkgver.tar.gz
- dbus-glib-underlinking.patch"
+source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-gtk-$pkgver.tar.gz"
_builddir="$srcdir"/mp3splt-gtk-$pkgver
prepare() {
@@ -25,8 +24,6 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- libtoolize --force && aclocal -I m4 && autoconf \
- && automake --add-missing
}
build() {
@@ -34,6 +31,7 @@ build() {
./configure --prefix=/usr \
--disable-gnome \
|| return 1
+ sed -i -e 's/-DGTK_DISABLE_DEPRECATED//' Makefile src/Makefile
make || return 1
}
@@ -43,9 +41,6 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="69cdc6344f45091e06ab4e3f3454a9f0 mp3splt-gtk-0.8.1.tar.gz
-9531efb02e98624356bda87c92be7cce dbus-glib-underlinking.patch"
-sha256sums="d0bfd6524bd29e061c9d00574c164ed70a112eec11f36ae8a240606c712f1241 mp3splt-gtk-0.8.1.tar.gz
-3f69ef630140230aec15c240a5b19b455a38334e58a98498066011483f75846d dbus-glib-underlinking.patch"
-sha512sums="ab4cd6bb9d790d4828ff480897ce1c8dd584bbe6bea0819dc5c5ec5f6409508d28cc7db0ece23a3239383734515ded1c35526322bb7d387e4ca7c14a896888ba mp3splt-gtk-0.8.1.tar.gz
-f209a5cfcb108f6207cb5e2a2f1baa19673609d419e6408c216ffbebb70ecb6c09b3d612bf5c460b83c0d701056d234c1616ac87011f7f11061aa38d633443f1 dbus-glib-underlinking.patch"
+md5sums="0484828f1c75a9be80788c84592640f0 mp3splt-gtk-0.8.2.tar.gz"
+sha256sums="5634d0a6d15f73affc361c49cafb96a5e53fa2e65a6d7723e74a3a79d3f27c88 mp3splt-gtk-0.8.2.tar.gz"
+sha512sums="9179b78deb7b6e227d0c8b5a1e1bdc6a60b26caf876ec45080e96a63d08098674701e7cb7c3755bb4a99bba3cb994b1594047e351b321d24891fa80a8551cef6 mp3splt-gtk-0.8.2.tar.gz"
diff --git a/main/mp3splt-gtk/dbus-glib-underlinking.patch b/main/mp3splt-gtk/dbus-glib-underlinking.patch
deleted file mode 100644
index 87623236e..000000000
--- a/main/mp3splt-gtk/dbus-glib-underlinking.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index bddace0..b4bb928 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -121,6 +121,9 @@ AC_MSG_RESULT($HOST)
- #check for -lm
- AC_CHECK_LIB(m, pow, [ haslm="yes" ] , [ AC_MSG_ERROR([libm not found !]) ] )
-
-+# check for dbus-glib
-+PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1)
-+
- #################################################
- # Initialize the gnome integration
- #################################################
-diff --git a/src/Makefile.am b/src/Makefile.am
-index fce2976..6e80355 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -48,7 +48,7 @@ mp3splt_gtk_SOURCES = \
-
- INCLUDES = @GTK_CFLAGS@ @MP3SPLT_CFLAGS@
-
--mp3splt_gtk_LDADD = @GTK_LIBS@ -lgthread-2.0 @MP3SPLT_LIBS@ -lm
-+mp3splt_gtk_LDADD = @GTK_LIBS@ -lgthread-2.0 @MP3SPLT_LIBS@ @DBUS_GLIB_LIBS@ -lm
-
- # Define a C macro LOCALEDIR indicating where catalogs will be installed.
- localedir = $(datadir)/locale