summaryrefslogtreecommitdiffstats
path: root/main/mplayer
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-23 18:59:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-23 18:59:43 +0000
commit4b8bd5f51b7ce3ea2e4135f2a503bef59f88bc59 (patch)
treed995d8cc8a19fa76c6806e8fe942ecd33bc4699a /main/mplayer
parent902506a11ebf6c53ac947f0ef86efc9aa4cc16a2 (diff)
downloadaports-4b8bd5f51b7ce3ea2e4135f2a503bef59f88bc59.tar.bz2
aports-4b8bd5f51b7ce3ea2e4135f2a503bef59f88bc59.tar.xz
main/mplayer: fix compilation against recent live-media
Diffstat (limited to 'main/mplayer')
-rw-r--r--main/mplayer/APKBUILD6
-rw-r--r--main/mplayer/live555.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/main/mplayer/APKBUILD b/main/mplayer/APKBUILD
index fb5f28bfa..a9a46a078 100644
--- a/main/mplayer/APKBUILD
+++ b/main/mplayer/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mplayer
pkgver=1.0_rc4
_ver=${pkgver%_*}${pkgver#*_}
-pkgrel=8
+pkgrel=9
pkgdesc="A movie player for linux"
url="http://www.mplayerhq.hu/"
arch="all"
@@ -18,6 +18,7 @@ source="http://www.mplayerhq.hu/MPlayer/releases/MPlayer-$_ver.tar.bz2
mplayer-gcc-4.6-audio-fix.patch
mplayer-libpng-1.5.patch
x11-libs.patch
+ live555.patch
"
_builddir="$srcdir"/MPlayer-$_ver
prepare() {
@@ -79,4 +80,5 @@ package() {
md5sums="1699c94de39da9c4c5d34e8f58e418f0 MPlayer-1.0rc4.tar.bz2
5f261813c5dfa70ba2378c2535428e5d mplayer-gcc-4.6-audio-fix.patch
f3f3bae09f6cee684ced1dbc7d7ed23c mplayer-libpng-1.5.patch
-01bcc935a6b429347e8e77e1a70bf2b2 x11-libs.patch"
+01bcc935a6b429347e8e77e1a70bf2b2 x11-libs.patch
+d194e74e35d5bfb460e1ecba0d976cc3 live555.patch"
diff --git a/main/mplayer/live555.patch b/main/mplayer/live555.patch
new file mode 100644
index 000000000..504185c03
--- /dev/null
+++ b/main/mplayer/live555.patch
@@ -0,0 +1,13 @@
+diff -Naur mplayer-export-2012-03-02.orig/libmpdemux/demux_rtp.cpp mplayer-export-2012-03-02/libmpdemux/demux_rtp.cpp
+--- mplayer-export-2012-03-02.orig/libmpdemux/demux_rtp.cpp 2011-10-26 11:12:25.000000000 -0400
++++ mplayer-export-2012-03-02/libmpdemux/demux_rtp.cpp 2012-03-04 11:53:30.000000000 -0500
+@@ -19,6 +19,8 @@
+ * 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+ */
+
++#define RTSPCLIENT_SYNCHRONOUS_INTERFACE 1
++
+ extern "C" {
+ // on MinGW, we must include windows.h before the things it conflicts
+ #ifdef __MINGW32__ // with. they are each protected from
+