summaryrefslogtreecommitdiffstats
path: root/main/mplayer
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-13 11:00:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-13 11:06:34 +0000
commit5c9e8564ce71a8b229e70b4d54d748bfc7345fb1 (patch)
tree443c674d6c783b25aff4806e02b95324ff3e55cf /main/mplayer
parentba719d421f2dc6f0588402e6375e4bca34d3daa2 (diff)
downloadaports-5c9e8564ce71a8b229e70b4d54d748bfc7345fb1.tar.bz2
aports-5c9e8564ce71a8b229e70b4d54d748bfc7345fb1.tar.xz
main/mplayer: fix audio decoding with gcc-4.6
http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2011-May/068495.html and remove unused patch
Diffstat (limited to 'main/mplayer')
-rw-r--r--main/mplayer/APKBUILD4
-rw-r--r--main/mplayer/liba52_gcc_bug.patch10
-rw-r--r--main/mplayer/mplayer-gcc-4.6-audio-fix.patch22
3 files changed, 25 insertions, 11 deletions
diff --git a/main/mplayer/APKBUILD b/main/mplayer/APKBUILD
index c4ed04198..a6c296672 100644
--- a/main/mplayer/APKBUILD
+++ b/main/mplayer/APKBUILD
@@ -2,7 +2,7 @@
pkgname=mplayer
pkgver=1.0_rc4
_ver=${pkgver%_*}${pkgver#*_}
-pkgrel=5
+pkgrel=6
pkgdesc="A movie player for linux"
url="http://www.mplayerhq.hu/"
arch="all"
@@ -15,6 +15,7 @@ makedepends="libxxf86dga-dev libxv-dev libmad-dev lame-dev libao-dev
mesa-dev"
source="http://www.mplayerhq.hu/MPlayer/releases/MPlayer-$_ver.tar.bz2
+ mplayer-gcc-4.6-audio-fix.patch
mplayer-libpng-1.5.patch
"
_builddir="$srcdir"/MPlayer-$_ver
@@ -75,4 +76,5 @@ package() {
rm -rf "$pkgdir"/usr/share/mplayer/font
}
md5sums="1699c94de39da9c4c5d34e8f58e418f0 MPlayer-1.0rc4.tar.bz2
+5f261813c5dfa70ba2378c2535428e5d mplayer-gcc-4.6-audio-fix.patch
f3f3bae09f6cee684ced1dbc7d7ed23c mplayer-libpng-1.5.patch"
diff --git a/main/mplayer/liba52_gcc_bug.patch b/main/mplayer/liba52_gcc_bug.patch
deleted file mode 100644
index c0d42f876..000000000
--- a/main/mplayer/liba52_gcc_bug.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- mplayer/configure.old 2009-04-16 12:02:10.000000000 +0200
-+++ mplayer/configure 2009-05-22 15:23:38.000000000 +0200
-@@ -6410,6 +6410,7 @@
- def_liba52='#undef CONFIG_LIBA52'
- def_liba52_internal="#undef CONFIG_LIBA52_INTERNAL"
- if test "$_liba52_internal" = yes ; then
-+ test "$cc_vendor" = gnu && test "$cc_version" = 4.4.0 && CFLAGS=$(echo $CFLAGS|sed "s/ *-O4 */ -O2 /")
- _liba52=yes
- def_liba52_internal="#define CONFIG_LIBA52_INTERNAL 1"
- _res_comment="internal"
diff --git a/main/mplayer/mplayer-gcc-4.6-audio-fix.patch b/main/mplayer/mplayer-gcc-4.6-audio-fix.patch
new file mode 100644
index 000000000..148856c23
--- /dev/null
+++ b/main/mplayer/mplayer-gcc-4.6-audio-fix.patch
@@ -0,0 +1,22 @@
+Fix broken audio decoding when compiling with gcc-4.6
+http://lists.mplayerhq.hu/pipermail/mplayer-dev-eng/2011-May/068495.html
+
+--- ./mp3lib/dct64_sse.c.orig
++++ ./mp3lib/dct64_sse.c
+@@ -113,7 +113,6 @@
+ }
+
+ {
+- real *costab = costab_mmx + 24;
+ int i;
+
+ __asm__(
+@@ -122,7 +121,7 @@
+ "movaps %1, %%xmm5\n\t"
+ "movaps %%xmm5, %%xmm6\n\t"
+ :
+- :"m"(*costab), "m"(*nnnn)
++ :"m"(costab_mmx[24]), "m"(*nnnn)
+ );
+
+ for (i = 0; i < 0x20; i += 8)