summaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-06-17 15:35:39 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2014-06-17 15:39:04 +0200
commitab9a249a661a8d3f61c430baf615d58a681933cd (patch)
tree1cad79b70695b199665623c0a7ff8e89f86b316c /main/musl
parent5d8cf242ec970e64a2b0c45b2376c66218ce8480 (diff)
downloadaports-ab9a249a661a8d3f61c430baf615d58a681933cd.tar.bz2
aports-ab9a249a661a8d3f61c430baf615d58a681933cd.tar.xz
main/musl: remove post-install and use only post-upgrade
The problem is that /bin/sh depends on bash which depends on musl so we get a circular dependency. To solve it we simply remove the post-install. The problem it is supposed to fix is very unlikely to happen on new installs and if it does, it will be resolved with next upgrade.
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/APKBUILD4
-rw-r--r--main/musl/musl.post-install6
-rw-r--r--[l---------]main/musl/musl.post-upgrade7
3 files changed, 8 insertions, 9 deletions
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 73492167a..b0974483f 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -10,7 +10,7 @@ license="MIT"
depends=""
depends_dev="!uclibc-dev"
makedepends="$depends_dev"
-install="$pkgname.post-install $pkgname.post-upgrade"
+install="$pkgname.post-upgrade"
subpackages="$pkgname-dev $pkgname-utils"
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0001-v1.1.2-to-66fcde4a.patch
diff --git a/main/musl/musl.post-install b/main/musl/musl.post-install
deleted file mode 100644
index 9a86fd073..000000000
--- a/main/musl/musl.post-install
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-if ! [ -e /etc/localtime ] && [ -e /etc/zoneinfo/localtime ]; then
- mv /etc/zoneinfo/localtime /etc/localtime
-fi
-
diff --git a/main/musl/musl.post-upgrade b/main/musl/musl.post-upgrade
index aae353b17..9a86fd073 120000..100644
--- a/main/musl/musl.post-upgrade
+++ b/main/musl/musl.post-upgrade
@@ -1 +1,6 @@
-musl.post-install \ No newline at end of file
+#!/bin/sh
+
+if ! [ -e /etc/localtime ] && [ -e /etc/zoneinfo/localtime ]; then
+ mv /etc/zoneinfo/localtime /etc/localtime
+fi
+